Author Topic: Problem with wifi control  (Read 7251 times)

0 Members and 2 Guests are viewing this topic.

REDACTED

  • Guest
Problem with wifi control
« on: March 05, 2015, 02:17:19 PM »
I have Nexus 4 running OTC Android 5.0.1. Like the idea and the implementation of Battery Saver. Downloaded and left all the default settings. After less than 24hrs, noticed that Wifi was off and on checking further found that it was stuck in 'turning wifi on'. Only way to restore wifi was to re-boot.

This is similar to problem which caused me to remove Juice Defender once my phone was upgraded to KitKat (I think that's when it broke).

Offline Ondra Cermak

  • AMS
  • Avast team
  • Full Member
  • *
  • Posts: 181
Re: Problem with wifi control
« Reply #1 on: March 07, 2015, 05:57:02 PM »
Hi dgm64, this is a known bug on Nexus 4 and also some other phones. It's a bug in the phone's software, which causes the wifi to get stuck. Unfortunately right now we don't know what to do with it from our side :(

Ondra

Offline Martin Popelka

  • Newbie
  • *
  • Posts: 1
Re: Problem with wifi control
« Reply #2 on: April 09, 2015, 05:44:02 PM »
Hello,
I am actually experiencing the same problem on two devices.
1.  Nexus 4 running latest version of Slimkat (www.slimroms.net).
2. Samsung Galaxy Note 8.0 (GT-N5100) running the non rooted stock ROM.

It is at least not related to Nexus 4 only.


Offline Ondra Cermak

  • AMS
  • Avast team
  • Full Member
  • *
  • Posts: 181
Re: Problem with wifi control
« Reply #3 on: April 10, 2015, 04:36:26 PM »
Here's Android issue for the Nexus 4 problems: https://code.google.com/p/android/issues/detail?id=80028

You can try to check the proposed fix in comment 39 and see if it helps: https://code.google.com/p/android/issues/detail?id=80028#c39

Ondra

REDACTED

  • Guest
Re: Problem with wifi control
« Reply #4 on: August 19, 2015, 10:20:25 AM »
I had the same problem with my Galaxy S3.
I solved it switching OFF Wi-Fi power save option:
Settings -> Connections -> WiFi -> Advanced -> "Keep Wi-Fi on during sleep"
Just set it to "Always".
Looks like Avast and Android can't manage Wi-Fi concurrently.

REDACTED

  • Guest
Re: Problem with wifi control
« Reply #5 on: August 24, 2015, 02:35:28 PM »
Grom2 says it the right way. It isn't a bug of the phone, the problemen didn't occur before I installed ABS. When I use the flight modus and turn on my screen, ABS wants to connect to a wifi network, this is not possible because the flight modus is on. When I turn off the flight modus the wifi controll is already jammed and the only thing I can do is restart my phone. They can't get along. ABS should get the function to turn off all data, not only wifi. Then a don't have to use the flight modus anymore.