Author Topic: an avast/proxomitron question  (Read 2345 times)

0 Members and 1 Guest are viewing this topic.

piydek

  • Guest
an avast/proxomitron question
« on: October 11, 2005, 03:47:07 PM »
hello, this is my first post on these boards.

i have started using avast the other day and so far i like it a lot. i only have one problem/question. i use opera as my browser and i also run proxomitron as my proxy. i have a problem with the web shield in avast, because when i turn on proxy (proxomitron) in opera then web shield doesn't scan anything. but when i turn proxy in opera off, then it scans normally. i've found a line in avast.ini under web scanner section, which says "IgnoreLocalhost=1". is this line related to my problem? i tried changing that value to "0" or deleting that line, but it always restores itself (i've always closed avast previous to changing the line). so...is that the line i should be looking at, or is there some other way in which i can resolve my problem?

thanks!

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1885
    • AVAST Software
Re: an avast/proxomitron question
« Reply #1 on: October 11, 2005, 04:55:35 PM »
Hello, this is my 548th post on these boards.

You can configure WebShield to work with proximotron in several ways. Either you can forward the connections from WebShield to proximotron and configure your browser to use localhost:12080 as a proxy, or you can instruct proximotron to forward the connections to webshield (localhost:12080) - at least I think proximotron has this feature.

You can also edit avast4.ini and add the proximotron main executable to the option OptinProcess, the connection from proximotron would be then scanned automatically.

You can also uncheck the "Ignore local communication" on the general tab of WebShield's configuration and add the port the proximotron is running on into the box "Redirected HTTP ports".

What I would suggest is the search button - since proximotron was discussed on these forums a lot. Going though the FAQ at http://www.avast.com/eng/webshield_issues.html should also be helpfull.

Cheers.
Lukas.

piydek

  • Guest
Re: an avast/proxomitron question
« Reply #2 on: October 11, 2005, 05:10:24 PM »
ok, thanks....