Author Topic: Avast 11.13 Web Shield incompatible with Cisco VPN?  (Read 2825 times)

0 Members and 1 Guest are viewing this topic.

Offline matt.landau

  • Newbie
  • *
  • Posts: 2
Avast 11.13 Web Shield incompatible with Cisco VPN?
« on: June 30, 2016, 05:14:36 PM »
I'm running Avast Mac Security version 11.13 (46580) and Cisco AnyConnect v 4.1.06020, which is required by my company to connect to any internal systems behind the firewall.

I find that when the VPN is active, the Avast Web Shield blocks all HTTP and HTTPS connections.  If I disable Web Shield but leave File System Shield and Mail Shield enabled everything works fine.  As soon as I reenable Web Shield, connections start failing immediately again.  I've tried adding the name and IP address of the proxy that the VPN is using to the Excluded Servers list in the Avast Configuration under both http and https protocols and have made sure that Scan secured connections is un-checked.  None of this helps.

Any idea how to get Avast Web Shield to play nicely with the Cisco VPN, or do I just have to temporary disable Web Shield whenever I'm connected to the VPN for work (which is kind of a pain).

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Avast 11.13 Web Shield incompatible with Cisco VPN?
« Reply #1 on: June 30, 2016, 05:49:17 PM »
What is in the system log file? What is the VPN server address? Without any info it is hard to say anything. Avast used to work with CISCO VPN unless you had installed their bundled security "addware" which came with the installation (but in this case all HTTP/HTTPS connections were broken, not only the VPN connection).