Author Topic: Avast SecureLine not connecting after passing from free test to licensed version  (Read 15717 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
After testing tor three days, I have just bought Securline VPN for one year. The test version worked fine but the regular version doesn't connect.

I made a system restore to last week point. I uninstalled and installed all my  avast! premier produst but without success.

After observing the problem i have seen that when I passed to licensed product the TAP driver (the driver wich is used as a virtual network ethernet adapter to activate the encrypted tunnel for transferring data to remote server (virtual private network connection))  stopped working with a generic and confusing message "Sorry, unable to connect".

I had to work a lot (about two days in my Christmas holydays) for solving the problem manually, but i have not fully understood the problem.

  • First of all, a system restore to a previous good status of Windows O.S. didn't solve;
  • reinstalling of the full Avast Premier antivirus product, didn't solve.
I have definitely seen that the problem is the OpenVPN TAP driver named "avsTap".
I am an informatic professional and web developer but never i worked with virtual vpn network drivers nor vpn software as a developer of code.

I found evidence that it is not possible to uninstal and reinstall correctly the OpenVPN tap driver.
So, naturally, it is not possible to connect without the virtual VPN adapter.

I tried from an elevated (run as administrator) command prompt as follows:

C:\Program Files\AVAST Software\Avast\OpenVPN\driver\win64\ndis6>dir
 Il volume nell'unit√† C non ha etichetta.
 Numero di serie del volume: D2F0-F077

 Directory di C:\Program Files\AVAST Software\Avast\OpenVPN\driver\win64\ndis6

31/12/2014  06:14    <DIR>          .
31/12/2014  06:14    <DIR>          ..
31/12/2014  06:13               126 addtap.bat
31/12/2014  06:13            10.530
31/12/2014  06:13             6.913 aswTap.inf
31/12/2014  06:13            44.640 aswTap.sys
31/12/2014  06:13               154 deltapall.bat
31/12/2014  06:13            88.816 tapinstall.exe
               6 File        151.179 byte
               2 Directory  661.109.903.360 byte disponibili

C:\Program Files\AVAST Software\Avast\OpenVPN\driver\win64\ndis6>type deltapall.bat
echo WARNING: this script will delete ALL TAP virtual adapters (use the device manager to delete adapters one at a time)

i tried to uninstall manually from device manager but the nodes didn't disappear.

"tapinstall.exe" remove aswTap

C:\Program Files\AVAST Software\Avast\OpenVPN\driver\win64\ndis6>tapinstall remove aswTap
ROOT\NET\0000                                               : Remove failed
ROOT\NET\0002                                               : Remove failed
ROOT\NET\0003                                               : Remove failed
No devices were removed.

I found by Google that tapinstall.exe utility is an OpenVPN version of Microsoft devcon.exe utility for
managing device drivers by command line instead of device manager GUI. (I never used devcon.exe
and it's too much complicated install tha original devcon.exe utility for Windows 8.1 because it needs the installation of the complete
visual studio platform for device driver developers.... ).

As you can see i made some tests so you see two nodes ROOT\NET\00n


C:\Program Files\AVAST Software\Avast\OpenVPN\driver\win64\ndis6>tapinstall status *net*
    Name: Shrew Soft Virtual Adapter
    Device is disabled.
    Name: VirtualBox Host-Only Ethernet Adapter
    Driver is running.
    Name: Controller Realtek PCIe GBE Family - VirtualBox Bridged Networking Driver Miniport
    Driver is running.
    Name: Qualcomm Atheros AR9485WB-EG Wireless Network Adapter - VirtualBox Bridged Networking Driver
    Miniport Driver is running.
4 matching device(s) found.

You can see
0000 -    my shrew soft VPN adapter for my work with my company VPN CISCO Gateway
   (i am an IT Manager in ARTEA - Italy).
0001 -    fhe virtualbox network adapter
   (i use virtualbox for tests in different versions of O.S., browser and so on.. for testing of
   web GIS software that i develop)

i can see also the device drivers of my ethernet network adapter and wireless network adapter.

C:\Program Files\AVAST Software\Avast\OpenVPN\driver\win64\ndis6>tapinstall status test
    Device is disabled.
1 matching device(s) found.

this is the node created for test purpouse with:
tapinstall install "awsTap.inf" test

I observed that in device manager, under the node "network adapters" (in italian "schede di rete") there are four entries marked as "unknown device".
Three of the four entries have the same hardware id "awsTap" and the fourth, my test, has the hardware id "test".
None of this entries has a driver correctly installed. I tried to install manually the first entry point to your path C:\Program Files\AVAST Software\Avast\OpenVPN\driver\win64\ndis6.
I obtained the following messages (translated from italian):

There was a problem during instation of the driver for the device.
The device driver was detected but there were an error during installation.
avast! SecureLine TAP Adapter v3
unable to find specified path.

I tried to install awsTap.inf directly by right clicking on the file and selecting "install". I obtained the error "element not found"
I tried a second time and this time the driver was correctly installed. 
As none was changed in the awsTap.inf file I think there is some problem in detecting the path of the awsTap.sys file or some other that i don't know.

Now in device manager i found that all unknown device nodes of class "NET" where installed with Avast! driver !!
(really cute about easy installation!!! ... if you consider that i spent about 60 euro to buy Avast!  SecureLine product).

Now i had to delete from device manager GUI the duplicated awsTap entries, i had to manually install a fake "generic software driver" to the entry "test" and finally i succeded in deleting that entry.

Finally i tested your SecurLine VPN Service and connected correctly!!

I have not really understood while Avast! (or better OpenVPN's) inf file failed.
But now the product works and i cannot spend a life to know all that is knowable about installing a driver and the structure of an inf file.
All is interesting but the life is limited and it's a good thing to study strictly only the necessary things.

If someone can explain i wil be happy..

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7168
  • When you think you know, Think Again
I've read of other accounts of the 'free trial' of Secureline working fine and then when License is purchased, Secureline doesn't connect. Maybe License unable to be recognized and now Trial is over (just a shot in the dark)
Personally,I can't understand what changes in the installation that causes the issue.
In any case, Any technical help may be a little while as Holidays and the weekend will mean Avast team members may not be available.
Good luck.


  • Guest
I am having the exact same issue as well.  The trail worked fine, purchased a month pass license, and will not either connect or I'm thinking it's the file itself that avast! has sent me.  As in, when I go to, "Settings", "Subscription", then scroll down to the SecureLine VPN, I click the where it says, "Already have a license file?  Insert it here.".  I do so, and nothing of any sort happens.  As if, I did not even clicked the file, which I sure did.  I even reinstalled avast! premier, and nothing.

It was the file; all I had to do was to re-download the license file I received from my email.  SecureLine VPN works just fine for me now.
« Last Edit: February 03, 2015, 11:01:47 PM by c.lauth »


  • Guest
I am also having this issue and cannot activate my license.  How do I download the attachment on the email?  I have tried right clicking and save as on desktop but when i go to insert, it is a blank data file.  $110 and I can't use it :/

Offline Davidek

  • Avast team
  • Poster
  • *
  • Posts: 405
Hi all,

Sorry for the late reply.  This has been passed to our Dev team for evaluation.  If anyone could also send a log file that would be great.  You can get that by going to C:, Program Data, Avast Software, Avast, Log.  In the log folder is the secureline.txt file, that is the one to send.

Many thanks,



  • Guest
Hi Davidek
I cannot even save the attachment from the email.  I am starting to think it is because I use Westnet Webmail.  I followed those instructions for txt file but there isn't a txt file.  I have a ticket in but have not heard.  Would uninstalling and re-installing possibly help?


  • Guest
I have the same problem as Emmie but for my desktop  trial was OK then ... bought....paid...downloaded...installed but the prog cant install the license file.
Now it tells me my license is cancelled.     >:(

Submitted a help request...and waiting.    Hohummm....zzzzz

Offline Rednose

  • Pirate Party Member
  • Avast √úberevangelist
  • Massive Poster
  • *****
  • Posts: 3741
  • Bits of Freedom :
    • Nederlandstalig Avast! forum
I have the same problem as Emmie but for my desktop  trial was OK then ... bought....paid...downloaded...installed but the prog cant install the license file.
Now it tells me my license is cancelled.     >:(

Submitted a help request...and waiting.    Hohummm....zzzzz

We are testing now a new upcomming release of Avast! which should fix this

Greetz, Red.
OS: Win 10 / iOS 17 / Debian 12 / Tails 6
Real Time: Avast Premium Security
On Demand: Malwarebytes
VPN: NordVPN ( NordLynx ) with Threat Protection ( Lite )

Offline ZombieZoom

  • Jr. Member
  • **
  • Posts: 34
  • avast! Super Sayajin since 2008
Even after the new update, the problem still exists!