Author Topic: High Disk Usage on startup  (Read 16966 times)

0 Members and 1 Guest are viewing this topic.

Offline karkinissan

  • Newbie
  • *
  • Posts: 11
High Disk Usage on startup
« on: May 23, 2015, 05:30:03 AM »
I use Avast Free Antivirus 2015 and its come to my attention that the software creates a 100% disk usage during startup, which can last upto 10 minutes.
Its been like this for quite a while now. It prevents me from immediately using my laptop once I boot it up, which makes me lose a lot of precious time.
Is there a fix for this? Or should I go ahead and switch to another antivirus?

Im on a windows 8.1 laptop with an intel core i7 4700 MQ CPU. No SSD.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31356
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: High Disk Usage on startup
« Reply #1 on: May 23, 2015, 11:53:23 AM »
What exact version of avast ?
Any other security (related) software installed ? (or did you have)
What process is using a lot of cpu time ? (and what is using the process if it is svchost)

Offline karkinissan

  • Newbie
  • *
  • Posts: 11
Re: High Disk Usage on startup
« Reply #2 on: May 23, 2015, 12:24:45 PM »
What exact version of avast ?
Any other security (related) software installed ? (or did you have)
What process is using a lot of cpu time ? (and what is using the process if it is svchost)

Sorry for not including all that earlier.
The version is 2015.10.2.2218
I have Malwarebytes Anti-malware installed. But it is always disabled unless i manually open it.
The "Avast! Service" is what takes up the highest disk usage. (see attachment)
If its not Avast thats taking up the disk usage, then it'll be netsvcs svchost. Its mostly avast though.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31356
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: High Disk Usage on startup
« Reply #3 on: May 23, 2015, 12:41:16 PM »
Is the NG component of avast enabled ?
If so, disable it and reboot.
See if there is a difference or not.

Offline karkinissan

  • Newbie
  • *
  • Posts: 11
Re: High Disk Usage on startup
« Reply #4 on: May 23, 2015, 12:53:36 PM »
I opted out of installing NG during the installation process. No idea if any automatic software updates reinstalled them though. How do I check if its installed?

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31356
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: High Disk Usage on startup
« Reply #5 on: May 23, 2015, 12:57:32 PM »
Can't check here but try:
Control panel > software > avast > change > remove the NG component
Could be it is called different now, but you should be able to find it if it is there.

Offline karkinissan

  • Newbie
  • *
  • Posts: 11
Re: High Disk Usage on startup
« Reply #6 on: May 23, 2015, 01:01:05 PM »
Hmm.. looks like NG is not an option anymore. I dont see it in the component list.(See attachment)
What are my other options?

Offline davexnet

  • Poster
  • *
  • Posts: 529
Re: High Disk Usage on startup
« Reply #7 on: May 23, 2015, 08:15:07 PM »
scroll down the list, it's the last one in the middle column.
AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free

Offline karkinissan

  • Newbie
  • *
  • Posts: 11
Re: High Disk Usage on startup
« Reply #8 on: May 24, 2015, 04:07:48 AM »
scroll down the list, it's the last one in the middle column.
That IS the bottom of the list. I scrolled a bit before taking the screenshot

Offline davexnet

  • Poster
  • *
  • Posts: 529
Re: High Disk Usage on startup
« Reply #9 on: May 24, 2015, 08:04:20 AM »
Doesn't seem to be installed then.  Anyway, if it were, I think you would see a process in the task manager.

Perhaps what you're seeing re: the HDD usage after boot up is the definitions update.
AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31356
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: High Disk Usage on startup
« Reply #10 on: May 24, 2015, 04:31:54 PM »
Just a thought.
Does this happen when you perform a cold boot or when you wake the laptop from sleeping mode/hibernation ?

Offline karkinissan

  • Newbie
  • *
  • Posts: 11
Re: High Disk Usage on startup
« Reply #11 on: May 26, 2015, 04:17:38 AM »
Just a thought.
Does this happen when you perform a cold boot or when you wake the laptop from sleeping mode/hibernation ?

Just the cold boot. Sleep/Hibernation isnt affected.

Offline petitlou61

  • Newbie
  • *
  • Posts: 15
Re: High Disk Usage on startup
« Reply #12 on: May 26, 2015, 10:31:25 AM »
Hello everybody

This problem is not from avast
with a fresh installed windows 8.1 with nothing else you can see two period of disk trashing with responses time over 3000 ms
first one during boot process, with all boot logs and windows update db
second one when openning session with session and event logs
on my PC (core i5) with 512e hdd the total trashing time is around 3 minutes

i beleive that problem increase with modern 512 bytes sector emulation disk because log activity need read of 4k sector , update then rewrite for each log action.
i think that microsoft logging routines are very badly writed because the only log which need synchronous logging is NTFS journal
the other ones can be writted asynchronously by 4k clusters
may be windows 8.1 was thinked with SSD not hdd

So when avastsvc need to use i/o at startup is it a victim of surronding trashing
the only thing i remark is a relatively huge number of simultaneous avastsvc process wich each read one
occurence of catroot inside database during bootup

Best regards
« Last Edit: May 27, 2015, 04:31:14 PM by petitlou61 »

Offline karkinissan

  • Newbie
  • *
  • Posts: 11
Re: High Disk Usage on startup
« Reply #13 on: September 28, 2015, 11:08:16 AM »
Its been 4 months and I still dont see an update from Avast that fixes this.
Should I uninstall?

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 62885
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: High Disk Usage on startup
« Reply #14 on: September 28, 2015, 11:11:31 AM »
- Which Avast..? (Free/Pro/IS/Premier)
- Which version..?
- OS..? (32/64 Bit..? - which SP..?)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
Win 8.1 [x64] - Avast PremSec 20.1.2397.Beta#4 [UI.460] - CC 5.63 - EEK - Firefox ESR 68.5 [NS/AOS/uBO/PB] - TB 68.5 - ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0