Author Topic: Disable scanning on startup  (Read 3715 times)

0 Members and 1 Guest are viewing this topic.

Offline kotrtim

  • Jr. Member
  • **
  • Posts: 34
Disable scanning on startup
« on: November 05, 2005, 04:55:45 PM »
Is there a way to disable Avast from scanning everything in Program Files on startup, it really slows down the startup process.

I have to always pause the standard shield on startup and resume it after 1minute....  >:(

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83750
  • No support PMs thanks
Re: Disable scanning on startup
« Reply #1 on: November 05, 2005, 05:38:43 PM »
What sensitivity do you have your standard shield set to?

On Normal my scanned count drops to about 256 after boot, on High this is up to 800 as my firewall accesses hundreds (450-500) of files on boot.

Try lowering it to Normal and you should find the numbers drop. But I doubt that it is scanning every file in your Program Files folder. I have two program files folders one on C: the other on D:, in this program files folder there are 399 sub folders and 5198 files, so it isn't coming close to scanning them all.

However, there are some files that are scanned in the program files folder/s that don't see the light of day from one month to the next, so that to my mind is wasted processor effort.

So I too would like to see only files that are opened during boot being scanned, even some uninstall.exe files are being scanned and that is madness. So I would like to find out why these type of infrequent files are being scanned (e.g. what triggers the scan)?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline kotrtim

  • Jr. Member
  • **
  • Posts: 34
Re: Disable scanning on startup
« Reply #2 on: November 05, 2005, 06:05:41 PM »
15,966 files 1,734 folders

set to "normal" as always

total files scanned = 400

time elapsed = 2:33

I've seen Avast scanning nero's executables, Winamp's .etc.... can't see properly, the "last scanned" is updated too fast...

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83750
  • No support PMs thanks
Re: Disable scanning on startup
« Reply #3 on: November 05, 2005, 06:30:42 PM »
Well the Nero and Winamp could be if you have them start on boot (when for the most part that isn't necessary) but 400 doesn't seem excessive based on what you have (15,966 files 1,734 folders) and certainly not all as previously stated.

My combined program files folder is in the order of 875 folders and 9250, my boot now takes just over a minute (1:15 - 1:30) to activity ends on the avast icon. My system isn't particularly fast (see signature), it's well locked down though with very few programs starting on boot unless they are absolutely necessary and I have also disabled many un-necessary services.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline kotrtim

  • Jr. Member
  • **
  • Posts: 34
Re: Disable scanning on startup
« Reply #4 on: November 06, 2005, 09:39:47 AM »
alg.exe
ashDisp.exe
ashMaiSv.exe
ashServ.exe
ashWebSv.exe
aswUpdSv.exe

csrss.exe

explorer.exe

lsass.exe

services.exe
smss.exe
spoolsv.exe
svchost.exe
svchost.exe
svchost.exe
System
System Idle Process

wdfmgr.exe
winlogon.exe
wuauclt.exe

165MB PF Usage

these are the processes on startup

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83750
  • No support PMs thanks
Re: Disable scanning on startup
« Reply #5 on: November 06, 2005, 03:34:20 PM »
Only these are avast's:
ashDisp.exe - MS Start-up entry - msconfig, startup tab.
ashMaiSv.exe - Windows Service - Manual Start - Starts if you have the Internet Mail provider enabled.
ashServ.exe - Windows Service - Auto Start
ashWebSv.exe - Windows Service - Manual Start - Starts if you have the Web Shield provider enabled.
aswUpdSv.exe - Windows Service - Auto Start

The main process being ashServ.exe, this would be the one scanning files at boot, to disable scanning, you would effectively need to disable the Windows services and msconfig startup entry, then manually start them which is probably a lot more hassle than what you have at the moment. Not to mention leaving you vulnerable.

I would suggest that you check exactly what programs are starting on boot, there are many that add themselves to the startup list when they don't need to start until you require them, media players being one such example. Disable those that don't need to start and avast won't have to scan the files that they open.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline kotrtim

  • Jr. Member
  • **
  • Posts: 34
Re: Disable scanning on startup
« Reply #6 on: November 08, 2005, 02:09:25 PM »
I've only had "volume icon" and "avast" on my taskbar, nothing else....  I have some feeling that sp2 has installed many patches and make the startup slower compared to no sp?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83750
  • No support PMs thanks
Re: Disable scanning on startup
« Reply #7 on: November 08, 2005, 02:27:49 PM »
All I can say re XP (pro) SP2 is I have it and every update since, I have also has XP installed for around 18 months and that wasn't from a clean install but an upgrade from win98SE. So in theory my system should be as bad or worse. You still haven't mentioned what your system spec is as that may also have an effect on boot.

As far as icons go for avast, you would only see the 'a' icon and possibly the 'i' icon if you hadn't merged both; the other services mentioned don't put icons in the tray at boot. The ashMaiSv.exe does when it is scanning email but it goes when complete.

Sorry I don't have any other suggestions other than do what I did some time ago, a google search on 'windows XP slow boot' or 'windows XP slow startup' (without the quotes) and see if it throws up anything that you can try that could improve the situation. However, before you start messing with the boot, services, etc. I would recommend you take a disk image as a means of recovering from over zealous tweaking.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro