Author Topic: Avast Free 10.3.2219 HTTPS corruption  (Read 16030 times)

0 Members and 1 Guest are viewing this topic.

Offline Zdenek

  • Avast team
  • Jr. Member
  • *
  • Posts: 38
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #15 on: June 19, 2015, 10:56:39 AM »
Hallo. We have found a problem in the HTTP(s) scanning engine and fix will be included in next beta release.

But, about the flickr problem, I'm not able to reproduce the problem here with current beta. Is enough to enter flickr and browse the site, or I have to do something else. And is the problem generic or related only to one browser, please ?

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71784
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #16 on: June 19, 2015, 11:01:58 AM »
Hallo. We have found a problem in the HTTP(s) scanning engine and fix will be included in next beta release.
OK, thanks Zdenek.
Win 8.1 [x64] - Avast PremSec 21.8.6586.IBC [UI.666] - EEK - Firefox ESR 78.14 [NS/uBO/PB] - TB 91.1
Avast-Tools: Secure Browser 93.0 - Cleanup 21.3 - SecureLine 5.13 - Driver Updater 21.3 - CCleaner 5.84
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline HDW38

  • Massive Poster
  • ****
  • Posts: 3406
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #17 on: June 19, 2015, 11:28:18 AM »
Me too.


Offline Rednose

  • Pirate Party Member
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 3744
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #18 on: June 19, 2015, 01:19:02 PM »
With Firefox and HTTPS scanning on : I have slowdowns, and on the forum even error messages.
Same here, I also got the 400 error quite often, a reload usually helps.

Thanks for the conformation.
I didn't post it earlier, because I was not sure the 400 error was Beta related.

Hallo. We have found a problem in the HTTP(s) scanning engine and fix will be included in next beta release.

Thanks :)

Greetz, Red.
OS: Win 10 / iOS 14 / Debian 10 / Tails 4
Real Time: Avast Premium Security
On Demand: Malwarebytes
VPN: NordVPN ( NordLynx ) with CyberSec

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85578
  • No support PMs thanks
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #19 on: June 19, 2015, 02:59:06 PM »
Hallo. We have found a problem in the HTTP(s) scanning engine and fix will be included in next beta release.
<snip>

Aside from having found the problem with HTTPS scanning - are you also going to fix the UI where XP users don't have HTTPS scanning options.

Currently I tried a fix from Lukas: https://forum.avast.com/index.php?topic=172470.msg1224686#msg1224686
WebShield.ini

[WebScanner]
HttpsScanning=0

This however doesn't stop HTTPS scanning in XP, Firefox 38.0.5, nor does it change the user interface.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4865
  • Whatever will be, will be.
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #20 on: June 19, 2015, 03:07:51 PM »
Hallo. We have found a problem in the HTTP(s) scanning engine and fix will be included in next beta release.
Thanks for the confirmation. :)
Main: Win10 Pro 20H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 21 Premium Beta(Icarus) / Comodo Firewall (testing again)
Mobile: Win10 Pro 20H2 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 21 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline lukor

  • Moderator
  • Super Poster
  • *
  • Posts: 1884
    • AVAST Software
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #21 on: June 19, 2015, 04:52:47 PM »
DavidR, have tried restarting? The ini file setting should absolutely work, the code is the same for all OSs and on other platforms it works. Of course the hidden gui will be fixed.

Lukas

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85578
  • No support PMs thanks
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #22 on: June 19, 2015, 05:06:20 PM »
DavidR, have tried restarting? The ini file setting should absolutely work, the code is the same for all OSs and on other platforms it works. Of course the hidden gui will be fixed.

Lukas

I have restarted the system a few times and still no stopping https scanning.

I have just had the system completely lock up today whilst browsing uk.yahoo.com which has https and http content. I'm not sure if this is related, but I have uploaded <b>DavidR_manual-crash-dump.7z</b> to the avast ftp. https://forum.avast.com/index.php?topic=172367.msg1224893#msg1224893
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9383
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #23 on: June 21, 2015, 08:28:43 AM »
So this is what I've been experiencing for a while now. Yeah, only HTTPS pages. I've turned HTTPS scanning off for now till next beta version is released.
Visit my webpage Angry Sheep Blog

Offline AndreaVr

  • Full Member
  • ***
  • Posts: 192
    • Blog Ufficiale Andrea Lonardi ~ Non si vive di sola tecnologia !!
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #24 on: June 24, 2015, 08:13:45 AM »
Hi, is this HTTPS only issue? No problems or slowdowns with HTTP only sites? Problems complety gone when HTTPS scanning is disabled?

Thanks. Lukas.
Hello Lukas,

I confirmed that disabling HTTPS scanning in WebShield settings solved the problem.
For example, I cannot access this website with HTTPS scanning enabled.
After disabling HTTPS scanning (and restart of WebShield), I can access it.
https://kaken.nii.ac.jp/

I also confirmed the problem with IE11.
IE11 gave me an error message saying enabling TLS 1.0, 1.1, 1.2 are needed to access the website, although they are already enabled.

I have the Beta3 with Windows7 64bit and that site opens without problems

Offline Yash Khan

  • Jr. Member
  • **
  • Posts: 91
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #25 on: June 24, 2015, 02:16:14 PM »
I have faced some site probs with SecureDNS enabled. I have uninstalled SecureDNS & no probs. I keep HTTPS on WebShield disabled.

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4865
  • Whatever will be, will be.
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #26 on: July 02, 2015, 04:06:08 PM »
I still have some issues with HTTPS scanning with Firefox.
Loading of Wikipedia never ends, but I forcefully stop loading and do a reload then the page loads without a problem.

I don't have this problem with IE though.
Main: Win10 Pro 20H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 21 Premium Beta(Icarus) / Comodo Firewall (testing again)
Mobile: Win10 Pro 20H2 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 21 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85578
  • No support PMs thanks
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #27 on: July 02, 2015, 04:14:22 PM »
I still have some issues with HTTPS scanning with Firefox.
Loading of Wikipedia never ends, but I forcefully stop loading and do a reload then the page loads without a problem.

I don't have this problem with IE though.

Do you still have Avast Free 10.3.2219 HTTPS ?

The latest beta build is 2015.10.3.2221 R3 Beta3
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline HDW38

  • Massive Poster
  • ****
  • Posts: 3406
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #28 on: July 02, 2015, 04:27:22 PM »

HTTPS corruption was history since 10.3.2220!
 ;)
HDW

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4865
  • Whatever will be, will be.
Re: Avast Free 10.3.2219 HTTPS corruption
« Reply #29 on: July 03, 2015, 05:10:07 PM »
Do you still have Avast Free 10.3.2219 HTTPS ?

The latest beta build is 2015.10.3.2221 R3 Beta3

Yes, I have latest build.

Maybe I should try clean reinstall of avast.
Main: Win10 Pro 20H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 21 Premium Beta(Icarus) / Comodo Firewall (testing again)
Mobile: Win10 Pro 20H2 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 21 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。