Author Topic: Avast blocking most internet traffic when Web Shield is enabled  (Read 19177 times)

0 Members and 1 Guest are viewing this topic.

Offline pavelivanov2000

  • Newbie
  • *
  • Posts: 1
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #30 on: July 26, 2015, 03:30:41 PM »
Thanks Ront50,
 that was our suspicion ;-) Problem is only in some cases on Win XP, we are working on a fix already.

That is great news MartinZ and is commendable that you will still support it. There are still tons of XP users in the world as you know. It could be worse, it could have been millenium :D

Cheers

Hello
I'm here to say that the issue is not on XP only. I have win 8.1 and my PC is affected. Since the update pages on IE, Chrome, Opera, Firefox seem to load forever. Downloads are very slow in general. When I disable Avast everything is back to normal. When I enable it slows down or blocks programs. It affects Teamviewer which is sometimes connected, sometimes not connected to server. When not connected and I disable Avast it connects immediately. I'm using an executable jar file to remote view/control my android devices and it's blocked by Avast now. I used an android emulation under oracle virtual box. I lost it after the Avast program update. I could not recover it because when I did system restore to previous point it said Avast prevented that. I have two other computers which have not version 10.3.2223 (they are set to manual update) and they work without problems. On the affected computer I'm sure Avast was configured to "ask when an update is available", but it updated without asking after a PC restart and then the problems began.
I hope the issue will be addressed not only for XP but for all affected platforms.
« Last Edit: July 26, 2015, 03:36:01 PM by pavelivanov2000 »

Offline bramweiser

  • Jr. Member
  • **
  • Posts: 32
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #31 on: July 26, 2015, 04:28:57 PM »
* I called Avast for support (7/26/15, 11:30pm ET, usually GMT-5) and the technician (Benjamin) insisted that this was my computer's fault, and not Avast's for supplying a bad update.
* He claimed to not have heard of this issue before my call (do they NOT read these forums?)
* He then insisted that I'd need to pay for "Tier 2 Support" that he said I needed to fix this.
* He THEN said that I should talk to Microsoft for further assistance because (again) it was my computer (which he kept saying was running "Windows HP", not XP, while besmirching MY computer knowledge as, he insisted, necessarily being less than his -- I have my doubts) causing this as far as he was concerned...even though this thread intimates that it was, indeed, Avast's update, instead, as I suspected.
Report your experience to Vojta Nekvapil: nekvapil[at]avast.com (3rd Party Support Manager)

Asyn,

That address doesn't work as emails sent there get kicked back because the user is "Unknown".  Are you sure there's no typo?

Bram

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45276
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #32 on: July 26, 2015, 04:45:56 PM »

nekvapil(at)avast.com
The address is correct simply replace the (at) with the @ symbol.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline bramweiser

  • Jr. Member
  • **
  • Posts: 32
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #33 on: July 26, 2015, 04:53:51 PM »

nekvapil(at)avast.com
The address is correct simply replace the (at) with the @ symbol.

I did that, bob3160, and this is part of what came back:

"<nekvapil [at] avast [dot] com>: host mx2.avast.com[91.213.143.6] said: 550 5.1.1
<nekvapil [at] avast [dot] com>: Recipient address rejected: User unknown in virtual
mailbox table (in reply to RCPT TO command)"

Bram

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84905
  • No support PMs thanks
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #34 on: July 26, 2015, 05:01:37 PM »
* I called Avast for support (7/26/15, 11:30pm ET, usually GMT-5) and the technician (Benjamin) insisted that this was my computer's fault, and not Avast's for supplying a bad update.
* He claimed to not have heard of this issue before my call (do they NOT read these forums?)
* He then insisted that I'd need to pay for "Tier 2 Support" that he said I needed to fix this.
* He THEN said that I should talk to Microsoft for further assistance because (again) it was my computer (which he kept saying was running "Windows HP", not XP, while besmirching MY computer knowledge as, he insisted, necessarily being less than his -- I have my doubts) causing this as far as he was concerned...even though this thread intimates that it was, indeed, Avast's update, instead, as I suspected.
Report your experience to Vojta Nekvapil: nekvapil[at]avast.com (3rd Party Support Manager)

Asyn,

That address doesn't work as emails sent there get kicked back because the user is "Unknown".  Are you sure there's no typo?

Bram

I change the [at] to the normal email @ ?

This is a valid email, I have just sent an email to that address and it appears to have gone through. I have referred him to your post.

EDIT: That email has just bounced back.
« Last Edit: July 26, 2015, 05:03:52 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline avtassel

  • Newbie
  • *
  • Posts: 1
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #35 on: July 26, 2015, 07:36:24 PM »
Update Avast Program vs.10.3.2223  on July 25, 2015.....bad news!!
Running XP SP2, Have respected Avast for years....until alerts of the blocking of Mozilla, facebook, startpage, and even Avast sites themselves.  Restore  back to 2015.10.2.2218 seems to have worked for now. ignoring  Pop up telling me to update Avast Program until it gets fixed.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84905
  • No support PMs thanks
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #36 on: July 26, 2015, 07:58:16 PM »
Update Avast Program vs.10.3.2223  on July 25, 2015.....bad news!!
Running XP SP2, Have respected Avast for years....until alerts of the blocking of Mozilla, facebook, startpage, and even Avast sites themselves.  Restore  back to 2015.10.2.2218 seems to have worked for now. ignoring  Pop up telling me to update Avast Program until it gets fixed.

You could have saved some trouble by just disabling the HTTPS scanning in the version as mentioned in Reply #20 and Reply #27
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45276
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #37 on: July 26, 2015, 08:26:22 PM »
Update Avast Program vs.10.3.2223  on July 25, 2015.....bad news!!
Running XP SP2, Have respected Avast for years....until alerts of the blocking of Mozilla, facebook, startpage, and even Avast sites themselves.  Restore  back to 2015.10.2.2218 seems to have worked for now. ignoring  Pop up telling me to update Avast Program until it gets fixed.

You could have saved some trouble by just disabling the HTTPS scanning in the version as mentioned in Reply #20 and Reply #27
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline bramweiser

  • Jr. Member
  • **
  • Posts: 32
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #38 on: July 26, 2015, 11:44:09 PM »
Yes, bob3160, thank you, I'm one who did that...disabling HTTPS as you showed...but the idea is that one shouldn't HAVE TO do that in order to have Avast run as intended.

This is a bug in the update that Avast will hopefully be fixing soon.  I surely hope so anyway...

Also, given that I and someone else have indeed found that the nekvapil@... address isn't working, do you (or does anyone) have an alternative?

Thanks again,
Bram Weiser

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45276
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #39 on: July 26, 2015, 11:49:54 PM »
I have already alerted one of my contacts at Avast of the email problem.
Remember it's Sunday today. I don't expect any answer till tomorrow. :)
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline bramweiser

  • Jr. Member
  • **
  • Posts: 32
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #40 on: July 27, 2015, 12:15:34 AM »
I have already alerted one of my contacts at Avast of the email problem.
Remember it's Sunday today. I don't expect any answer till tomorrow. :)

Thanks, bob3160.  That's fine, and understandable.

If he/they(/you?) can please let us know when the email issue is resolved (and if, say, there's a different address we should use...and, if so, what it would be), that would be great, too!

Thanks,
Bram Weiser

Offline Ront50

  • Newbie
  • *
  • Posts: 14
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #41 on: July 27, 2015, 12:33:08 AM »
It is fair to say that disabling functionality of a product is a bandaid solution to a coding bug. Here's hoping it will be fixed in the next version but until then, I have reverted back to an earlier version without the bug. MartinZ did say a fix was in the works but I have not seen him back in this thread yet and I would like to believe turning off HTTPS is not the fix he meant considering the number of pages that are S these days. I am really not keen on turning off SSL on pages like my banking and any other where sensitive information is shared so will it work, probably and possibly since I will not do that but is it a good idea? Easy to figure out.

Cheers
« Last Edit: July 27, 2015, 12:36:22 AM by Ront50 »

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45276
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #42 on: July 27, 2015, 12:38:37 AM »
I have already alerted one of my contacts at Avast of the email problem.
Remember it's Sunday today. I don't expect any answer till tomorrow. :)

Thanks, bob3160.  That's fine, and understandable.

If he/they(/you?) can please let us know when the email issue is resolved (and if, say, there's a different address we should use...and, if so, what it would be), that would be great, too!

Thanks,
Bram Weiser
Once I know, you'll know unless someone from Avast post a reply directly.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84905
  • No support PMs thanks
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #43 on: July 27, 2015, 01:24:59 AM »
It is fair to say that disabling functionality of a product is a bandaid solution to a coding bug. Here's hoping it will be fixed in the next version but until then, I have reverted back to an earlier version without the bug. MartinZ did say a fix was in the works but I have not seen him back in this thread yet and I would like to believe turning off HTTPS is not the fix he meant considering the number of pages that are S these days.

I am really not keen on turning off SSL on pages like my banking and any other where sensitive information is shared so will it work, probably and possibly since I will not do that but is it a good idea? Easy to figure out.

Cheers

The reason earlier versions didn't have this bug, was previously XP and Vista didn't have the infrastructure to enable avast to scan HTTPS pages. HTTPS scanning on XP and Vista was only introduced from 10.3.2223 when avast made changes to enable XP and Vista to scan HTTPS pages.

I think you are confused by what was suggested disabling HTTPS scanning is in the Web Shield settings - not trying to turn off SSL on your banking pages (which I don't think you can do for sites that are specifically HTTPS). They would remain using SSL/TLS just that avast web shield wouldn't scan those pages.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Ront50

  • Newbie
  • *
  • Posts: 14
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #44 on: July 27, 2015, 01:55:29 AM »
Hi DavidR,

No I am aware and just posted out wrong in haste. I understand that those sites will only use browsers that support it, I really meant to say, disabling that in the web shield was not a great idea considering the number of pages these days that are HTTPS. We could not even get to the Avast site due to that. I still maintain, turning off the Enable HTTPS scanning is not what most people would want in a Virus program based on that.  I do realize the option is not available on the earlier version although it is available in 10.2.2218 as I am running that right here and now, hence "The bug"  Fingers crossed it might be fixed because reality is there is still a huge XP user base out there and of course we want all the pages scanned since I am very confident in my banking site, the others? Not so much.

Cheers.
« Last Edit: July 27, 2015, 02:00:37 AM by Ront50 »