Author Topic: problem to start the avast antivirus  (Read 9561 times)

0 Members and 1 Guest are viewing this topic.

Offline yasrt

  • Newbie
  • *
  • Posts: 11
Re: problem to start the avast antivirus
« Reply #15 on: November 16, 2005, 12:00:01 PM »
yes

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11745
    • AVAST Software
Re: problem to start the avast antivirus
« Reply #16 on: November 16, 2005, 01:15:53 PM »
OK... let's try some heavier weapons ;)
I have prepared a special version of one avast! module that logs some "debugging" information into a file. So, if it's not a problem, please do the following:

1. Make sure you are using the latest build of avast! (4.6.731). If not, invoke a program update first and make sure that the problem is still present.
2. Download this file
3. Go to avast! installation folder and rename the file aswEngin.dll to something else, e.g. aswEngin_.dll. It should be possible to do even when avast! is running. You can use the command
ren aswEngin.dll aswEngin_.dll
4. Copy the file you downloaded in point 2 to avast! installation folder (i.e. you have just replaced the aswEngin.dll file with a new version)
5. Now, invoke again the command  ashQuick.exe "*STRT-MEM-SHORT"
6. Wait for the window to disappear.

During the scanning, the file C:\avast.log is created. When the scan is done, attach the file here, please - I'll take a look at it (you may have to rename it to .txt, I'm not sure if the board permits .log extension for attachments).

Then, you may rename the aswEngin.dll file back (i.e. delete the aswEngin.dll file and do ren aswEngin.dll aswEngin_.dll) - or simply invoke a VPS or program update and avast! setup will revert the file back itself (but it will ask for reboot).

Thanks!


Offline yasrt

  • Newbie
  • *
  • Posts: 11
Re: problem to start the avast antivirus
« Reply #17 on: November 16, 2005, 02:08:00 PM »
The log is attached
« Last Edit: November 16, 2005, 03:22:28 PM by igor »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11745
    • AVAST Software
Re: problem to start the avast antivirus
« Reply #18 on: November 16, 2005, 02:25:01 PM »
Hmm, that's what I was afraid of  :-\
The problem seems to be in the startup enumeration... which is quote a lot of code. It might be hard to find it - but it really seems like a bug.
I'll prepare another modified version of the module in a while (that will log the progress of this particular part of the enumeration).

Thanks for your help!

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11745
    • AVAST Software
Re: problem to start the avast antivirus
« Reply #19 on: November 16, 2005, 02:52:12 PM »
OK, I updated the file on web. Could you please download it again and do exactly the same as before? Hopefully it will get us closer to the problem location.
Thanks.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11745
    • AVAST Software
Re: problem to start the avast antivirus
« Reply #20 on: November 17, 2005, 06:59:51 PM »
Any news on the last log, yasrt? I hope I could pinpoint the exact location of the problem from the log...
Thanks for your help!

Offline yasrt

  • Newbie
  • *
  • Posts: 11
Re: problem to start the avast antivirus
« Reply #21 on: November 17, 2005, 07:33:42 PM »
I send it already yesterday to the mail address that you gave me

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11745
    • AVAST Software
Re: problem to start the avast antivirus
« Reply #22 on: November 22, 2005, 04:15:16 PM »
Try this file, please.
Go to avast! installation folder, rename aswEngin.dll to something else (e.g. aswEngin.dl_) and extract the content of the archive to the folder.
I hope it should fix the problems.

Offline yasrt

  • Newbie
  • *
  • Posts: 11
Re: problem to start the avast antivirus
« Reply #23 on: December 03, 2005, 05:01:20 PM »
OK , I test it and it work well , also with the problematic shortcut (startup adsl)
Thanks