Author Topic: Avast blocks just one of my imap account.  (Read 3592 times)

0 Members and 1 Guest are viewing this topic.

Offline DrObnxs

  • Newbie
  • *
  • Posts: 1
Avast blocks just one of my imap account.
« on: August 21, 2015, 08:47:03 PM »
Hi there, I'm having a weird problem. I use 1and1 as a web and email host. I have three or four imap accounts set up. When I turn the Mail Shield on, only one of the accounts can't connect, all the others are fine.

I tried deselecting everything from the options tab for the mail shield, and it only connects to that one account when I have the mail shield disabled.

Mac OS 10.10.5
Avast Free 10.14

Offline johan53

  • Newbie
  • *
  • Posts: 1
Re: Avast blocks just one of my imap account.
« Reply #1 on: December 02, 2015, 11:18:32 AM »
I have the same problem.
OSX 10.11.1
Avast 11.4

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast blocks just one of my imap account.
« Reply #2 on: December 02, 2015, 11:27:09 AM »
Just saying something isn't working is not much helping to find a solution.

The client/server is using the IMAP extension (RFC 4551)
If so, you need to wait for a update of avast.
That protocol is not (yet) supported.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Avast blocks just one of my imap account.
« Reply #3 on: December 04, 2015, 03:13:11 PM »
Just saying something isn't working is not much helping to find a solution.

The client/server is using the IMAP extension (RFC 4551)
If so, you need to wait for a update of avast.
That protocol is not (yet) supported.

How do you know? Do you have an account there? Even when the server and client support this extension, it should not be used as the mail shield should remove the required CONDSTORE support promotion from the imap CAPABILITIES responses.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Avast blocks just one of my imap account.
« Reply #4 on: December 04, 2015, 03:15:34 PM »
Is there something in the system log file (/var/log/system.log)? The origin process name is com.avast.proxy.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast blocks just one of my imap account.
« Reply #5 on: December 04, 2015, 03:36:05 PM »
Tumic,

someone from avast explained that.
That is how I know.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Avast blocks just one of my imap account.
« Reply #6 on: December 04, 2015, 06:18:46 PM »
Tumic,

someone from avast explained that.
That is how I know.

Yes and I guess it was me. But that was a different mail server and the person asking has included
a log snippet. Here we do not know anything... (Additionally the previous case is still a mystery
as this should theoretically not happen)

Offline dhart

  • Newbie
  • *
  • Posts: 2
Re: Avast blocks just one of my imap account.
« Reply #7 on: December 22, 2015, 08:56:37 PM »
I'm having a similar problem.

I have two gmail accounts that I am connecting to via Outlook 2013.  The first will connect via IMAP SSL with no problems.  The second account, using the same IMAP settings, but with a different login, will not connect with Avast running.  I have a third IMAP connection to a different email system and that works fine.  So,

I see the following error in the mail.log file:  Cannot connect to IMAP server 2607:f8b0:400d:c08::6c (2607:f8b0:400d:c08::6c:993), connect error 10051

The IMAP server is imap.gmail.com.

The error message indicates a problem with Avast and IPv6 when opening multiple SSL connections to the same IMAP server.

Scenarios Tested

IPv6: Enabled, Avast Mail Scanning: Enabled - First IMAP connection using my primary gmail account works, second connection with different account to the same IMAP server fails

IPv6: Enabled, Avast Mail Scanning: Disabled - Both IMAP accounts connect and login

IPv6: Disabled, Avast Mail Scanning: Enabled - Both IMAP accounts connect and login


Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Avast blocks just one of my imap account.
« Reply #8 on: December 22, 2015, 11:22:54 PM »
Again - is there anything in the system log file? Without any info, there is nothing we can do
about it.

Additionally, I don't think, that the problem is in multiple connections. To prove this, a simple
test with only the problematic mail account should be sufficient. I suppose, it won't work
even when it is the only connection to the IMAP server.

Finally just a note: if you disable IPv6 scanning and the mail server has an IPv6 address, it is
the same as disabling the mailshield generally.

Offline mike348

  • Newbie
  • *
  • Posts: 2
Re: Avast blocks just one of my imap account.
« Reply #9 on: December 31, 2015, 01:23:39 PM »
I'm having a similar problem using a single imap account on a godaddy server using Apple Mail 9.2 under El Capitan 10.11.2  Mail hangs after initial downloading of messages unless I turn off "scan secured connections" or "enable ipv6." There must be some way around this problem as Avast works together perfectly without disabling features using Apple Mail 8.2 operating under Yosemite 10.10.5 

Offline mike348

  • Newbie
  • *
  • Posts: 2
Re: Avast blocks just one of my imap account.
« Reply #10 on: December 31, 2015, 05:45:29 PM »
This is a continuation of my previous comment. The combination of Avast and Apple Mail 9.2 apparently ONLY work together when "scan secured connections" is unchecked. If I uncheck only "enable ipv6" Mail seems to work for a while but eventually hangs up after 10 or so minutes of seeming to work correctly.