Author Topic: "Communication with Avast service failed - no such process" on 10.8  (Read 4986 times)

0 Members and 1 Guest are viewing this topic.

spullum@uci.edu

  • Guest
I have multiple OS X 10.8 machines running Avast for Mac. When I try to "edit settings" for File, Mail, or Web Shields, or if I try to "submit to virus lab" I get a pop-up stating "Communication with Avast service failed."

This issue does not arise on 10.7, 10.9, or 10.10 machines.
Anyone else experiencing this? Is there a way to configure the settings via Terminal or config file?

Thanks,

drewshg@gmail.com

  • Guest
Re: "Communication with Avast service failed - no such process" on 10.8
« Reply #1 on: September 15, 2015, 10:09:26 PM »
I have the same issue. But on 10.10.5…  Did you find a way to fix this?
« Last Edit: September 15, 2015, 10:51:45 PM by drewshg »

spullum@uci.edu

  • Guest
Re: "Communication with Avast service failed - no such process" on 10.8
« Reply #2 on: September 16, 2015, 04:25:23 PM »
Interesting... no unfortunately not yet. I'm not sure how command-line friendly Avast for Mac is. I think it has a helper daemon that the GUI sends messages to but is being blocked from doing so.

I'm going to install the latest beta on an affected machine to see if it still happens.
Thanks for sharing. Hopefully there is a workaround.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: "Communication with Avast service failed - no such process" on 10.8
« Reply #3 on: September 16, 2015, 10:56:00 PM »
Interesting... no unfortunately not yet. I'm not sure how command-line friendly Avast for Mac is. I think it has a helper daemon that the GUI sends messages to but is being blocked from doing so.

I'm going to install the latest beta on an affected machine to see if it still happens.
Thanks for sharing. Hopefully there is a workaround.

Avast for Mac is quiet command-line friendly and technically can be configured using
configuration files, but that is not the solution. The solution is to find out, why the
Avast service crashes. I'm pretty sure you will have some crashreports for
"com.avast.service" in your Console. Can you post one of theme here?

spullum@uci.edu

  • Guest
Re: "Communication with Avast service failed - no such process" on 10.8
« Reply #4 on: April 01, 2016, 04:03:50 PM »
Hi Tumic,

Sorry, I never saw your post here. Do you know of anywhere I can find command-line help for Avast for Mac so I can script it?

I'm not encountering crashes anymore (although we have moved on to OS X 10.10 at minimum). Now I'm dealing with exclusions not being saved. I've found a few config files and could hack something together but hoping there are tools for this.

Thanks
Shawn