Author Topic: Invalid certificate popup + Exclusions that don't seem to work  (Read 2653 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Invalid certificate popup + Exclusions that don't seem to work
« on: October 04, 2015, 03:08:37 PM »
I've already took a look at some related topics (e.g. Web Shield 2015 is blocking access because "... certificate is invalid:bing.com" thread, but also Updated to 2015, Now Chrome is giving me "Your connection is not private" msg. one), and I couldn't find an answer to my problem.

Namely I am experiencing the same issue as OP in the first link thread above. When I try to visit http://genius.com/ (or http://rap.genius.com/) website I get this error text in the Avast's popup right above the clock & other icons/programs in task bar)

Quote
Avast Web Shield has blocked access to this page because the following certificate is invalid: ssl149088.cloudflaressl.com

Okay I thought, it's a well-known & trusted website so I will just put that URL under Exclusions and Avast will stop checking "cloudflaressl.com" so I could visit & browse http://genius.com/. But the problem is that apparently Exclusions do not work at all. I added the "http://*.cloudflaressl.com*" to Web Shield's (Settings, Active protection tab, Web Shield -> Customize, Exclusions tab) and just to be completely sure also under Avast's general Exclusions (Settings, General tab, Exclusions section under "URLs" tab; the other 3 tabs being File paths, DeepScreen, and Hardened mode)

At the moment the only way to visit the mentioned website (http://genius.com/) is to temporarily disable Web Shield! Am I right in assuming think I the other way would be to I un-tick "Enable HTTPS scanning" (Web Shield -> Main settings tab)?

P.S. I am using the latest version 10.4.2233 of Avast Free Antivirus 2015, which I downloaded & installed a bit more (i.e. on 25th September) than one week ago.
« Last Edit: October 07, 2015, 02:14:07 PM by tadejp »

Offline bob3160

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 47411
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
If you think it's a false positive, send it to Avast: https://blog.avast.com/tag/false-positive/

Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11818
    • AVAST Software
I'd say that messages about an invalid certificate must be related to a https connections, i.e. the http mask most likely wouldn't match.

REDACTED

  • Guest
Thank you igor for the hint that it may indeed be related to SSL (https connections); maybe I will just un-tick/check "HTTPS Scanning". And thanks for the 2nd reply to the other poster too. :)

But otherwise any idea on why it appears in this case that "Exclusions" (as mentioned both - Web Shield's under Settings, Active protection, and Avast's general Exclusions under Settings, General tab, Exclusions) don't work?