Author Topic: avast.vpsupdate  (Read 3601 times)

0 Members and 1 Guest are viewing this topic.

Offline 2opv

  • Newbie
  • *
  • Posts: 11
avast.vpsupdate
« on: October 16, 2015, 02:56:45 AM »
Good day.
Every time as avast.vpsupdate starts (every 3 hours by cron in my case) I receive email from cron:
Subj: Cron <avast@server> /var/lib/avast/Setup/avast.vpsupdate
Body: standard in must be a tty

Is it Error?

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 725
Re: avast.vpsupdate
« Reply #1 on: October 19, 2015, 11:39:22 AM »
Most probable you have enabled the requiretty setting in /etc/sudoers for root.
As the update script is running from cron (thus with no tty) and uses sudo to run
under the "avast" user, this will not work.

Offline 2opv

  • Newbie
  • *
  • Posts: 11
Re: avast.vpsupdate
« Reply #2 on: October 20, 2015, 08:39:01 AM »
Thanks,
Question is closed.