Author Topic: exchange webmail 'Service Unavailable'  (Read 14572 times)

0 Members and 1 Guest are viewing this topic.

elb

  • Guest
exchange webmail 'Service Unavailable'
« on: December 01, 2005, 10:06:32 AM »
Hi

I've just installed avast server 4 edition with the exchange plugin.

Everything is working great, except :

Our company webmail through exchange is no longer available, and says "Service Unavailable". The only change was the install of avast.

The address used is https://domain

Ive searched through earlier posts about webmail not working because its secure and cannot be read by avast, but they all seemed to relate to using external webmail from an avast protected pc rather then viewing webmail on the exchange server itself.

All services are currently running.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: exchange webmail 'Service Unavailable'
« Reply #1 on: December 01, 2005, 10:12:55 AM »
Is the IIS service running as well? Any relevant entries in the Windows Event Log?
If at first you don't succeed, then skydiving's not for you.

elb

  • Guest
Re: exchange webmail 'Service Unavailable'
« Reply #2 on: December 01, 2005, 11:03:45 AM »
Thanks

IIS is running ok. I did notice some errors with avast on reboot in the eventlog. trying a few things on them now

elb

  • Guest
Re: exchange webmail 'Service Unavailable'
« Reply #3 on: December 01, 2005, 11:21:50 AM »
ok ive got the server restarted, no errors in event log. Then a few minutes later when I first try to go to the website,  get 5 occurrences of these 2 errors in teh application log :

error ID : 2214
The HTTP Filter DLL C:\Program Files\Alwil Software\Avast4\AvIsaHlp.dll failed to load.  The data is the error.


error ID : 2268
Could not load all ISAPI filters for site/service.  Therefore startup aborted.


And at the same time in the system log, 5 of these, althought the process ID did vary :

error ID : 1039
A process serving application pool 'ExchangeApplicationPool' reported a failure. The process id was '6100'.  The data field contains the error number.

After restartinh IIS, going to the web address triggers teh same 5 error's.

Any and all advice muchly appreciated. The only thing I've found so far is this : http://support.microsoft.com/?id=895976
« Last Edit: December 01, 2005, 11:27:10 AM by elb »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: exchange webmail 'Service Unavailable'
« Reply #4 on: December 01, 2005, 11:36:15 AM »
So you have ISA Server installed? And Avast for ISA?
If at first you don't succeed, then skydiving's not for you.

elb

  • Guest
Re: exchange webmail 'Service Unavailable'
« Reply #5 on: December 01, 2005, 11:41:45 AM »
ive currently got exchange 2000/2003

standard shield

and ms prxy/isa running

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: exchange webmail 'Service Unavailable'
« Reply #6 on: December 01, 2005, 11:57:08 AM »
So this machine has a MS ISA Server installed? Which version?
If at first you don't succeed, then skydiving's not for you.

elb

  • Guest
Re: exchange webmail 'Service Unavailable'
« Reply #7 on: December 01, 2005, 12:02:17 PM »
im assuming it does have ISA because it has the weblogin. I didnt set it up though and have no idea how to tell the version or confirm it is intalled.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: exchange webmail 'Service Unavailable'
« Reply #8 on: December 01, 2005, 12:10:42 PM »
Hmm, is this a Small Business Server? Or regular Windows server?
If at first you don't succeed, then skydiving's not for you.

elb

  • Guest
Re: exchange webmail 'Service Unavailable'
« Reply #9 on: December 01, 2005, 12:19:43 PM »
exchange 2k3 standard

we have a small business server as the DC

elb

  • Guest
Re: exchange webmail 'Service Unavailable'
« Reply #10 on: December 01, 2005, 12:48:24 PM »
I tried having various avast services on and off to no success. I just uninstalled, and its all back to normal again.

I'll try and give this another shot with jsut hte exchange service installed

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: exchange webmail 'Service Unavailable'
« Reply #11 on: December 01, 2005, 02:43:11 PM »
Exactly, that's what I wanted to suggest. Try not installing the ISA plugin.
If at first you don't succeed, then skydiving's not for you.

elb

  • Guest
Re: exchange webmail 'Service Unavailable'
« Reply #12 on: December 02, 2005, 02:47:16 AM »
yep all good now. Ive got exchange and smtp plugins only installed.  My issue appears I overinstalled.

Where do i find a bit more documentation as to what each bit is for?

thanks for teh prompt responses btw, muchly appreciated