Author Topic: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2  (Read 5374 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83965
  • No support PMs thanks
Well this issue really hasn't been squashed yet.

I'm constantly having issues browsing in Yahoo's portal - https://uk.yahoo.com/ - that I browse for news, etc.

I also get this issue in the avast forums.

1. Several time a day I have to disable https scanning and stop the web shield. I then try to refresh those tabs I can't view, but I'm still unable to view them.
2. Only when I enable https scanning and restart the web shield am I able to view the pages.
3. On occasion I also have to do this same exercise with the Mail Shield.

So there is certainly some work still to be done on HTTPS scanning for XP SP3.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 67440
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #1 on: October 24, 2015, 04:49:40 PM »
Hi Dave, still waiting for a reply from the devs here...

- WebShield HTTPS Scanning: We introduced a new method of HTTPs scanning. It is used in Firefox, Chrome and Opera. It works without changing the certificates with the help of kernel mode hooking. The security parameters and certificates are verified by the browser itself, including checks for untrusted or revoked certificates.
Interesting, is this also valid for XP systems..??
Win 8.1 [x64] - Avast PremSec 20.9.2435.Beta#3 [UI.575] - CC 5.73 - EEK - FF ESR 78.4 [NS/AOS/uBO/PB] - TB 78.4 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83965
  • No support PMs thanks
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #2 on: October 24, 2015, 06:30:10 PM »
Yes this has certainly been around for some considerable time and there were meant to be fixes, when it was first introduced I didn't really have an issue when other were reporting issues in the likes of Yahoo and some other sites.

But from the time of the work around for XP is when I started to have issues, weird the fixes for me had the reverse effect. I too wonder about this new web shield HTTPS method, as I thought it was also for XP, but only those with SP3.

For me when they tried the selective/qualified update experiment to stop XP systems getting a beta if they weren't allowed on XP was another problem area as it still let me install a beta that shouldn't have been allowed and the only way round that was a clean reinstall.

The last two rounds of beta testing (for XP) and release for 10.4.x and 11.1.x have for me been probably the least stable of all of the betas I have taken part in in over 11 years.

I'm also still getting system lockups whilst browsing (also in MS Excel and also memory errors reported) with no other course of action than hard shutdown. This for me has been the worst as there is no way to gather any data or run the the support tool. Really frustrating.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 67440
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #3 on: October 24, 2015, 07:25:21 PM »
1. I too wonder about this new web shield HTTPS method, as I thought it was also for XP, but only those with SP3.
2. For me when they tried the selective/qualified update experiment to stop XP systems getting a beta if they weren't allowed on XP was another problem area as it still let me install a beta that shouldn't have been allowed and the only way round that was a clean reinstall.
3. The last two rounds of beta testing (for XP) and release for 10.4.x and 11.1.x have for me been probably the least stable of all of the betas I have taken part in in over 11 years.
1. I doubt it, as the same problems/bugs are still showing up...
2. Was on vacation back than, so I missed all the "fun".
3. Well, it works/worked well, if HTTPS-scanning is disabled, so we know the culprit.
Win 8.1 [x64] - Avast PremSec 20.9.2435.Beta#3 [UI.575] - CC 5.73 - EEK - FF ESR 78.4 [NS/AOS/uBO/PB] - TB 78.4 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83965
  • No support PMs thanks
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #4 on: October 24, 2015, 08:22:20 PM »
For me simply disabling HTTPS didn't seem to be enough.

I had also to stop and restart the web shield and then ultimately have to enable HTTPS again, weird or what.

Along the way, there was a point in time when with https scanning disabled, statstics showed https pages still being scanned.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 67440
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #5 on: October 25, 2015, 06:04:25 AM »
Strange. Did you try a clean reinstall yet..!?
Win 8.1 [x64] - Avast PremSec 20.9.2435.Beta#3 [UI.575] - CC 5.73 - EEK - FF ESR 78.4 [NS/AOS/uBO/PB] - TB 78.4 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83965
  • No support PMs thanks
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #6 on: October 25, 2015, 03:25:54 PM »
Strange. Did you try a clean reinstall yet..!?

Not for this beta update, but with the hassle on earlier beta updates I had done a clean install at 2016 beta. And that didn't resolve any prior issues, in fact I seem to have had more hassle with 2016 than any other given I started out with a clean install.

For beta testing I generally do a program update from the UI as that is what I think most users do in regard of program updates.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 67440
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #7 on: October 25, 2015, 08:21:42 PM »
Unfortunately, we can only wait (and hope) for input from the devs...
Win 8.1 [x64] - Avast PremSec 20.9.2435.Beta#3 [UI.575] - CC 5.73 - EEK - FF ESR 78.4 [NS/AOS/uBO/PB] - TB 78.4 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83965
  • No support PMs thanks
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #8 on: October 25, 2015, 09:33:36 PM »
Yep, that is what I'm hoping for.

What makes this more frustrating is it will work for a while without issue and then loading effectively stops. Then I have to do my dance with the web shield. For now I have the https scanning option disabled, fingers crossed it is working.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline davexnet

  • Poster
  • *
  • Posts: 537
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #9 on: October 26, 2015, 05:19:23 PM »
I've been looking around on the interwebs, other A/V's that have tried XP SSL scanning have also experienced
similar problems.  Perhaps the whole thing in XP is a bit of a kludge and will never work properly...
AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83965
  • No support PMs thanks
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #10 on: October 26, 2015, 06:30:50 PM »
Well I think it could be deeper than HTTPS scanning as I have had it off for a day or so now, but I again experienced issues when browsing the yahoo Portal https://uk.yahoo.com/.

The same symptoms as before, pages not loading, stopping the web shield and trying to browse/refresh the pages didn't do anything until I re-enabled the web shield.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline davexnet

  • Poster
  • *
  • Posts: 537
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #11 on: October 26, 2015, 06:57:42 PM »
Yes I see what you're saying.  I have reverted back to 2218 at least twice now, and this is what I'm running on my XP pc's.
But the symptoms you describe point to a general lack of stability.  Where the problem actually is,
I don't know.

I would have assumed that turning off SSL scanning in the latest releases would be equivalent to 2218 where it was not implemented -
but it doesn't seem to be.  I've seen higher CPU in the task manager even with SSL scanning off, compared to 2218.
AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83965
  • No support PMs thanks
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #12 on: October 28, 2015, 07:21:58 PM »
This problem is still present in 11.1.2238 avast 2016 RC1 - why does that not surprise me it has been around for quite some time.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline davexnet

  • Poster
  • *
  • Posts: 537
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #13 on: October 28, 2015, 07:43:27 PM »
For me, avast development cycle lacks any credibility.  If SSL scanning in XP is not reliable it should be dropped.
If it's a problem in avast and the XP infrastructure is sound, avast should explain the situation in full detail.

avast's behavior is more reminiscent of an unaccountable mad professor than a professional software organization.


AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83965
  • No support PMs thanks
Re: Beta 4 - 11.1.2237 - XP SP3 and HTTPS scanning in Firefox 41.0.2
« Reply #14 on: October 28, 2015, 08:19:13 PM »
For me, avast development cycle lacks any credibility.  If SSL scanning in XP is not reliable it should be dropped.
If it's a problem in avast and the XP infrastructure is sound, avast should explain the situation in full detail.

avast's behavior is more reminiscent of an unaccountable mad professor than a professional software organization.

Sorry but I completely disagree with your analogy.

Part of the problem is XP is old and doesn't have the functionality (APIs) that would ordinarily be used in other OSes. So in trying to continue support for XP (unlike many others) they tried another method. But that in itself may have had issues and depending on what SP was installed the additional method wasn't working 100%.

In the end some restrictions in what SP was required to be able to support https scanning and that was SP3. So those without SP3 probably couldn't have the HTTPS scanning function, but why I ask myself would they still be on SP2 when SP3 is eons old.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security