Author Topic: 'my.avast.com' is mostly innaccurate  (Read 4857 times)

0 Members and 1 Guest are viewing this topic.

Offline Vladimyr

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1639
  • Super(massive black hole) Poster
'my.avast.com' is mostly innaccurate
« on: October 30, 2015, 03:49:32 PM »
Having moved most of my PCs to 'Avast for Business' some time ago, I was curious to see if the accuracy of 'my.avast.com' had improved since I last checked.

Sadly, no. So messed-up is the info there provided that it's more harmful than helpful.

8 devices are listed.

2 are Windows PCs showing green "You are protected" dots,
1 is accurately reported (Avast Internet Security)
The other tells me the license expired on 28/08/2015 when the program itself assures me I have 290 days remaining (Avast Free).

3 are Android devices showing green "You are protected" dots,
1 is accurately reported
1 has not had Avast on it since February.
And the other, I reset and returned to the retailer for credit in March 2014 (yet still it proclaims that the "current battery state" is 54%).

The remaining 3 are Windows PCs showing red dots.
All 3 no longer have Avast installed but the portal just tells me things like "Shields are turned off".

Any chance of fixes?

There is a way that seems right to a man,
       but in the end it leads to death
.” - Proverbs 16:25

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7111
  • When you think you know, Think Again
Re: 'my.avast.com' is mostly innaccurate
« Reply #1 on: November 02, 2015, 06:16:41 PM »
Frankly,I stopped watching my Account a long time ago due to the lack of accurate/up to date information/statistics and it doesn't add or take away from my security so for me I see it as useless.
***HP ENVY 15K LT W10 Pro 21H2 64Bit/250GB SSD/16GB Ram/ADU v.22.2b/VS/SANDBOXIE-plus/MailWasherPRO
**HP Compaq 8510p LT W10 Pro 21H2 64Bit/1TB HD/8GB Ram/ADU v.22.2b/VS/SANDBOXIE/HotSpot Shield
 Avast Mobile Security (Android)
LAYERED SECURITY SOFTWARE

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86500
  • No support PMs thanks
Re: 'my.avast.com' is mostly innaccurate
« Reply #2 on: November 02, 2015, 06:54:50 PM »
I have found it to be inaccurate - to the point that it barely worth visiting it.

I have one PC, 1 Netbook and avast Mobile, yet it shows two PC devices. Some time ago it was doing this so I changed the Device name, now it shows two devices, which are one and the same PC. It is showing both are on-line, great, but only one shows license information and that is &*%^dy wrong.

So it is pretty much a waste of time currently - going to try deleting one of the devices again - but that invariably removes both entries.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31222
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: 'my.avast.com' is mostly innaccurate
« Reply #3 on: November 02, 2015, 07:23:27 PM »
Just looked at my.avast.com...

I can't even scroll down on the main site.
Even not with the scrollbar in my browser !

Except for the menu options, there is no link at the page that even works !
Quote
You don't have any Avast licenses yet.
I don't ? Totally BS! Except for (some) trials, you need (as far as I know) a license. Either a free or a paid one.

And the reward system...
How long needs it be in "beta" before they have enough data to setup at least some sort of reward system ?

The real problem is the management of avast.
For them it is "all about the money".

I have received several things from avast for free without asking for them and without doing anything special.
- Ballpoint
- Desktop clock/thermometer
- T-Shirts

Only thing I did (and still am sometimes doing) is trying to help people on this webboard.

Offline OndraM

  • Moderator
  • Full Member
  • *
  • Posts: 147
Re: 'my.avast.com' is mostly innaccurate
« Reply #4 on: November 03, 2015, 05:15:41 PM »
I am afraid that you are right. my.avast.com was originally an afterthought based on the data gather on our backends. This left us with a few problems, mainly concerning data accuracy. The biggest one being the fact, that in lots of cases we failed to detect that Avast account was deleted from the device, or Avast completely uninstalled.

With Avast 2016 we are putting new communication channels in place that will improve the data accuracy. Moreover, it will enable 2-way communication, so hopefully my.avast.com situation will improve in the near future..

Offline tomas.tunkl

  • Avast team
  • Newbie
  • *
  • Posts: 10
Re: 'my.avast.com' is mostly innaccurate
« Reply #5 on: November 04, 2015, 03:45:58 PM »
Having moved most of my PCs to 'Avast for Business' some time ago, I was curious to see if the accuracy of 'my.avast.com' had improved since I last checked.

Sadly, no. So messed-up is the info there provided that it's more harmful than helpful.

8 devices are listed.

2 are Windows PCs showing green "You are protected" dots,
1 is accurately reported (Avast Internet Security)
The other tells me the license expired on 28/08/2015 when the program itself assures me I have 290 days remaining (Avast Free).

3 are Android devices showing green "You are protected" dots,
1 is accurately reported
1 has not had Avast on it since February.
And the other, I reset and returned to the retailer for credit in March 2014 (yet still it proclaims that the "current battery state" is 54%).

The remaining 3 are Windows PCs showing red dots.
All 3 no longer have Avast installed but the portal just tells me things like "Shields are turned off".

Any chance of fixes?

Hi, I am from Avast Account development team. About the problem with Avast no longer installed. We are trying to do our best, but there is a problem. For Windows, it is quite easy. When the client is uninstalled we get the notification and remove it from myAvast page. This almost always works. If you throw the PC from window, and the application does not have the chance to  tell us, we cannot remove it from web. For Android, it is as throwing the PC from window. If you uninstall the application, Android does not notify the application and just deletes it. So no way we can let the myAvast know. There is only one exception, which is, if there is another Avast application we can tell that the other one is gone.

So the problem is: For some cases we dont know the application disappeared. What do you propose? We could hide every device which didnt contact us for 7 days for example. But what if you just went to holiday? :) I would really like to know your opinion, since this is something we are trying to solve for some time. Maybe we could create some special "section" for such devices, so they would not be visible in regular list of devices, but if you need them, you can still find them, or force them to be in the main list.

Thanks for any opinion
Tom

brandon@password-plus.com

  • Guest
Re: 'my.avast.com' is mostly innaccurate
« Reply #6 on: November 09, 2015, 01:50:50 PM »
When I schedule an auto-scan (full scan) every week, I do not get the 3 points for scheduling the auto-scan nor the 5 points for the full scan. I also do not get the points for running Avast Browser Cleanup once a week.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86500
  • No support PMs thanks
Re: 'my.avast.com' is mostly innaccurate
« Reply #7 on: November 09, 2015, 04:28:41 PM »
When I schedule an auto-scan (full scan) every week, I do not get the 3 points for scheduling the auto-scan nor the 5 points for the full scan. I also do not get the points for running Avast Browser Cleanup once a week.

I thought that it was the Smart Scan that counts - on checking my.avast.com account I see that I got 5 points for a full scan. I don't run scheduled scans so I can't say if that works for me. I generally only run a scan when testing something and that is usually related to something mentioned in the forums.

I do know that it may not happen instantly but could take a little time. But mine seems to have been credited relatively soon, less than a  day.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security