Author Topic: You are unprotected - Avast background service is not running  (Read 24237 times)

0 Members and 1 Guest are viewing this topic.

Offline Fluffhead_81

  • Newbie
  • *
  • Posts: 10
You are unprotected - Avast background service is not running
« on: December 28, 2015, 04:58:38 PM »
I have searched all over the forums and other websites and tried a variety of things to solve this with no luck. I really like Avast and would love to continue using it! Any ideas from anyone?

My Avast (2016, version 11.1.2245 at the moment - running on Windows 10 64 bit) starts fine with Windows, then about a half hour later no matter what I do stops running and it says "You are unprotected - Avast background service is not running". If I click "Resolve all" it starts working again (and asks me to restart Windows). Whether I restart or not, it will stop running again.


What I've tried so far:

Attempt 1
Uninstall Avast via Control Panel and re-install latest version

Attempt 2
Repair Avast:
1. Control Panel -> Add/Remove programs -> Avast
2. Click on 'Repair'.
3. Follow instructions.
4. Reboot.

Attempt 3
Update Avast:
1. Control Panel -> Add/Remove programs -> Avast
2. Click on 'Update'.
3. Follow instructions.
4. Reboot.

Attempt 4
Right click on Avast icon in the system tray, select “Avast Shields Control > select “Disable until Computer is restarted”
Restart the Computer

Attempt 5
1. From Start Menu > open Run command box and type “services.msc” (without quotes)
2. Try to “Start” Avast Service if stopped as reported by Avast and make sure “Startup type” is set to “Automatic”.
Avast Service (note: it was already set to Automatic, so this didn't do anything)
3. Restart your Computer.

Attempt 6
1. Download and run Avast Uninstall Utility in safe mode.
2. After uninstallation, re-install Avast new version and register your free copy.

Attempt 7
I followed all the steps on this page, which basically had me ensure no conflicting programs exist (they don't), run the avast uninstall utility, and install with an offline installer
https://forum.avast.com/index.php?topic=143284.0

I also tried to disable Spybot Search & Destroy and CCleaner (which didn't do anything).

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 10898
  • No support PM's thanks
Re: You are unprotected - Avast background service is not running
« Reply #1 on: December 28, 2015, 05:09:10 PM »
Try uninstalling Spybot then reboot and run a repair of Avast followed by another reboot.

Offline Fluffhead_81

  • Newbie
  • *
  • Posts: 10
Re: You are unprotected - Avast background service is not running
« Reply #2 on: December 28, 2015, 09:11:49 PM »
Hi CraigB - I just did that and it happened again. It was fine for an hour or so, then the service stopped again.

Any other ideas?

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31366
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: You are unprotected - Avast background service is not running
« Reply #3 on: December 28, 2015, 09:50:49 PM »
Run Farbar and attach FRST.txt and Addition.txt to your next post.
Perhaps they show a possible cause.

http://www.bleepingcomputer.com/download/farbar-recovery-scan-tool/

Offline Fluffhead_81

  • Newbie
  • *
  • Posts: 10
Re: You are unprotected - Avast background service is not running
« Reply #4 on: December 28, 2015, 11:20:05 PM »
Here are the files. I edited out some things that don't seem applicable to this issue. Thank you for the help!

FRST: http://freetexthost.com/1bmamwrhfv
Addition: http://freetexthost.com/2ff6wauthf

FYI, I noticed these in Addition.txt:

Error: (12/28/2015 02:44:56 PM) (Source: Service Control Manager) (EventID: 7034) (User: )
Description: The Avast Antivirus service terminated unexpectedly.  It has done this 4 time(s).

Error: (12/28/2015 11:18:42 AM) (Source: Service Control Manager) (EventID: 7031) (User: )
Description: The Avast Antivirus service terminated unexpectedly.  It has done this 3 time(s).  The following corrective action will be taken in 5000 milliseconds: Run the configured recovery program.

Error: (12/28/2015 11:08:29 AM) (Source: Service Control Manager) (EventID: 7031) (User: )
Description: The Avast Antivirus service terminated unexpectedly.  It has done this 2 time(s).  The following corrective action will be taken in 5000 milliseconds: Restart the service.

Error: (12/28/2015 10:58:15 AM) (Source: Service Control Manager) (EventID: 7031) (User: )
Description: The Avast Antivirus service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 5000 milliseconds: Restart the service.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31366
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: You are unprotected - Avast background service is not running
« Reply #5 on: December 29, 2015, 12:01:09 AM »
I did say attach them to your post.

Offline Fluffhead_81

  • Newbie
  • *
  • Posts: 10
Re: You are unprotected - Avast background service is not running
« Reply #6 on: December 29, 2015, 12:23:17 AM »
Sorry, I don't know how to attach a file, and the text is too long to paste in here (I reach a character limit). If you tell me what I should do, I'll try it.

Online bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 41289
  • 59 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: You are unprotected - Avast background service is not running
« Reply #7 on: December 29, 2015, 12:27:27 AM »
Sorry, I don't know how to attach a file, and the text is too long to paste in here (I reach a character limit). If you tell me what I should do, I'll try it.
Free avast! Security Seminar: https://goo.gl/kh3cqR  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1903 64bit, 8 Gig Ram, AvastFree 19.6.xxxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Fluffhead_81

  • Newbie
  • *
  • Posts: 10
Re: You are unprotected - Avast background service is not running
« Reply #8 on: December 29, 2015, 02:01:31 AM »
Totally missed that! Here they are.
« Last Edit: December 30, 2015, 02:34:01 AM by Fluffhead_81 »

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31366
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: You are unprotected - Avast background service is not running
« Reply #9 on: December 29, 2015, 01:59:13 PM »
We need the full logs, not edited ones.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11678
    • AVAST Software
Re: You are unprotected - Avast background service is not running
« Reply #10 on: December 29, 2015, 05:54:52 PM »
If you check the folder C:\ProgramData\AVAST Software\Avast\log, are there any (recent) files called unpXXXXXXXX.mdmp there? (where X are some numbers)
If so, can you upload one of them to ftp://ftp.avast.com/incoming and let us know the filename?
Thanks.

Offline nompere2004

  • Newbie
  • *
  • Posts: 10
Re: You are unprotected - Avast background service is not running
« Reply #11 on: December 29, 2015, 07:07:33 PM »
I am having exactly the same problem. I think Avast needs to sort out a fix. I am constantly having to check whether it is switched on or has switched itself off. If it has switched off there is the annoyance of having to restart the computer. i am not a computer expert and the possible fixes I have seen seem to be aimed at computer experts. I am seriously considering another anti-virus brand. A pity as I have used Avast for many, many years.

Offline Andrey,pro

  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5017
  • Things happen
Re: You are unprotected - Avast background service is not running
« Reply #12 on: December 29, 2015, 07:23:49 PM »
Hello nompere2004 and welcome to avast support forum!

Can you please follow igor's instructions above and check if there is any minidump files in C:\ProgramData\AVAST Software\Avast\log folder.

Thanks.

Offline Fluffhead_81

  • Newbie
  • *
  • Posts: 10
Re: You are unprotected - Avast background service is not running
« Reply #13 on: December 29, 2015, 07:52:19 PM »
Eddy: Sorry to be a pain, but I don't feel comfortable posting un-filtered log files on a public forum. I only cut out the host file and some download history, so a bulk of the info is still there. If you're not able to help using the files as is, I appreciate your willingness to help and apologize for wasting your time.

igor: I don't seem to have a /log folder. I have a log.dll, but no log folder.

Offline nobacktrail

  • Newbie
  • *
  • Posts: 2
Re: You are unprotected - Avast background service is not running
« Reply #14 on: December 29, 2015, 08:57:27 PM »
I'm new at this forum and haven't figured out how to post regarding a previously reported problem.
I am also having the Yellow triangle on Avast tray icon problem that says "Attention, your system is not fully protected.  It originally started as a small box containing an "x" on the tray icon.  When I right clicked the tray icon and clicked on shields, it said I had three (3) background ... that were not running.  I clicked on "Resolve problems" and nothing happened.  Same thing when I clicked on "Start now".  After trying the uninstall repair option and rebooting when it said to do so, the problem was still there.  I uninstalled Avast and downloaded the free version installer and executed it.  That's when the Avast tray icon Yellow triangle started manifesting in place of the small "x" box.

Is there no way of reporting a problem directly to Avast or is this forum the only recourse?