Author Topic: HTTP server returned error?  (Read 6916 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
HTTP server returned error?
« on: December 30, 2015, 02:51:22 AM »
Is Avast still having issues with their update servers? I got a notification that my virus definitions are out of date, but every time I try to update them, I get this message: "Last encountered error: Error: HTTP server returned error". I have seen several threads here for a different error message, so before I right this off as the same issue, I wanted to ask.

Avast Free Version (2015?)
Program: 11.1.2245
Definitions: 151228-2
Windows 7 Ultimate


Side Note: I tried downloading the updates manually from the Avast website ("Avast VPS update for versions 2014 to 2015"), but when I try to run it, I get an error message that states, "vpsupd.exe is not a valid Win32 application." It won't run. What gives?


EDIT: Original issue of update failing seems to resolved itself. Still not able to use the true manual update from the website, though. :c
« Last Edit: December 30, 2015, 09:14:26 PM by Riannon »

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31078
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: HTTP server returned error?
« Reply #1 on: December 30, 2015, 03:03:37 AM »
11.1.2245 = 2016.11.1.2245  ;)

You are 3 vps updates behind.
Latest one is 20151229-2
https://www.avast.com/virus-update-history

The problem seems to be solved, according to a post from a avast team member
Try a manual update.

REDACTED

  • Guest
Re: HTTP server returned error?
« Reply #2 on: December 30, 2015, 04:32:09 AM »
Is Avast still having issues with their update servers? I got a notification that my virus definitions are out of date, but every time I try to update them, I get this message: "Last encountered error: Error: HTTP server returned error". I have seen several threads here for a different error message, so before I right this off as the same issue, I wanted to ask.

Avast Free Version (2015?)
Program: 11.1.2245
Definitions: 151228-2
Windows 7 Ultimate


Side Note: I tried downloading the updates manually from the Avast website ("Avast VPS update for versions 2014 to 2015"), but when I try to run it, I get an error message that states, "vpsupd.exe is not a valid Win32 application." It won't run. What gives?


Thank you for responding and passing on the info on the virus definitions, but as I said, the update available on the website is not running. My system keeps telling me it's "not a valid Win32 application." There isn't an option for Avast 2016, and the "2014 to 2015" isn't working for me  :(
Update download site: https://www.avast.com/download-update
« Last Edit: December 30, 2015, 04:37:22 AM by Riannon »

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31078
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: HTTP server returned error?
« Reply #3 on: December 30, 2015, 04:36:52 AM »
As I said, try a manual update.
Right click the avast icon near the clock > update > Engine and virus definitions

REDACTED

  • Guest
Re: HTTP server returned error?
« Reply #4 on: December 30, 2015, 04:41:29 AM »
That's where I see the error message. When I got the notification about out-of-date definitions, I went to update them "manually" as you instructed (before I came here for help).

Going to try repairing the program, and will update this post once the reboot is completed.
EDIT: The repair does not seem to have helped. I'm still getting the same error when I try to manually update.


EDIT 2: If it helps, the file it seems to be getting stuck on is "part-jrog2-f9a.vpx.dld", and the most recent server info it gave me is, "Download d7847891 AVAST9 Server, http://d7847891.ivps9x.u.avast.com/ivps9x" (though it has happened with numerous servers now).
« Last Edit: December 30, 2015, 04:59:32 AM by Riannon »

REDACTED

  • Guest
Re: HTTP server returned error?
« Reply #5 on: December 30, 2015, 07:17:21 AM »
Same thing.

REDACTED

  • Guest
Re: HTTP server returned error?
« Reply #6 on: December 30, 2015, 08:33:22 AM »
still getting the same error on avast pro antivirus