Author Topic: Mail Shield hangs El Capitan imap, syncing, logs, crashes Mail, overuses CPU etc  (Read 5493 times)

0 Members and 1 Guest are viewing this topic.

Offline DrTodd

  • Newbie
  • *
  • Posts: 4
I use El Capitan Mail and have a dozen or so imap accounts in addition to a few pop accounts. I only converted the imap accounts from pop a few days. Since then, Mail has been hanging, crashing, not filing or deleting messages without them returning to the inbox on restart, not syncing properly with my devices, and using CPU resources that are almost always at least 200% and many times as high as 450% (4 gHz i7 5K iMac, OSX 11.2), causing overheating and fans to run extensively.

This has also resulted in 100GB of Mail log files being generated every 24 hours!

All these issues disappeared when disabling Avast Mail Shield.

I would be happy to provide more information if desired. Meanwhile, I'd sure appreciate a fix for Avast Mail Shield so that I may enable it again.


I have examined Console and found hundreds of Avast errors. This is a sample. In just one minute there were 135 of these!

1/25/16 2:15:51.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_IMAPConnection-santro.websitewelcome.com.log [40]
1/25/16 2:15:51.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_IMAPConnection-santro.websitewelcome.com.log [40]
1/25/16 2:15:52.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_SocketStreamEvents.log [40]
1/25/16 2:15:52.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_IMAPConnection-santro.websitewelcome.com.log [40]
1/25/16 2:15:53.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_Library.log [40]
1/25/16 2:15:53.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_SocketStreamEvents.log [40]
1/25/16 2:15:54.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_Library.log [40]
1/25/16 2:15:54.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_Library.log [40]
1/25/16 2:15:55.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_SocketStreamEvents.log [40]
1/25/16 2:15:55.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_SocketStreamEvents.log [40]
1/25/16 2:15:56.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_SocketStreamEvents.log [40]
1/25/16 2:15:56.000 PM kernel[0]: com.avast.fileshield Warning: Unable to send req. /Users/todd/Library/Containers/com.apple.mail/Data/Library/Logs/Mail/2016-01-25_IMAPConnection-santro.websitewelcome.com.log [40]

Offline canetree

  • Newbie
  • *
  • Posts: 7
I copied the relevant console data immediately following a Mail launch when Getting New Mail is hanging up. Looks like the Avast proxy is implicated:

1/27/16 3:34:23.003 PM Mail[2081]: Stream 0x7f9f1e2169e0 is sending an event before being opened
1/27/16 3:34:26.779 PM sharingd[557]: 15:34:26.779 : SDConnectionManager:: XPC connection invalidated
1/27/16 3:34:26.807 PM com.apple.xpc.launchd[1]: (com.apple.WebKit.WebContent.BBC736D8-FECE-4396-AD39-512D6E18C631[4641]) Service exited with abnormal code: 1
1/27/16 3:34:37.564 PM Mail[5075]: Stream 0x7fa674358380 is sending an event before being opened
1/27/16 3:34:37.819 PM Mail[5075]: Stream 0x7fa672e050d0 is sending an event before being opened
1/27/16 3:34:37.825 PM Mail[5075]: Stream 0x7fa6742300c0 is sending an event before being opened
1/27/16 3:34:37.835 PM Mail[5075]: Stream 0x7fa674065eb0 is sending an event before being opened
1/27/16 3:34:37.949 PM secd[634]:  SOSAccountThisDeviceCanSyncWithCircle sync with device failure: Error Domain=com.apple.security.sos.error Code=1035 "Account identity not set" UserInfo={NSDescription=Account identity not set}
1/27/16 3:34:38.006 PM Mail[5075]: Stream 0x7fa674548120 is sending an event before being opened
1/27/16 3:34:38.476 PM com.avast.proxy[410]: Defective IMAP response!
1/27/16 3:34:38.476 PM com.avast.proxy[410]: * 4699 FETCH (UID 17671 MODSEQ (291598475406328))
6.4 OK Completed
1/27/16 3:34:38.799 PM com.avast.proxy[410]: Defective IMAP response!
1/27/16 3:34:38.799 PM com.avast.proxy[410]: * 5972 FETCH (UID 148581 MODSEQ (291598475709213))
* 5973 FETCH (UID 148582 MODSEQ (291598475709443))
6.1 OK Completed
1/27/16 3:34:39.229 PM com.avast.proxy[410]: Defective IMAP response!
1/27/16 3:34:39.229 PM com.avast.proxy[410]: * 4698 FETCH (UID 17670 MODSEQ (291598476159935))
5.6 OK Completed
1/27/16 3:34:42.804 PM sandboxd[154]: ([5075]) Mail(5075) deny mach-lookup com.apple.GSSCred
1/27/16 3:34:44.741 PM accountsd[633]: AIDA Notification plugin running
1/27/16 3:34:44.747 PM accountsd[633]: AIDA Notification plugin running

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
I copied the relevant console data immediately following a Mail launch when Getting New Mail is hanging up. Looks like the Avast proxy is implicated:

1/27/16 3:34:23.003 PM Mail[2081]: Stream 0x7f9f1e2169e0 is sending an event before being opened
1/27/16 3:34:26.779 PM sharingd[557]: 15:34:26.779 : SDConnectionManager:: XPC connection invalidated
1/27/16 3:34:26.807 PM com.apple.xpc.launchd[1]: (com.apple.WebKit.WebContent.BBC736D8-FECE-4396-AD39-512D6E18C631[4641]) Service exited with abnormal code: 1
1/27/16 3:34:37.564 PM Mail[5075]: Stream 0x7fa674358380 is sending an event before being opened
1/27/16 3:34:37.819 PM Mail[5075]: Stream 0x7fa672e050d0 is sending an event before being opened
1/27/16 3:34:37.825 PM Mail[5075]: Stream 0x7fa6742300c0 is sending an event before being opened
1/27/16 3:34:37.835 PM Mail[5075]: Stream 0x7fa674065eb0 is sending an event before being opened
1/27/16 3:34:37.949 PM secd[634]:  SOSAccountThisDeviceCanSyncWithCircle sync with device failure: Error Domain=com.apple.security.sos.error Code=1035 "Account identity not set" UserInfo={NSDescription=Account identity not set}
1/27/16 3:34:38.006 PM Mail[5075]: Stream 0x7fa674548120 is sending an event before being opened
1/27/16 3:34:38.476 PM com.avast.proxy[410]: Defective IMAP response!
1/27/16 3:34:38.476 PM com.avast.proxy[410]: * 4699 FETCH (UID 17671 MODSEQ (291598475406328))
6.4 OK Completed
1/27/16 3:34:38.799 PM com.avast.proxy[410]: Defective IMAP response!
1/27/16 3:34:38.799 PM com.avast.proxy[410]: * 5972 FETCH (UID 148581 MODSEQ (291598475709213))
* 5973 FETCH (UID 148582 MODSEQ (291598475709443))
6.1 OK Completed
1/27/16 3:34:39.229 PM com.avast.proxy[410]: Defective IMAP response!
1/27/16 3:34:39.229 PM com.avast.proxy[410]: * 4698 FETCH (UID 17670 MODSEQ (291598476159935))
5.6 OK Completed
1/27/16 3:34:42.804 PM sandboxd[154]: ([5075]) Mail(5075) deny mach-lookup com.apple.GSSCred
1/27/16 3:34:44.741 PM accountsd[633]: AIDA Notification plugin running
1/27/16 3:34:44.747 PM accountsd[633]: AIDA Notification plugin running
What email client (exact version) do you use? What mail server (mail provider) do you use?

Offline canetree

  • Newbie
  • *
  • Posts: 7
Using Apple Mail 9.2 build 3112. These errors appear to occur syncing with my primary iCloud account (formerly MobileMe/.Mac) I'm on the latest build of OS X 10.10.3.

Offline Secondmineboy

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3651
Using Apple Mail 9.2 build 3112. These errors appear to occur syncing with my primary iCloud account (formerly MobileMe/.Mac) I'm on the latest build of OS X 10.10.3.

Just one thing tossing in here, you not using the newest release of OSX (10.11.3)   :)
Windows 10 1909, 4 GB DDR3 RAM, 500 GB 5400 RPM HDD, 1366 by 768 LCD Screen, Intel Core i3 5010U Dual Core, Intel HD Graphics 5500
HUAWEI P30 Pro. Android 10

Offline canetree

  • Newbie
  • *
  • Posts: 7
Sorry, typo ;) it is indeed 10.11.3

Offline mity

  • Avast team
  • Full Member
  • *
  • Posts: 149
@DrTodd: Thanks for reporting the issue. I've sent you a private message with my contact info and few questions so we can analyze the issue.

Offline Ziggyke

  • Newbie
  • *
  • Posts: 3
Maybe this can help troubleshooting the problem.

I'm running on Mac OSX version: 10.11.1 with Mail version: 9.1 build 3096.5 and don't have this problem.
My Avast program version is: 11.5.45630
Can someone else confirms this?

A little bit research learns that upgrading to 10.11.2 & 10.11.3, which at this moment are impacted with this problem, has Mail version: 9.2 build 3112 installed.

Source: https://discussions.apple.com/message/29547585#29547585 (the problem described in this discussions has nothing to do with this problem, but it shows a log of the Apple Mail application)

Hopefully Avast can find and isolate this problem for the impacted customer who use Avast on Mac in combination with Mail.
« Last Edit: February 03, 2016, 07:10:19 PM by Ziggyke »

Offline jgelfond

  • Newbie
  • *
  • Posts: 10
I am also having this issue. Using Avast 11.5 (45630) and Ep Cap 10.11.3 when my iCloud mail account is enabled and Avast's mail shield is enabled Mail eats CPU cycles (100-200% constantly) and Mail has problems syncing changes (e.g. deleting or moving mail to folders) to the server.  Disabling the mail shield fixes the issue.

I want to make sure my logs are not eating up my hard disk space as another user reported. How can I do that?

Offline jgelfond

  • Newbie
  • *
  • Posts: 10
Avast has failed me in multiple ways over the past few weeks.

Not only is there no response to this issue that's significantly affecting iCloud accounts (and it took a significant troubleshooting effort to uncover that it was Avast that was causing my Mail problems...time I will never get back).

Avast also blocked my VPN service, Hotspot Shield, the other day. HSS said they were investigating with Avast but never heard from Avast.

And, I was considering switching to Avast's VPN but over a week after a support inquiry regarding details of the VPN software, Avast never responded.

I have recommended Avast Mac to clients in the past, but I'm not sure I can do that anymore with 3 black eyes and no responsiveness from support via official channels or the forum.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
The 11.7. update which is out since yesterday should fix the issues with iCloud.

Offline DrTodd

  • Newbie
  • *
  • Posts: 4
While I had these horrible issues with 10.11.2, updating to 10.11.3 lessened them, though I didn't have a chance to confirm that it eliminated them before yesterday. However, Avast auto-updated to 11.7 a couple of days ago and I now see no anomalous behavior. Logs aren't growing to GBs in size and CPU resources are no longer monopolized. I also see that Mail doesn't hang on checking mail as it did before.

So, with Avast 1.7 and El Capitan 10.11.3 (at least, & maybe also with 10.11.2) the issues appear to have been solved.