Author Topic: Avast 11.7 Causing Problems with Apple Reseller Landing Page  (Read 1582 times)

0 Members and 1 Guest are viewing this topic.

Offline pod_flu1_as

  • Newbie
  • *
  • Posts: 2
Avast 11.7 Causing Problems with Apple Reseller Landing Page
« on: February 23, 2016, 05:41:14 PM »
I've just experienced an odd problem on two new (late 2015) MacBook Pros both running Avast 11.7.   Both join the home network and I suspect most other networks with no problem.   However, the owner is taking lessons at a branch of the Stormfront Apple reseller here in the UK.  The store has open access to its WiFi, but sends a landing page into which the user must log.   Avast blocks the landing page - it just doesn't appear.

Turning WebShield off doesn't solve the problem and allow the landing page to appear.  The only thing that works is to completely uninstall Avast, reboot the Mac and then the landing page appears immediately.  Clearly, this isn't a satisfactory state of affairs. 

Just to make thinks really odd, my old (late 2009) MacBook Pro, also running Avast and set up seemingly in the same way as the first two has absolutely no problem and sees the landing page.

Has anyone else experienced similar problems or can suggest a solution, otherwise I will have to find an alternative.

Offline pod_flu1_as

  • Newbie
  • *
  • Posts: 2
Re: Avast 11.7 Causing Problems with Apple Reseller Landing Page
« Reply #1 on: February 24, 2016, 12:09:50 PM »
I think I may have found the answer to this problem - after hours of ploughing through forum entries on seemingly peripherally related topics.  It's yet another example of how Avast handles certificates from HTTPS sites.   The following document from Avast explains the detail:  http://public.avast.com/~tuma/techinfo/

It may be that the store's signed CA certificate (ie one from a trusted Certificate Authority - is un-verifiable, self-signed or expired, or that Avast's resigning of the certificate is not "liked" by the client; or Avast resigns the certificate as "untrusted" and so the connection isn't made.  Or, perhaps, the certificate used by the Sormfront store has been revokedor is invalid in some other way, Avast "refuses" to sign the certificate and the connection is dropped (this "feels" like what was happening in the store).

So the simple fixes are to whitelist the landing page, if the URL can be found, or, switch off "Scan secured connections" entirely when logging on to the store's router.  But I'll also do a bit more digging to see if the store's SSL CA certificate is valid in the first place...

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Avast 11.7 Causing Problems with Apple Reseller Landing Page
« Reply #2 on: February 29, 2016, 06:47:36 PM »
What is the exact URL causing problems?