Author Topic: Updating problems  (Read 2419 times)

0 Members and 1 Guest are viewing this topic.

weesieO

  • Guest
Updating problems
« on: December 29, 2005, 06:34:10 PM »
I am running HP IntelR CeleronR CPU 280Ghz..MW XP SP2...I couldn't install avast ,,so I started it up in safe mode and it install...but now I cannot update to newer verisons...this is the message I get....I have all administrator,,rights...

 29.12.2005 12:26:49 general: Started: 29.12.2005, 12:26:49
29.12.2005 12:26:49 general: Running setup_av_pro-28c (652)
29.12.2005 12:26:49 system: Operating system: WindowsXP ver 5.1, build 2600, sp 2.0 [Service Pack 2]
29.12.2005 12:26:49 system: Computer WinName: WEESIE
29.12.2005 12:26:49 system: Windows Net User: WEESIE\Lisa
29.12.2005 12:26:49 general: Cmdline: /downloadpkgs /noreboot /silent /progress 
29.12.2005 12:26:49 general: DldSrc set to inet
29.12.2005 12:26:49 general: Operation set to INST_OP_UPDATE_GET_PACKAGES
29.12.2005 12:26:49 general: Old version: 28c (652)
29.12.2005 12:26:49 general: SGW32P::CheckIfInstalled set m_bAlreadyInstalled to 1
29.12.2005 12:26:49 system: Computer DnsName: weesie
29.12.2005 12:26:49 system: Computer Ip Addr: 66.153.198.165
29.12.2005 12:26:49 internet: SYNCER: Type: 1
29.12.2005 12:26:49 internet: SYNCER: Auth: 2
29.12.2005 12:26:50 package: Part prg_av_pro-28c is installed
29.12.2005 12:26:50 package: Part vps-55201 is installed
29.12.2005 12:26:50 package: Part news-48 is installed
29.12.2005 12:26:50 package: Part setup_av_pro-28c is installed
29.12.2005 12:26:50 general: Old version: 28c (652)
29.12.2005 12:26:50 registry: ERROR!:Cannot access registry HKLM\SYSTEM\CurrentControlSet\Services\avastTestService, error code: 0x00000002
29.12.2005 12:26:50 general: Err:Not enough user rights to continue.

Online DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88173
  • No support PMs thanks
Re: Updating problems
« Reply #1 on: December 29, 2005, 09:04:30 PM »
I'm not sure that it will have been installed correctly in safe mode (could well be wrong) did you try to update it from safe mode?

On the install from safe mode perhaps the registry key HKLM\SYSTEM\CurrentControlSet\Services\avastTestService doesn't have read access rights to all only 'The Administrator' not those with administrator rights, you could check that.

Failing that I suggest you download the latest version 4.6.744 and save it to your HDD boot into safe mode and uninstall avast, reboot and install the latest version using 'The Administrator' account not just an account with admin rights and reboot.

From your log it looks like you have an old version 229.12.2005 12:26:49 general: Running setup_av_pro-28c (652)"
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67199
Re: Updating problems
« Reply #2 on: December 30, 2005, 08:45:31 PM »
I'm not sure that it will have been installed correctly in safe mode (could well be wrong) did you try to update it from safe mode?
avast can't be installed in Safe Mode as the Windows Installer service cannot run for installations at Safe Mode.
On contrary, avast could be uninstalled at Safe Mode.

Is there more than one account with Administrator rights?
The best things in life are free.