Author Topic: Mail not downloading with avast installed (mac el capitan)  (Read 6187 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Mail not downloading with avast installed (mac el capitan)
« on: February 29, 2016, 05:09:41 AM »
I have el capitan installed.

clicking get mail in apple mail..
i see a spike in data usage by avast.. i assume avast is downloading the mail before apple mail to scan them..( i am ok with this).

The problem is it suddenly stops downloading mail after 1 or 2 emails.
the data traffic is also negligible.. i was struggle to find the problem for the last 3 days.

thats when i though of and option and uninstalled avast for mac. now when i click get mail instead of avast now apple mail uses the traffic and thankfully the mails are downloading.

What could be the problem

Vik

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #1 on: March 11, 2016, 07:25:33 PM »
I'm having a similar problem with Avast on a 10.9.5 Mac.
Most of the mails are visible in Mail, but some not.
When I disable the mail shield in Avast, these mails can be fetched by Mail.

I'm trying to locate the Avast logfiles to dig further into this issue, but can't find them.
Any clues on why this is happening are welcome.

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #2 on: June 01, 2016, 11:29:35 PM »
Also having problems with Apple mail (all latest version mail and avast)

- some emails appear as 'text' though they are not, just as if some heading was cut
- some emails show "From ABC" in the list view, but it is in fact "From XYZ"
- some emails are online (webmail) and/or not offline (Apple Mail)

Rebuild, reboot, what ever these emails remain with their problems.
Changing few settings for Email Agent does not seems to solve the problems.

Can't find any reason.
No problem if Agent Mail is disabled.

Mac El Cap, Apple Mail, French, IP4 only (IP6 local only, off/closed on router, etc...), firewall on, host file with several 0 domain.tld, site.abc...

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #3 on: June 02, 2016, 04:22:39 PM »
Are there any related messages in the system log file?

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #4 on: June 03, 2016, 04:49:50 PM »
Thanks Tumic.

(Strange I did not received a notification/email of your answer, will check my settings... and KYI), ok was not set in forum settings.

The following concern today ONLY, Mail agent is disabled because ~5/120 emails/day were damaged.
I you tell me that you'll investigate the case, I will set back the mail agent and KYI.


My IMAP Gmail seems ok or I did not see damages.

The IMAP email concerned is my own domain with a starssl.com email certificate.
My Apple account is:
IMAP: mail.example.com - email/password
SMTP: mail.example.com - TLS Certificate - 465 Use SSL - Authenticate by email/passwowrd.
All stay stored on my server.
DNS, mail test, whatever, everything is correctly set/ok.

The only 'special' settings:
- I do not use my ISP DNS Resolvers, I use public ones, for privacy.
- ~100 lines in host file to block them but not my domain, some for Google domain though
e.g.
0 doubleclick.net,facebook.com

What I have noticed is that after installing Avast, I had to give again my password
for the gmail and mine.

If you want I can create you an account or email you what you need to investigate
as it seems to affect lot of mac users for several months.
I am a Software tester, that could help too ;-)
thank you for your help.


Console:
The only messages I see are
...... com.avast.proxy[317]: Error connecting to 0.0.0.0: Connection refused
It's almost non-stop, really like 99.9% of the lines in the log.


Sometimes
10:29:52,057 com.avast.proxy[317]: SecTrustEvaluate(): www.ublock.org: 5

OR

03/06/16 12:07:58,778 Avast[1945]: CFNetwork SSLHandshake failed (-9806)
03/06/16 12:07:58,800 Avast[1945]: CFNetwork SSLHandshake failed (-9806)
03/06/16 12:07:58,803 Avast[1945]: CFNetwork SSLHandshake failed (-9806)
03/06/16 12:07:58,804 Avast[1945]: CFNetwork SSLHandshake failed (-9806)
03/06/16 12:07:58,805 Avast[1945]: NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9806)


OR

15:47:57,735 com.avast.proxy[317]: SSL_accept(): EOF
15:47:57,735 com.avast.proxy[317]: SSL_shutdown(): shutdown while in init
15:47:57,737 com.avast.proxy[317]: SSL_accept(): EOF
15:47:57,737 com.avast.proxy[317]: SSL_shutdown(): shutdown while in init

« Last Edit: June 03, 2016, 04:55:23 PM by TraderStf »

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #5 on: June 03, 2016, 05:39:31 PM »
FYI
Mail agent is disabled already.

After disabling Web Agent:

03/06/16 17:34:03,077 com.avast.proxy[317]: SIGHUP received. Reloading...
03/06/16 17:34:05,970 com.avast.proxy[317]: swquery.apple.com:https: nodename nor servname provided, or not known

Then disabling also File Agent.

03/06/16 17:35:27,327 com.avast.fileshield[363]: Rereading config...

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #6 on: June 04, 2016, 11:12:40 AM »
com.avast.proxy[317]: Error connecting to 0.0.0.0 (OR 127.0.0.1): Connection refused
are due to a blocked site in the private/host file.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #7 on: June 06, 2016, 10:45:18 AM »
There is nothing suspicious in the logs you have posted. What mail server do you use? mail.example.com is not a valid address...

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #8 on: June 06, 2016, 11:52:59 AM »
mail.moureau.me

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #9 on: June 06, 2016, 03:20:15 PM »
The problem here is, that the server has no public mail accounts, so there is no way for us to try to reproduce the error. I have some suspicion in the short timeouts of the server, but without the possibility to test it its pure guessing...

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #10 on: June 06, 2016, 03:25:07 PM »
I can make you an email account, tumic@moureau.me.
Will it help you?
Thanks so much.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #11 on: June 06, 2016, 03:32:34 PM »
I can make you an email account, tumic@moureau.me.
Will it help you?

Yes. If I have an account, I can try to reproduce the issue, which is the first step required to fix it. You can send me the account info to tuma@avast.com.

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #12 on: August 11, 2016, 09:48:52 AM »
still the same problem, email are deleted, some are shown as text though html is in source code...

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #13 on: August 11, 2016, 01:55:17 PM »
Hmm, I still have the account in my own mail client (Apple Mail) and do get some of the newsletters (e.g. TechRepublic), but they all look ok = are HTML mails... I will try to copy the setup and try it with the latest Apple Mail (I'm on an older system than 10.11), maybe I can then see what's going on.

REDACTED

  • Guest
Re: Mail not downloading with avast installed (mac el capitan)
« Reply #14 on: August 13, 2016, 08:50:12 AM »
Code: [Select]
Thanks a lot.

(FYI mail settings are sometimes not updated... a bug, just change one 'useless' character, in the name, to get the Save? dialog.)

IP6 is disabled everywhere: tv cable modem, mac net settings (local only)
Apple Firewall activated and in Stealth mode.

In the 3 Avast Agents, all check boxes in the config are marked [x]

My Apple Mail settings:
Have one moureau.me and one gmail account.
Translated from French...

GENERAL
Take mail : automatically
Delete unmodified downloads : after msg deleted

SPAM
[x] filter spam
spam arrival : move to spam folder
do not filter :
[x] if in my contact
[x] trust spam header
[x] filter spam first

RULES
few mainly if email, move to folder or color it
(I never use delete rule)

ACCOUNT
——— MOUREAU.ME
IMAP
No TLS
SMTP : no TLS - [x] detect - 465 [x] SSL - auth:password - [ ] unsecure
ALL are set [x] store on server
sent: never delete
spam & trash : delete after 1 month


——— GMAIL
IMAP
No TLS
SMTP : no TLS - [x] detect - 587 [x] SSL - auth:none - [ ] unsecure
ALL are set [x] store on server
sent: never delete
spam & trash : delete after 1 month

[x] detect automatically settings
[x] include
[x] compact
[ ] download attach
[ ] send maildrop

Path : 'empty'
993 [x] SSL
Auth: external TLS certificat
[ ] unsecure
[x] idle


« Last Edit: August 13, 2016, 08:55:57 AM by TraderStf »