Author Topic: Avast is slowing down my internet access.  (Read 25844 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81415
  • No support PMs thanks
Re: Avast is slowing down my internet access.
« Reply #15 on: January 02, 2006, 04:12:22 PM »
WebWasher may have an effect if web shield is monitoring content and then WebWasher is filtering ads. You would need to ensure that the two proxies are working together and it would be better if ad content was removed before web shield monitors. That may well not be possible.

My Firewall can filter ad content, as can my browser firefox, all without having to use a proxy, so I don't need another ad blocker or the extra complexability.

Web Shield in my opinion is absolutly essential, Standard Shield is trying to catch something that is already on your HDD (which may be more difficult to remove), Web Shield can block before it gets on your HDD. No contest, protection in depth.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.5.2378/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Avast is slowing down my internet access.
« Reply #16 on: January 02, 2006, 04:16:14 PM »
I don't really know how to control this as avast! now uses the transparent "hook on" to the port 80. If I could use the old way (avast! beeing a proxy) I could choose who connected to the Internet. Then WebWasher could connect to the net and filter the ads, THEN avast! could scan the rest of the page, THEN IE6 could get the content :-)

The page is much smaller after WebWasher has scanned it (all commercial itemt are removed from the HTML code, not just hidden) so commercial images and scripts won't even reach IE (love WebWasher)
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Umath

  • Sr. Member
  • ****
  • Posts: 204
Re: Avast is slowing down my internet access.
« Reply #17 on: January 02, 2006, 04:22:41 PM »
?  Where is igor?

Although I don't know how it works but how about unchecking "Use intelligent stream scanning"?

Also, if you'd like to "chain" the proxies in the way you like, you can go for the good old ways.  Please use the links below.

http://www.avast.com/eng/my_isp_wants_me_to_u.html

http://www.avast.com/eng/on_my_pc_i_am_runnin.html

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Avast is slowing down my internet access.
« Reply #18 on: January 02, 2006, 04:30:02 PM »
But if I add WebWashers proxy port here (8080) and uncheck the "Ignore local communication". Won't avast! check twice (first on port 80 before WebWasher and then again later after WebWasher on port 8080) and slow down things even more that now?

I see that with the standard settings avast! will monitor port 80, and hook on before WebWasher (scanning things WebWasher later removes), and that's a waste (it removes HUGE items :-)

I can't remove port 80 from the list either can I, or is that safe (all traffic on port 80 from IE is routed trough WebWasher on port 8080).

Or will other programs (not routing through WebWasher as a proxy) then be unprotected (if they use port 80 directly that is).

Help.  Technical avast! person needed :-)
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Avast is slowing down my internet access.
« Reply #19 on: January 02, 2006, 04:47:44 PM »
Just to clearify what I'm looking for :-)

I want it to work like this:

  Internet -> WebWasher -> WebShield -> Internet browsers

I do NOT want it to work like this:

  Internet -> WebShield -> WebWasher -> Internet browsers

nor like this (if I just add WebWashers proxy I suspect this is what I get):

  Internet -> WebShield -> WebWasher -> WebShield -> Internet browser
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Umath

  • Sr. Member
  • ****
  • Posts: 204
Re: Avast is slowing down my internet access.
« Reply #20 on: January 02, 2006, 04:56:29 PM »
Non-transparent proxy.

1.Open the file avast4.ini located in C:\PROGRAM FILES\ALWIL SOFTWARE\AVAST4\DATA in Notepad.
Find the section [WebScanner]
2.In this section add the following two lines:
UpstreamProxyHost=localhost
UpstreamProxyPort=8080

3.Restart the Web Shield provider – terminate and then start again
4.Configure your browser to use Web Shield as its proxy (server: localhost, port: 12080).

Transparent proxy.

1.Open the file avast4.ini located in C:\PROGRAM FILES\ALWIL SOFTWARE\AVAST4\DATA in Notepad.
Find the section [WebScanner] in this section add the following line:
OptinProcess=my_proxy.exe
(Replace the my_proxy.exe value with the real process name of your proxy app.) If the OptinProcess line is already present in the avast4.ini file, you can add another process name to the list by separating them by commas. E.g.:
OptinProcess=my_proxy.exe, my_browser.exe

2.Restart the Web Shield provider - terminate and then start again

Sorry, but I don't know what is the process name of Web Washer...

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Avast is slowing down my internet access.
« Reply #21 on: January 02, 2006, 05:01:29 PM »
I saw that article. But won't that do the exact opposite of what I want?
(i.e. scan the web-data BEFORE WebWasher has filtered it at all).

Which one of these are true with the standard configuration
(monitor port 80, ignore local comm, IE set to proxy on WebWasher):

1) Internet -> WebWasher -> WebShield -> Browser
2) Internet -> WebShield -> WebWasher -> Browser
3) Internet -> WebShield -> WebWasher -> WebShield -> Browser

The trick is to get it to scan ONLY data between WebWasher and browser...   Or is that what happends with the standard settings.
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Umath

  • Sr. Member
  • ****
  • Posts: 204
Re: Avast is slowing down my internet access.
« Reply #22 on: January 02, 2006, 05:08:05 PM »
Did you try the way for non-transparent proxy?

For transparent proxy, I am not sure but setting "redirected HTTP port(s)" in Web Shield configuration only as 8080 may do the trick.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67276
Re: Avast is slowing down my internet access.
« Reply #23 on: January 02, 2006, 05:11:32 PM »
Is WebShield necessary?  Won't Standard Shield catch all?

But if I add WebWashers proxy port here (8080) and uncheck the "Ignore local communication". Won't avast! check twice (first on port 80 before WebWasher and then again later after WebWasher on port 8080) and slow down things even more that now?

If you use Standard Shield at HIGH sensitivity, you can disable WebShield.
But, WebShield + Standard Shield at NORMAL sensitivity, at least for me, uses less resources.

All traffic on port 80 from IE is routed trough WebWasher on port 8080).
So, why don't you uncheck 'Ignore local communication' and set WebShield to 8080 port?

Or will other programs (not routing through WebWasher as a proxy) then be unprotected (if they use port 80 directly that is).
If any other HTTP traffic passes through the port 80 and WebShield is not configurated to scan it... it won't scan.
« Last Edit: January 02, 2006, 05:18:53 PM by Tech »
The best things in life are free.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Avast is slowing down my internet access.
« Reply #24 on: January 02, 2006, 05:17:57 PM »
All traffic on port 80 from IE is routed trough WebWasher on port 8080).
So, why don't you uncheck 'Ignore local communication' and set WebShield to 8080 port?

You mean remove 80 and just have 8080 there?  Yep, that would check only the traffic between the browser and WebWasher, BUT if one program or browser accesses Internet using 80 (and not through WebWasher on 8080) that program can download web content that is not scannet at all :-(

If I keep BOTH 80 and 8080, won't Web Shield then can TWICE (before WebWasher AND after WebWasher).....   Hmmmm....  Tricky...

If the broswer uses proxy on 8080 I want that traffic to be scanned, else I want 80 to be scanned. AND traffic between WebWasher and Internet should never be scanned (that will be scanned on 8080 later instead, right :-)

:-/
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Avast is slowing down my internet access.
« Reply #25 on: January 02, 2006, 05:22:59 PM »
If you use Standard Shield at HIGH sensitivity, you can disable WebShield.

I use Custom setting for the Standard Shield. What need to be ON to make it safe. I have selected to scan some files types only (but added more than the standard). DLLs, OCXs and all program-file type are scanned. Also CLASS, scripts, web-pages extensions, JS, SWF and other binary types...
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline Umath

  • Sr. Member
  • ****
  • Posts: 204
Re: Avast is slowing down my internet access.
« Reply #26 on: January 02, 2006, 05:24:39 PM »
Lars-Erik, how about using Web Shield as non-transparent proxy only for the browser, then?  As I showed, there are two ways of setting Web Shield.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67276
Re: Avast is slowing down my internet access.
« Reply #27 on: January 02, 2006, 05:29:01 PM »
AND traffic between WebWasher and Internet should never be scanned
If you set port 80 and check 'Ignore local communication', I think you will have what you want: avoid scanning between WebWasher and browser:
Internet > WebShield acting as a proxy at port 8080 for IE > at local communication you will pass the traffic from 8080 to 80 and WebShield will take it.
Maybe I'm wrong  ::)
The best things in life are free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67276
Re: Avast is slowing down my internet access.
« Reply #28 on: January 02, 2006, 05:32:01 PM »
But added more than the standard: DLLs, OCXs.
They're scanned as text (binary files) and I don't think this will help that much.

Also CLASS, scripts, web-pages extensions, JS, SWF and other binary types...
If this is a part of WebShield scanning, why do you do that? Let them to WebShield...
The best things in life are free.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re: Avast is slowing down my internet access.
« Reply #29 on: January 02, 2006, 07:39:13 PM »
AND traffic between WebWasher and Internet should never be scanned
If you set port 80 and check 'Ignore local communication', I think you will have what you want: avoid scanning between WebWasher and browser:
Internet > WebShield acting as a proxy at port 8080 for IE > at local communication you will pass the traffic from 8080 to 80 and WebShield will take it.
Maybe I'm wrong  ::)

No I want the opposite: Avoid scanning between WebWasher and the net, and ONLY scanning between WebWaser (after its filter) and the browser.
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud