Author Topic: aswStm service failed to start due to error system cannot find file specified  (Read 4546 times)

0 Members and 1 Guest are viewing this topic.

Offline Dwarden

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1787
  • Ideas, that's ocean without borders!
    • Bohemia Interactive
the behavior was EXACTLY the same as since I reported it before (from 2015.11.2241 or maybe even lil longer)
https://forum.avast.com/index.php?topic=179243.0

the Windows DNS service got stalled
the Avast! service ceased to respond (took 5+ minutes in stopping state before stop)
A. The Avast Antivirus service entered the running state.
then on restart of service (start of the Avast! service this happened)
B. The aswStm service failed to start due to the following error:  The system cannot find the file specified.
C. The aswStm service failed to start due to the following error:  The system cannot find the file specified.
D. Application popup: Microsoft Visual C++ Runtime Library : Runtime Error!  Program: C:\Program Files\AVAST Software\Avast\AvastSvc.exe  R6025 - pure virtual function call
E. The aswStm service failed to start due to the following error:  The system cannot find the file specified.
F. The Avast Antivirus service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 5000 milliseconds: Restart the service.
G. The Avast Antivirus service entered the running state.
H. The aswStm service failed to start due to the following error:  The system cannot find the file specified.

subsequently the DNS service failed to be stopped , restarted or else, full system reboot needed

in short total mess

note: the Avast Stm is avast! StreamFilter Callout Driver
and the file \SystemRoot\system32\drivers\aswStm.sys is present
« Last Edit: April 06, 2016, 07:56:25 PM by Dwarden »
https://twitter.com/FoltynD , Tech. Community, Online Services & Distribution manager of Bohemia Interactive

Offline lukor

  • Moderator
  • Super Poster
  • *
  • Posts: 1877
    • AVAST Software
Dwarden Hi and thanks.

We know about the pure-virtual-function-call crash, it is a bug inside deinitialization and is already fixed and waiting for a release.

The problem that troubles us is the original reason why aswstm fails to start (which then leads to the deinit bug and crash) - it is apparent, that when the service is hanged it does not process any requests (including DNS ones) and the whole pc can appear stalled.

The steps (A-H) you are describing here do happen after the DNS starts to fail? Such as: it runs for a while, that you see problems with DNS, try to stop it - stop hangs and then when trying to start again you see this start/fail/crash loop?

Thanks,
Lukas.

Offline Zdenek

  • Avast team
  • Jr. Member
  • *
  • Posts: 38
Hi Dwarden.

I'm a developer responsible for the aswStm.sys driver. I can ask you for cooperation with problem analysis. I'm going to prepare some steps for you how to enable diagnostic messages and collect info. I'll provide it to you through private message.

Thank you.

Offline Dwarden

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1787
  • Ideas, that's ocean without borders!
    • Bohemia Interactive
thanks for taking your time to find and address/fix issue(s)

please, optimally, roll those fixes/changes out into new public beta build of Avast!

I uninstalled Avast! because of this bug and bug https://forum.avast.com/index.php?topic=183875.0
as both turned the systems into unstable mess and I can't use such systems

so until both those major issues are resolved at least in beta, I'm not going to install this Avast! generation

I think I reported plenty important (way too many) issues in recent builds and in past dozen years too
way too much troubles to just use my systems so I need break from Avast! until those issues get addressed ...
https://twitter.com/FoltynD , Tech. Community, Online Services & Distribution manager of Bohemia Interactive