Author Topic: avast! blocking web browsers  (Read 6168 times)

0 Members and 1 Guest are viewing this topic.

AnyMouse

  • Guest
avast! blocking web browsers
« on: July 28, 2005, 10:07:12 PM »
I am running Windows XP x64 on a Gigabyte K8NXP-SLI motherboard with built in nVidia firewall. I surf using either Netscape  8.0.3.1 or Internet Explorer. After I installed and updated avast!, I find my web pages will not load completely. I get only part of a web page plus some HTML code. I tried turning off my firewalls (nVidia and Windows firewalls) but it makes no difference. I have no other antivirus installed, nor are there any remaining scraps of any other antiviruses on my computer or in my registry. Can anyone please tell me why avast! is causing this and what I can do to correct it? I have already bought it so I have to fix it. Thank you.

Offline YLAP

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2118
Re: avast! blocking web browsers
« Reply #1 on: July 28, 2005, 10:17:44 PM »
Have you tried to terminate web shield provider temporally? Does it helps to solve your problem?
« Last Edit: July 28, 2005, 10:24:14 PM by =YLAP= »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: avast! blocking web browsers
« Reply #2 on: July 28, 2005, 10:21:10 PM »
Ohh, this starts to be kinda strange. We have seen 3 different people complaining about internet access with avast's during last two days - yet the very reason of these problems is probably WebShield - component that has not changed significantly for several weeks.

Anyway, the thing is that avast has a download monitoring component, called WebShield.
For more info please read here:
http://www.avast.com/eng/avast_4_professional.html#23

and here:
http://www.avast.com/eng/webshield_issues.html

This tool needs to have full access to the internet and needs also the rights to accepts incoming connections from localhost. As a first step please check your firewall config. Secondly, you can try to terminate the webshield provider to confirm that webshield is really the source of your problems.

It this works we can try other tricks to determine the source of problems. Mainly you could try this:
http://www.avast.com/eng/webshield_issues.html#idt_6869

and see if manually configuring proxy would help.

And beware, when trying do not pause (as YLAP suggests) always terminate the provider to test something.

AnyMouse

  • Guest
Re: avast! blocking web browsers
« Reply #3 on: July 28, 2005, 10:41:58 PM »
Yesw, turning off Web Shield fixes it.
No, I can't use a proxy with my router.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: avast! blocking web browsers
« Reply #4 on: July 28, 2005, 10:47:57 PM »
Yesw, turning off Web Shield fixes it.
No, I can't use a proxy with my router.

Sure you can.

Edit: something is wrong with your installation of avast. Setting localhost:12080 as your HTTP proxy might help us determine if it is the redirecting part of the process or the network communication of WebShield that is wrong. The fact that you probably own a router is not relevant in this situation. And if it is, then you must have some strange network configuration that prevents your from using services running on your very PC. In this case this networking setup might perhaps be the reason why WebShield is not able to work.
« Last Edit: July 29, 2005, 12:01:57 AM by lukor »

AnyMouse

  • Guest
Re: avast! blocking web browsers
« Reply #5 on: July 29, 2005, 02:23:25 AM »
Well, you'll have to bear with me for a while. Now my LAN connection through that computer is down. I will try your fix as soon as I figure out this problem. Setting up this motherboard to run x64 OS sure is intensively interesting.
« Last Edit: July 29, 2005, 02:41:30 AM by AnyMouse »

AnyMouse

  • Guest
Re: avast! blocking web browsers
« Reply #6 on: July 29, 2005, 08:25:33 AM »
OK, I had a router problem and just now got it fixed.
So, I did as you said, Lukor, and created the proxie and yes, it did screw up my router, but I added one more client, which fixed that. Anyway, I can't run Web Shield without causing browser problems. Any ideas on how to fix that? Thank you.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: avast! blocking web browsers
« Reply #7 on: July 29, 2005, 11:31:36 AM »
OK, I had a router problem and just now got it fixed.
So, I did as you said, Lukor, and created the proxie and yes, it did screw up my router, but I added one more client, which fixed that. Anyway, I can't run Web Shield without causing browser problems. Any ideas on how to fix that? Thank you.

Can you explain this? Does the router care if the connection is coming from Internet Explorer or from avast! WebShield? How does the router know?

AnyMouse

  • Guest
Re: avast! blocking web browsers
« Reply #8 on: July 31, 2005, 09:09:13 AM »
Yes, it seems the router cares considerably. After much experimentation, I discovered a solution to all my problems with Avast! Entering a proxy in Internet Explorer did not  work at all, however, by going into my router to "Port Forwarding" and designating  port 12080 for Avast!, everything works perfectly with no other changes needed to any other software. I am not saying this will work for everyone, but it sure works good on my machine. Now I feel like the money I spent on Avast! was well spent.
By the way, I found "Tiny Forewall 64" works great with this antivirus, but you will want to completely disable your Windows firewall to run it. To do that, do the following:
1. Press the "Start Button".
2. In "Start Menu" select "Run".
3. Type "gpedit.msc" in the "Open:" box.
4. Expand the “Computer Configuration” section.
5. Expand the “Administrative Templates” section.
6. Expand the “Network” section.
7. Expand the “Networks Connections” section.
8. Expand the “Windows Firewall” section.
9. Select “Standard Profile”.
10. Double click the “Windows Firewall: Protect all network connections”.
11. Select the disabled option.
12. Select the “OK” or “Apply” button.
Then your Windows firewall will not only be shut off, but will also be greyed out.


AMD Athlon 64 FX-55 2.6GHz Processor (Clawhammer) Socket 939 CPU
GIGABYTE  GA-K8NXP-SLI Socket 939 NVIDIA nForce4 ATX AMD Motherboard
GIGABYTE GV-NX68T256DH Geforce 6800 GT 256MB GDDR3 PCI-Express x16
Video Card
Corsair TWINX2048-3200C2 2 GB Kit DDR400 XMS3200 Memory
Thermaltake W0049RUC Silent Pure Power 680W Power Supply
Microsoft Windows XP Professional x64 Edition

tmsec

  • Guest
Re: avast! blocking web browsers
« Reply #9 on: March 08, 2006, 12:03:23 PM »
Hello,

I have a firewall/router and previously used Avast with a 32 bits computer and WinXP pro.

I recently bought a amd64 with winxp 64, and tried to install avast !

after several computer launchs, suddently all access to network cause the programs to crash, including svchost. The problem disappears if I get rid of avast services.

I tried to reinstall it several times, and disable all services except scan on access, same result. I even got a blue screen "Memory management exception".

Does someone have any idea ?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: avast! blocking web browsers
« Reply #10 on: March 08, 2006, 02:17:51 PM »
Tmsec, maybe it will be better to start a new topic about your problem than to use this one, related to browsers.
avast should be compatible with 64bits environment... Do you install any other software before avast?
Maybe you can answer in that new thread  ;)
The best things in life are free.