Author Topic: Subsystem detected a RPC error ?  (Read 11544 times)

0 Members and 1 Guest are viewing this topic.

Brian A.

  • Guest
Subsystem detected a RPC error ?
« on: September 08, 2005, 06:23:30 AM »
The little 'a' in my system tray has a little "not" symbol across it. When I click on the little 'a',  the following message appears:

avast!: The AAVM subsystem detected a RPC error.
The operation could not be completed.

Does this mean that avast is not working??

Umath

  • Guest
Re: Subsystem detected a RPC error ?
« Reply #1 on: September 08, 2005, 07:35:52 AM »
Hi, Brian A.

Does this help?

There already some posts about this error.  Please remember the search function is your friend.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Subsystem detected a RPC error ?
« Reply #2 on: September 08, 2005, 01:59:48 PM »
RPC error is generally related to other antivirus present or, at least, firewall blocking. RPC error may also be because of avast! services being stopped.

Anyway, RPC error is most likely correct by this procedure:
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove
Then choose Repair function in the pop up window (Repair).

If this does not help, can you uninstall / boot / install / boot again?
The best things in life are free.

Philippe_E

  • Guest
Re: Subsystem detected a RPC error ?
« Reply #3 on: January 23, 2006, 08:40:22 AM »
Hello,

I got the same trouble...
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove
Then choose Repair function in the pop up window (Repair).

If this does not help, can you uninstall / boot / install / boot again?
I did all that, but the problem arrives still from time to time, always with starting (icon barred of red).

I must then pass as an administrator mode to be able to make start the service, because as a user mode I have an error message "Impossible to start the service antivirus avast on local computer - Error 5 accesses refused".
I am on XP Pro and I use Zone Alarm 6.1.737.
I explain this with a screen-copy here.
Philippe 
« Last Edit: January 23, 2006, 08:42:43 AM by Philippe_E »

Offline TedNelly

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1538
  • Trust No-One!
Re: Subsystem detected a RPC error ?
« Reply #4 on: January 23, 2006, 08:51:48 AM »
Are all services correct and do they have the correct firewall permissions
Windows 10 Pro | Intel I7 CPU | 16 Gig 2133 RAM | Avast beta 17.5.2295 | Firefox 54 b9(64-bit) | Cyberfox 52.1 | T-Bird 52.1.1 | SpyWareBlaster 5.5 | MalwareBytes 3.0.0.865 | WinPatrol 35.5.2 | GlassWire 1.2.100 | Cybereason Ransomfree 2.2.7 |  Pulla-dePlug Final!

Philippe_E

  • Guest
Re: Subsystem detected a RPC error ?
« Reply #5 on: January 23, 2006, 09:38:56 AM »
I show you a picture of services and a picture of zone alarm

Philippe

Offline TedNelly

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1538
  • Trust No-One!
Re: Subsystem detected a RPC error ?
« Reply #6 on: January 23, 2006, 09:44:46 AM »
Try restarting Avast antivirus/Mail scanner/and web scanner and reboot
« Last Edit: January 23, 2006, 09:51:54 AM by tednelly »
Windows 10 Pro | Intel I7 CPU | 16 Gig 2133 RAM | Avast beta 17.5.2295 | Firefox 54 b9(64-bit) | Cyberfox 52.1 | T-Bird 52.1.1 | SpyWareBlaster 5.5 | MalwareBytes 3.0.0.865 | WinPatrol 35.5.2 | GlassWire 1.2.100 | Cybereason Ransomfree 2.2.7 |  Pulla-dePlug Final!

Philippe_E

  • Guest
Re: Subsystem detected a RPC error ?
« Reply #7 on: January 23, 2006, 11:10:17 AM »
yes, to do that I must each time start again the computer in mode "administrator" and there I can restart "antivirus Avast" then I reboot and logg me in "users" mode and it goes.

But my problem it is that this adjustment lasts only a time. From time to time "antivirus Avast" does not start more automatically (whereas it is however well regulated on "automatic")...

Philippe

Philippe_E

  • Guest
Re: Subsystem detected a RPC error ?
« Reply #8 on: February 05, 2006, 08:32:05 AM »
Hello,

Is there an other solution ? Do you know why Avast don't start automatically ? I always get this message : « le sous-système AAVM a détecté une erreur RPC »... :-(

Philippe