Author Topic: Avast blocks Firefox? - Your connection is not secure  (Read 5664 times)

0 Members and 2 Guests are viewing this topic.

Offline Gascogne

  • Newbie
  • *
  • Posts: 2
Avast blocks Firefox? - Your connection is not secure
« on: April 21, 2016, 10:41:22 AM »
How come Avast blocks Firefox from connecting to the internet?



Firefox ver. 45.0.2

Avast Mac Security 2015
Avast ver. 11.9

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 725
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #1 on: April 21, 2016, 12:36:47 PM »
Works fine for me. It's hard to say from the image what is going on on your computer, but I guess you are for some reason missing the Avast webshield certificate. A simple logout/login should fix this. If not, more investigation would be required to see what's wrong in your case.

Offline Gascogne

  • Newbie
  • *
  • Posts: 2
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #2 on: April 21, 2016, 02:15:42 PM »
Tried logout and login but it did not solve the problem on my Macbook.
FireFox and Avast works fine on my iMac.

Offline pkal30

  • Newbie
  • *
  • Posts: 1
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #3 on: January 16, 2018, 10:39:02 PM »
I have been have this same problem since sometime in early to mid 2017 I think.  I gave up on using Firefox completely and switched to Google Chrome.  I was wondering if you were ever able to find a solution.  I have been trying to use Firefox again today, but I still can't find a solution.  Thank you.

Offline ondrej.kolacek

  • Avast team
  • Full Member
  • *
  • Posts: 125
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #4 on: January 17, 2018, 09:41:04 AM »
I have been have this same problem since sometime in early to mid 2017 I think.  I gave up on using Firefox completely and switched to Google Chrome.  I was wondering if you were ever able to find a solution.  I have been trying to use Firefox again today, but I still can't find a solution.  Thank you.
Hello,
we have currently an outstanding issue that when having Avast installed, after newly installing Firefox, it won't work correctly until next login. This will be fixed in the next version. Other than that it should be fine.
Kind Regards,
Ondrej Kolacek

Offline MadOranges

  • Newbie
  • *
  • Posts: 1
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #5 on: February 10, 2018, 11:16:09 PM »
This appears (google searches show it is) to be a regular Avast issue, across a number of application versions.  I am running avast security pro 13.4 , on OSX 10.12.6.  I had recently switched from mcafee (their mac software offers less, looks worse vs windows version) to avast, I did not think something so basic as browser compatibility would be an issue in 2018.  Log Off/ Restart/ Log On has not worked, neither has adding avast certificates in keychain/ login to firefox authorities manager.  Is there an approx date for a fix?

Offline ondrej.kolacek

  • Avast team
  • Full Member
  • *
  • Posts: 125
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #6 on: February 12, 2018, 07:18:48 AM »
Hello,
in the version 58, Firefox has changed format in which it saves certificates, which is causing the issue. We are pushing out update as fast as possible. As a temporary workaround:

What you can do is to add "Avast trusted CA" to Firefox's certificate manager.

Firstly, you need to obtain a copy of the certificate.
This can be found with Keychain Access with Keychain "login" and category "Certificates". Search for "avast". You should find "Avast trusted CA". Select it and export it from the menu bar under "File" then "Export Items...". Save it somewhere accessible.

Next, the certificate needs to be added to Firefox's certificate manager.
Open Firefox's Preferences > Privacy & Security tab. Scroll down to Security > Certificates. Open "View Certificates...". Click on "Authorities" then "Import...". Import "Avast trusted CA" and trust it to "identify websites". You can select "identify mail users" if you want.

Kind regards,
Ondrej Kolacek

Offline galoislie

  • Newbie
  • *
  • Posts: 3
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #7 on: February 24, 2018, 09:44:14 PM »
Importing "Avast Trusted CA" into Firefox did not work for me.

Date and time have been verified as being correct.  I'm running Firefox 58.0.2 on a MacBook with High Sierra 10.13.2.  The problem occurred today when I uninstalled Avast and then re-installed it.  I now have the latest version, 13.4.  I do not recall what the old version was.

Firefox will connect to https pages if I disable "Scan Secure Connections" in Web Shield, but I prefer to *not* disable this feature.

A similar problem happened to me ~Nov'17.  At that time a Firefox "refresh" helped.  That did not help this time.
« Last Edit: February 24, 2018, 09:46:54 PM by galoislie »

Offline ondrej.kolacek

  • Avast team
  • Full Member
  • *
  • Posts: 125
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #8 on: February 26, 2018, 10:13:55 AM »
Importing "Avast Trusted CA" into Firefox did not work for me.

Date and time have been verified as being correct.  I'm running Firefox 58.0.2 on a MacBook with High Sierra 10.13.2.  The problem occurred today when I uninstalled Avast and then re-installed it.  I now have the latest version, 13.4.  I do not recall what the old version was.

Firefox will connect to https pages if I disable "Scan Secure Connections" in Web Shield, but I prefer to *not* disable this feature.

A similar problem happened to me ~Nov'17.  At that time a Firefox "refresh" helped.  That did not help this time.

Hello,
when Avast is installed, it generates a unique "Avast trusted CA", but every such certificate is always called "Avast trusted CA". The reason it does not work may be because you might have installed the old one by accident.
Kind regards,
Ondrej Kolacek

Offline galoislie

  • Newbie
  • *
  • Posts: 3
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #9 on: February 27, 2018, 04:49:46 AM »
Thanks Ondrej.  I just looked at KeyChain Access again.  As of right now, there is just one "Avast Trusted CA".  So I went through the process again.  Unfortunately, it doesn't work.  Do you have a suggestion as to how I can confirm I'm importing the correct (most up to date) certificate into Firefox?  Better yet, do you have an estimated time for when the updates you mentioned (on Feb 12th) will be pushed out?  Thanks.

Offline ondrej.kolacek

  • Avast team
  • Full Member
  • *
  • Posts: 125
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #10 on: March 02, 2018, 10:29:44 AM »
Thanks Ondrej.  I just looked at KeyChain Access again.  As of right now, there is just one "Avast Trusted CA".  So I went through the process again.  Unfortunately, it doesn't work.  Do you have a suggestion as to how I can confirm I'm importing the correct (most up to date) certificate into Firefox?  Better yet, do you have an estimated time for when the updates you mentioned (on Feb 12th) will be pushed out?  Thanks.
Hello,
hopefully the new version should be out within few days.

Regarding the certificate you have added, please delete it (Open Firefox's Preferences > Privacy & Security tab. Scroll down to Security > Certificates. Open "View Certificates...". Click on "Authorities" , select "Avast trusted CA", and click "Delete or distrust"). Please note that you will possibly have to close the Certificate Manager window and immediately reopen it, or the next step will fail (it seems they have a bug there).

After that press Import, go to /Library/Application Support/Avast/config/cert (you can press cmd+shift+g and paste it there), select cacert.pem and import it (check at least "trust certificate to identify web sites").
>>Please do NOT import the second .pem file which is in the same directory!<<

This should ensure that you are using the correct certificate.
Kind regards,
Ondrej Kolacek

Offline galoislie

  • Newbie
  • *
  • Posts: 3
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #11 on: March 02, 2018, 03:58:26 PM »
Thanks. It's working now!

Offline Treva2

  • Newbie
  • *
  • Posts: 1
Re: Avast blocks Firefox? - Your connection is not secure
« Reply #12 on: August 17, 2018, 09:09:51 PM »
Hello,
in the version 58, Firefox has changed format in which it saves certificates, which is causing the issue. We are pushing out update as fast as possible. As a temporary workaround:

What you can do is to add "Avast trusted CA" to Firefox's certificate manager.

Firstly, you need to obtain a copy of the certificate.
This can be found with Keychain Access with Keychain "login" and category "Certificates". Search for "avast". You should find "Avast trusted CA". Select it and export it from the menu bar under "File" then "Export Items...". Save it somewhere accessible.

Next, the certificate needs to be added to Firefox's certificate manager.
Open Firefox's Preferences > Privacy & Security tab. Scroll down to Security > Certificates. Open "View Certificates...". Click on "Authorities" then "Import...". Import "Avast trusted CA" and trust it to "identify websites". You can select "identify mail users" if you want.

Kind regards,
Ondrej Kolacek

I wanted to say thank you, this worked perfectly.  The only difference is that I found the certificate under "System" and not "login". 

I'm happy that we have Firefox working on my daughter's MacBook and I can't wait to get mine back get it going too.

Thanks again.