Author Topic: Memory leaking when viewing statistics in UI? :/  (Read 4363 times)

0 Members and 1 Guest are viewing this topic.

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Memory leaking when viewing statistics in UI? :/
« on: May 14, 2016, 01:29:56 PM »
So I recently updated to the newest version of AVAST! Antivirus (11.2.2262) because I had an much older 2015 version of the program installed before and was recommended to update... which I have... now everything seems fine and I notice the new changes to the main UI. (Less cluttered and uses a lot less memory when in it.) but when I go to the Tools > Statistics section where it would open a new UI interface with the statistics of the File, Web and Mail shield and what they are scanning... the RAM my computer uses starts low, at around 50MB, but as the statistics go on, it just keeps going up and up and up, until all my RAM is taken...

Anyone else having this issue?

EDIT: On further inspection... it also seems that when I'm in that part of the UI, after about 30 seconds of it being active, the whole part of that UI lags very badly... (like when the stats are animating, it's very choppy), it wasn't like this in previous versions of AVAST!, the stats were always fluid and not laggy. 
« Last Edit: May 14, 2016, 01:37:37 PM by Braver »

Offline Be Secure

  • Long Time Avast User(9years.....) Security Enthusiast.
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1902
Re: Memory leaking when viewing statistics in UI? :/
« Reply #1 on: May 14, 2016, 01:39:05 PM »
 Statistics in UI is under redesign and removed from last beta version hopefully back soon  :D
PC- Windows10 EDU 64Bit,Avast Free V.19.8.2393,uBlock Origin,NVT_OSA,GoogleChrome(64bit),CCleaner,Unchecky,ZAM Free,Shadow Defender.
Security Enthusiast

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Re: Memory leaking when viewing statistics in UI? :/
« Reply #2 on: May 14, 2016, 01:49:09 PM »
Statistics in UI is under redesign and removed from last beta version hopefully back soon  :D

Huh... you have any idea why this is? I mean... on older versions of the program... in 2015... that part of the UI ran pretty much flawlessly. No memory leaks, lag or anything... did they program the Statistics UI differently in the 2016 version...? Cause it looks exactly the same.

And beta? I just downloaded the latest version according to the site... which was 11.2.2262... is that the latest version? So in the current beta build of the program... statistics has been removed? 'Cause it still exists in this current build of the program... in Tools.
« Last Edit: May 14, 2016, 01:54:49 PM by Braver »

Offline Be Secure

  • Long Time Avast User(9years.....) Security Enthusiast.
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1902
Re: Memory leaking when viewing statistics in UI? :/
« Reply #3 on: May 14, 2016, 01:56:44 PM »
Quote
you have any idea why this is? I mean... on older versions of the program... in 2015... that part of the UI ran pretty much flawlessly. No memory leaks, lag or anything... did they program the Statistics UI differently in the 2016 version...? Cause it looks exactly the same.
No.It is not changed.No it was a Memory leakage/BUG.

Quote
is that the latest version?(11.2.2262)
Yes latest stable version.

Quote
So in the current beta build of the program... statistics has been removed?
Yes.
PC- Windows10 EDU 64Bit,Avast Free V.19.8.2393,uBlock Origin,NVT_OSA,GoogleChrome(64bit),CCleaner,Unchecky,ZAM Free,Shadow Defender.
Security Enthusiast

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Re: Memory leaking when viewing statistics in UI? :/
« Reply #4 on: May 14, 2016, 02:05:03 PM »
Quote
No.It is not changed.No it was a Memory leakage/BUG.

Is it going to be fixed in future versions? 'Cause the memory leakage/lag at the moment makes this feature basically unusable.

Quote
Yes latest stable version.

Ahh, okay... and statistics would probably still be in this version, right? (well it is in mine)

So should I completely avoid using the statistics function at the moment then?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83011
  • No support PMs thanks
Re: Memory leaking when viewing statistics in UI? :/
« Reply #5 on: May 14, 2016, 02:31:08 PM »
Quote
No.It is not changed.No it was a Memory leakage/BUG.

Is it going to be fixed in future versions? 'Cause the memory leakage/lag at the moment makes this feature basically unusable.

Quote
Yes latest stable version.

Ahh, okay... and statistics would probably still be in this version, right? (well it is in mine)

So should I completely avoid using the statistics function at the moment then?


1. Yes no doubt it will be fixed when it is released after they have also done a redesign.

2. It is still in 11.2.2262 any later (beta or regular release) version then no it won't be there.

Personally in its present form I think the Statistics function is pretty poor, it is totally lacking in detailed information to make it worthwhile. I hope that after the redesign it will have more detail or they might as well leave it out.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Re: Memory leaking when viewing statistics in UI? :/
« Reply #6 on: May 14, 2016, 03:10:42 PM »
Quote
No.It is not changed.No it was a Memory leakage/BUG.

Is it going to be fixed in future versions? 'Cause the memory leakage/lag at the moment makes this feature basically unusable.

Quote
Yes latest stable version.

Ahh, okay... and statistics would probably still be in this version, right? (well it is in mine)

So should I completely avoid using the statistics function at the moment then?


1. Yes no doubt it will be fixed when it is released after they have also done a redesign.

2. It is still in 11.2.2262 any later (beta or regular release) version then no it won't be there.

Personally in its present form I think the Statistics function is pretty poor, it is totally lacking in detailed information to make it worthwhile. I hope that after the redesign it will have more detail or they might as well leave it out.

1) Okay... that's good to know. So is this memory leakage/lag thing a known-bug and everyone is suffering it?

2) I'll just leave it be then... it doesn't give very detailed information, as you said... I found the detail to be lacking... but still useful... sometimes... to know what pages/files are being scanned and such... but they do really need to work on it... so you can maybe see more of the latest pages/files scanned...

Thanks for the heads up, anyhow.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31350
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Memory leaking when viewing statistics in UI? :/
« Reply #7 on: May 14, 2016, 03:35:31 PM »
Keep in mind that there are basically two "latest versions".

1] The one that is called "final release" (currently 2016.11.2.2262)
2] The latest "beta release" (currently 2016.12.1.2264)

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Re: Memory leaking when viewing statistics in UI? :/
« Reply #8 on: May 14, 2016, 03:51:36 PM »
Keep in mind that there are basically two "latest versions".

1] The one that is called "final release" (currently 2016.11.2.2262)
2] The latest "beta release" (currently 2016.12.1.2264)

Ahhh. Well the question I have really is that the current "stable" build. (2016.11.2.2262) This is the version that has the memory leak/lag statistics problem, right?

And then the Beta release (2016.12.1.2264) is the one where that feature has been completely removed?

But I want to make sure that everyone is having this same issue I'm having with the current build where the statistics part of the UI is constantly rising my RAM usage indefinitely while it's animating... starts off fine at low memory and runs smoothly... as the memory rises... the graphs/graphics start to lag hard and even switching tabs from it takes a long time.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83011
  • No support PMs thanks
Re: Memory leaking when viewing statistics in UI? :/
« Reply #9 on: May 14, 2016, 04:01:00 PM »
<snip>
1. Yes no doubt it will be fixed when it is released after they have also done a redesign.

2. It is still in 11.2.2262 any later (beta or regular release) version then no it won't be there.

Personally in its present form I think the Statistics function is pretty poor, it is totally lacking in detailed information to make it worthwhile. I hope that after the redesign it will have more detail or they might as well leave it out.

1) Okay... that's good to know. So is this memory leakage/lag thing a known-bug and everyone is suffering it?

2) I'll just leave it be then... it doesn't give very detailed information, as you said... I found the detail to be lacking... but still useful... sometimes... to know what pages/files are being scanned and such... but they do really need to work on it... so you can maybe see more of the latest pages/files scanned...

Thanks for the heads up, anyhow.

You're welcome.

I don't believe everyone will be suffering Lag, that would be dependent on many things:
A. Your system, CPU, RAM and OS.
B. What other programs you also have running.
C. Leaving the avastUI interface open - this would only exacerbate the problem - whilst the CPU usage might be around 50% it does stabilise, the real issue is RAM continuing to rise.

The more programs you have running the greater this would be as with no (or reduced) RAM to share then you would have lots of hard disk activity as data from RAM being transferred to the swap file.

As they say if banging your head against a brick wall hurts, stop doing it, e.g. Don't use the Stats section in this current form.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.2.2401 (build 20.2.5130.570) UI-1.0.505/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Braver

  • Full Member
  • ***
  • Posts: 132
Re: Memory leaking when viewing statistics in UI? :/
« Reply #10 on: May 14, 2016, 04:22:09 PM »
<snip>
1. Yes no doubt it will be fixed when it is released after they have also done a redesign.

2. It is still in 11.2.2262 any later (beta or regular release) version then no it won't be there.

Personally in its present form I think the Statistics function is pretty poor, it is totally lacking in detailed information to make it worthwhile. I hope that after the redesign it will have more detail or they might as well leave it out.

1) Okay... that's good to know. So is this memory leakage/lag thing a known-bug and everyone is suffering it?

2) I'll just leave it be then... it doesn't give very detailed information, as you said... I found the detail to be lacking... but still useful... sometimes... to know what pages/files are being scanned and such... but they do really need to work on it... so you can maybe see more of the latest pages/files scanned...

Thanks for the heads up, anyhow.

You're welcome.

I don't believe everyone will be suffering Lag, that would be dependent on many things:
A. Your system, CPU, RAM and OS.
B. What other programs you also have running.
C. Leaving the avastUI interface open - this would only exacerbate the problem - whilst the CPU usage might be around 50% it does stabilise, the real issue is RAM continuing to rise.

The more programs you have running the greater this would be as with no (or reduced) RAM to share then you would have lots of hard disk activity as data from RAM being transferred to the swap file.

As they say if banging your head against a brick wall hurts, stop doing it, e.g. Don't use the Stats section in this current form.

I have plenty of RAM. My system is fine. I do mean when you leave the stats page open for a longer period of time... I used to do this fine in older versions of the program and the RAM wouldn't rise very much.

In this version though... if you leave the stats open for about 30 seconds, the RAM it uses up is insane and just continues to rise. And as it rises, the fluidity of the graphs also becomes laggier and staggers quite a bit.

Why did they mess it up this badly from a stats page that was working fine previously on earlier versions of the program?

Offline AliA

  • Newbie
  • *
  • Posts: 18
  • Hi Peeps
Re: Memory leaking when viewing statistics in UI? :/
« Reply #11 on: May 15, 2016, 02:23:21 PM »
So I recently updated to the newest version of AVAST! Antivirus (11.2.2262) because I had an much older 2015 version of the program installed before and was recommended to update... which I have... now everything seems fine and I notice the new changes to the main UI. (Less cluttered and uses a lot less memory when in it.) but when I go to the Tools > Statistics section where it would open a new UI interface with the statistics of the File, Web and Mail shield and what they are scanning... the RAM my computer uses starts low, at around 50MB, but as the statistics go on, it just keeps going up and up and up, until all my RAM is taken...

Anyone else having this issue?

EDIT: On further inspection... it also seems that when I'm in that part of the UI, after about 30 seconds of it being active, the whole part of that UI lags very badly... (like when the stats are animating, it's very choppy), it wasn't like this in previous versions of AVAST!, the stats were always fluid and not laggy.

Exactly the same issue :)

Hope there is a fix, I also found what seems another bug. If you select boot time scan and press start. The restart box which prompts the user to restart there machine now takes ages to appear. I have created a post about that, hopefully someone can confirm that is also a bug which some people are experiencing. As for this I have the exact same issue, the stats slow down to a point where it becomes very slugglish and un usable.

Online bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 43557
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Memory leaking when viewing statistics in UI? :/
« Reply #12 on: May 16, 2016, 02:46:04 AM »
So I recently updated to the newest version of AVAST! Antivirus (11.2.2262) because I had an much older 2015 version of the program installed before and was recommended to update... which I have... now everything seems fine and I notice the new changes to the main UI. (Less cluttered and uses a lot less memory when in it.) but when I go to the Tools > Statistics section where it would open a new UI interface with the statistics of the File, Web and Mail shield and what they are scanning... the RAM my computer uses starts low, at around 50MB, but as the statistics go on, it just keeps going up and up and up, until all my RAM is taken...

Anyone else having this issue?

EDIT: On further inspection... it also seems that when I'm in that part of the UI, after about 30 seconds of it being active, the whole part of that UI lags very badly... (like when the stats are animating, it's very choppy), it wasn't like this in previous versions of AVAST!, the stats were always fluid and not laggy.

Exactly the same issue :)

Hope there is a fix, I also found what seems another bug. If you select boot time scan and press start. The restart box which prompts the user to restart there machine now takes ages to appear. I have created a post about that, hopefully someone can confirm that is also a bug which some people are experiencing. As for this I have the exact same issue, the stats slow down to a point where it becomes very slugglish and un usable.
I wouldn't call it ages. There is a definite delay. Not anything that's ever bothered me since I don't generally run scans. :)
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.3.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline AliA

  • Newbie
  • *
  • Posts: 18
  • Hi Peeps
Re: Memory leaking when viewing statistics in UI? :/
« Reply #13 on: May 17, 2016, 06:14:08 AM »
So I recently updated to the newest version of AVAST! Antivirus (11.2.2262) because I had an much older 2015 version of the program installed before and was recommended to update... which I have... now everything seems fine and I notice the new changes to the main UI. (Less cluttered and uses a lot less memory when in it.) but when I go to the Tools > Statistics section where it would open a new UI interface with the statistics of the File, Web and Mail shield and what they are scanning... the RAM my computer uses starts low, at around 50MB, but as the statistics go on, it just keeps going up and up and up, until all my RAM is taken...

Anyone else having this issue?

EDIT: On further inspection... it also seems that when I'm in that part of the UI, after about 30 seconds of it being active, the whole part of that UI lags very badly... (like when the stats are animating, it's very choppy), it wasn't like this in previous versions of AVAST!, the stats were always fluid and not laggy.

Exactly the same issue :)

Hope there is a fix, I also found what seems another bug. If you select boot time scan and press start. The restart box which prompts the user to restart there machine now takes ages to appear. I have created a post about that, hopefully someone can confirm that is also a bug which some people are experiencing. As for this I have the exact same issue, the stats slow down to a point where it becomes very slugglish and un usable.
I wouldn't call it ages. There is a definite delay. Not anything that's ever bothered me since I don't generally run scans. :)

I agree it isnt ages but the delay is longer then what it should be, but it seems like ages since before it use to be instant as soon as you click the start button the restart option would appear. I watched ur video which you sent me and the delay which you had I timed it buy clicking the boot time scan on my pc the exact same time as you did on ur pc at least 6 times over. And the results where, the delay lasted exactly the same time, the restart box appeared exactly the same time on my pc as it did on ur pc and the results remained consistent every time I did this.

So the delay isnt a hardware issue. I not trying to be big headed or rude or trying to show off and say my pc is better ect... But i do feel this is not a hardware issue based on the test I did. I do believe my pc at the current moment is faster then many of the people here as I have 16gb 1866mhzt ram and a 4.1ghzt cpu. And the strange thing is the delay on your video lasts the exact same time as the delay on my pc when i tested this more then 6 times. My rig is a gaming pc and isnt a simple desktop. Based on statistics many people who buy ready built pc's dont have more then 8gb ram and these hp and dell and other pre built pc's the ram is running at 1006mhzt or at least 1333mhzt.

Again I am sorry, I am not trying to say I have a better pc and cause a argument. But based on stats on what I have seen I could be wrong so forgive me. But many people dont have use for more then 8gb ram or a basic i3/i5 cpu. But that issue which I have and you just confimred as having is address buy ur kind self as you reported it. But this UI issue I am also getting and so is my brother and my uncles laptop. This UI memory leak seems universal.
« Last Edit: May 17, 2016, 06:38:26 AM by AliA »