Author Topic: ashWebSv.exe encountered a problem and needed to close  (Read 5486 times)

0 Members and 1 Guest are viewing this topic.

rob59

  • Guest
ashWebSv.exe encountered a problem and needed to close
« on: January 08, 2006, 09:13:05 PM »
I get the message "ashWebSv.exe encountered a problem and needed to close" every time I log on in Windows XP.

I gather that this file is used for Web Shield, but when I look at this in the On-Access Protection Control, it says:

"Web Shield
The provider is currently running."

Does this mean I don't have a problem?
Can I do anything to stop this message?

I have Avast! version 4.6 Home Edition.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87305
  • No support PMs thanks
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #1 on: January 08, 2006, 09:30:45 PM »
Is there any more information in that message, like another file/process/dll, etc.?
Look in the windows Event Logs and see if there is any mor information there.

There is obviously a problem hence the message even though the provider is running (it may have restarted automatically) but without more information I can't see how to stop the message.

Do (or did) you have another AV on this system, if so what?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.12.6044 (build 22.12.7758.768) UI 1.0.741/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

rob59

  • Guest
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #2 on: January 12, 2006, 10:39:04 PM »
The message says:

"ashWebSv.exe encountered a problem and needed to close.

This error occurred on 12/01/2006 at 18:26:29.

Please tell Microsoft about this problem.

.... [etc]

Send Error Report    Don't Send"

In Event Viewer, there is an entry under Application with description:

"Faulting application ashWebSv.exe, version 4.6.739.0, faulting module radhslib.dll, version 0.0.0.0, fault address 0x00003b6f."

I did have Bullguard on the system.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11822
    • AVAST Software
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #3 on: January 12, 2006, 10:47:21 PM »
OK, the error is caused by radhslib.dll - which is not an avast! module. I guess it's another faulty LSP that hooks the network communication on your computer.
Can you check the version (author) of the DLL? Maybe it's Bullguard?

CharleyO

  • Guest
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #4 on: January 12, 2006, 11:19:00 PM »
***

Welcome to the forums, rob59!    :)

Do you have or have you had Naomi Internet Filter on your computer? This program will install that dll as part of it's program.

http://search.earthlink.net/search?q=radhslib.dll&area=earthlink-ws&FD=0&channel=narrowband

Naomi program is available here:

http://www.radiance.m6.net/

Hope this helps you!    :)


***
« Last Edit: January 14, 2006, 04:31:17 AM by CharleyO »

rob59

  • Guest
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #5 on: January 13, 2006, 11:00:20 PM »
Thanks - I do have Naomi.

Does this mean there is a problem with Naomi or with Avast?

Is Avast still working?
(It says it is, but ashWebSv.exe is not on the list of Processes on Task Manager - should it be?)

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #6 on: January 14, 2006, 04:43:20 AM »
Does this mean there is a problem with Naomi or with Avast
It shouldn't have one... Naomi + XP + avast work perfectly togheter as far I could test.

Is Avast still working?
Do you see a red cross in the 'a' blue icon on system tray?

It says it is, but ashWebSv.exe is not on the list of Processes on Task Manager - should it be?
Well, if you're browsing, it should be running...
The best things in life are free.

rob59

  • Guest
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #7 on: January 14, 2006, 06:56:47 PM »
Quote
Is Avast still working?
Do you see a red cross in the 'a' blue icon on system tray?

No, there is no red cross.

Quote
It says it is, but ashWebSv.exe is not on the list of Processes on Task Manager - should it be?
Well, if you're browsing, it should be running...

Task Manager shows the following ashx processes:

ashDisp.exe            [user]
ashMaiSv.exe         [SYSTEM]
ashServ.exe           [SYSTEM]
ashUpdSv.exe         [SYSTEM]

There is no red cross on the 'a' blue icon in the system tray,
and in On-Access Protection Control for Web Shield, it says
The provider is currently running.

However, ashWebSv.exe is not on the list of processes
even though I am obviously browsing to write this!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #8 on: January 14, 2006, 07:43:06 PM »
However, ashWebSv.exe is not on the list of processes even though I am obviously browsing to write this!
Which browser do you use?
Did you try to repair your avast installation or, even, uninstall and install again?
The best things in life are free.

rob59

  • Guest
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #9 on: January 15, 2006, 10:45:36 PM »
I use IE 6.0 SP2

I have not tried to repair or uninstall and install avast again.
Should I? How do I do this?

Thanks for your help.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: ashWebSv.exe encountered a problem and needed to close
« Reply #10 on: January 15, 2006, 10:54:32 PM »
I use IE 6.0 SP2
It should work  :-\ :'(

I have not tried to repair or uninstall and install avast again.
Should I? How do I do this?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove. Then choose Repair function in the popup window (Repair). You must be connected to the internet while repairing.

Maybe if nothing more helps, you could follow: uninstall / boot / install / boot again
The best things in life are free.