Author Topic: Battery Saver will not turn off WiFi when appropriate profile was selected.  (Read 14730 times)

0 Members and 1 Guest are viewing this topic.


  • Guest

I have a Note 5 (Android 6.0.1) from T-Mobile, and just started using Avast Battery Saver. I noticed that if I have the Profile setup to disable WiFi, it doesn't seem to do anything whether I start the profile manually or ABS starts it automatically based on the condition provided. The WiFi icon shows connected to auto connect SSID, or if not connected, icon is not greyed out.

What am I missing?  Please advise.



  • Guest
I have the same problem. Did you ever find a solution that doesn't involve uninstalling the software?

My device is a LG Leon LTE from MetroPCS, with Android 5.1.1 installed. I also have other symptoms to add to this issue.

On profiles where ABS is set to disable the phone's wi-fi, it does exactly what the OP says it does. In addition, if I manually turn off the Wi-Fi, ABS turns it back on within 1-2 minutes, even if the active profile is set to disable the wi-fi. On profiles where wi-fi is set to on, or optimized, ABS repeatedly disrupts my wi-fi  connection, causing my phone to either switch to another saved wi-fi connection, (disrupting that one in the same manner within a few minutes), or switch to mobile data. Usually the message I get from my phone when this happens is that my wi-fi connection has no internet.

Disabling, or uninstalling the app are the only solutions I've found that work so far.

Offline Avast-TS

  • Avast team
  • Jr. Member
  • *
  • Posts: 22

These issues should have fixed in last Avast Battery Saver version. Which version are you using? You can check it in Settings -> About screen


  • Guest
I'm using Samsung S7 edge. Had the same problem for many month - lots of troubles. All my researches failed. I tried all settings - no success. Today I found th solution and I feel happy again
=> I uninstalled battery safer and everything works perfect!!