Author Topic: Avast blocking all traffic through openvpn tap adapter  (Read 7817 times)

0 Members and 1 Guest are viewing this topic.

Offline swc-it

  • Newbie
  • *
  • Posts: 12
Avast blocking all traffic through openvpn tap adapter
« on: June 24, 2016, 12:31:45 AM »
Yesterday I updated Avast Internet Security to version 12.1.2272 build 12.1.3076.0 on a Windows 7x64 pc.  Since then all traffic running through my openvpn connection is being blocked.  If I look in the firewall logs I can see the various network connections being blocked under the "Public/High Risk Zone" rule.

If I look in the avast firewall Settings > Network Profiles I have 2 network adapters, both with the same mac address, both with the profile listed as Private.  I see no way to add the openvpn adapter to the network profiles list, nor can I see where I can set this adapter the Private profile.

I've added application rules to the firewall but they are still being blocked.

The openvpn ip's are within the 10.0.0.0/10.255.255.255 range in the "Friends" list.

I've repaired the avast install from the windows add/remove programs option but the issue persists.

Anyone know how I can allow this traffic?  It was working fine for years on the previous version of avast.

Offline swc-it

  • Newbie
  • *
  • Posts: 12
Re: Avast blocking all traffic through openvpn tap adapter
« Reply #1 on: July 04, 2016, 06:53:48 PM »
Anyone have any advice?  I've opened a support ticket with Avast but they have been unable to resolve the issue.

Offline bob3160

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 48620
  • 64 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast blocking all traffic through openvpn tap adapter
« Reply #2 on: July 04, 2016, 08:13:32 PM »

Welcome to the forum.I've reported this to Avast and asked for assistance. I use the free version so am not familiar enough with the firewall module
which isn't included in the free version.
Free Security Seminar: https://bit.ly/bobg2023  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v24H2 64bit, 32 Gig Ram, 1TB SSD, Avast Free 24.4.6112, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://bit.ly/BobGInternet

REDACTED

  • Guest
Re: Avast blocking all traffic through openvpn tap adapter
« Reply #3 on: July 05, 2016, 10:34:36 AM »
I have exactly the same problem.

Yesterday I updated Avast Internet Security to version 12.1.2272 build 12.1.3076.0 on a Windows 7x64 pc.  Since then all traffic running through my openvpn connection is being blocked.  If I look in the firewall logs I can see the various network connections being blocked under the "Public/High Risk Zone" rule.

Offline swc-it

  • Newbie
  • *
  • Posts: 12
Re: Avast blocking all traffic through openvpn tap adapter
« Reply #4 on: July 12, 2016, 07:57:09 PM »
I have exactly the same problem.

Thanks for the reply!  At least it's not only me having the problem.  I'm still working with Avast Support but have yet to resolve the issue.  I'll post here if the come up with something but I suspect it's not a config issue & that there is a bug in the software.

Offline bruce_b

  • Sr. Member
  • ****
  • Posts: 333
Re: Avast blocking all traffic through openvpn tap adapter
« Reply #5 on: July 13, 2016, 12:25:30 AM »
You can try this: (not sure if it will work, it is from another link, but looks promising)

1. Open Avast Internet Security.
2. Click on 'firewall',
3. On the firewall settings click onto 'expert settings'.
4. Click 'packet rules'
5. Select 'add new entry' and enter 'VPN'
6. Enter the following action, 'allow protocol: all - direction: in/out'
7. Add the server ip address(es).
 8. Click 'OK'. You should now be able to connect to the VPN.
Dell Dimension 8200 P4 1.8Ghz Windows XP PRO SP3
Avast Free Antivirus 18.8.2356
Toshiba Satellite C855-S5347 Celeron B830 1.8Ghz
Windows 10 Home 64 Bit Version 1909 Build 18363.900
Avast Free Antivirus 20.4.2410 Build 20.4.5312.578

Offline swc-it

  • Newbie
  • *
  • Posts: 12
Re: Avast blocking all traffic through openvpn tap adapter
« Reply #6 on: July 15, 2016, 01:22:19 AM »
You can try this: (not sure if it will work, it is from another link, but looks promising)

1. Open Avast Internet Security.
2. Click on 'firewall',
3. On the firewall settings click onto 'expert settings'.
4. Click 'packet rules'
5. Select 'add new entry' and enter 'VPN'
6. Enter the following action, 'allow protocol: all - direction: in/out'
7. Add the server ip address(es).
 8. Click 'OK'. You should now be able to connect to the VPN.


Thanks for the tip but it doesn't resolve the issue.  The problem appears to be that all VPN traffic is being considered part of the "Public/High Risk Zone".  Any firewall rule I create is only applied to the "Private" zone as that is what is assigned to the NIC.  Still working with support on this but no resolution yet.

Offline swc-it

  • Newbie
  • *
  • Posts: 12
Re: Avast blocking all traffic through openvpn tap adapter
« Reply #7 on: July 15, 2016, 05:52:23 PM »
Avast support has confirmed this is a bug and will be fixed in the next release.

Quote
We found where the issue is and it's now fixed in our internal build. It will be released at the end of this month.
For now, please, disable Avast Firewall, when you are connecting to VPN.