Author Topic: Avast performance since nitro update  (Read 7880 times)

0 Members and 1 Guest are viewing this topic.

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Avast performance since nitro update
« on: July 28, 2016, 10:59:40 PM »
Since the nitro update, the launch time for Avast after logon has dramatically increased ...

On top of this, there's a performance slowdown.

I'm not the only one experiencing this and others have said so in other forums...

Take a look at this test for example : https://www.virusbulletin.com/testing/results/latest/vb100-antimalware

Until this is solved, I'm removing Avast from my PCs.
« Last Edit: August 06, 2016, 06:46:01 PM by Alikhan »
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Online =Snake=

  • Nincsen elfelejtettem.
  • Serious Graphoman
  • **
  • Posts: 8854
Re: Avast performance since nitro update
« Reply #1 on: July 28, 2016, 11:18:38 PM »
Until this is solved, I'm removing Avast from my PCs.

If you do it right, it's a lot of work!!!
 ;)
=Snake=
Main: AMD LE1620,W7ult SP1|MS-7091,P4,XP pro SP3| AMD-Athlon 1800+(XP pro SP3 & W7ult.SP1,FFesr 45.9,TB 45.8,CC 5.11)|
Laptops: Acer Aspire V5-591G,W10 Home[x64] v1909(Build 18363.959)|HPI_2020M,W8.1 pro[x64]|Amilo Xi2428,W8.1 pro|MD95400,W7ult SP1|MD97400,XP pro SP3|
FF 78.10.0 esr[NS,AOS,ABP],TB 78.10.0,MCS,CC 5.77, Defraggler 2.19.982,MBAM[OD],MBAE,FW(XP+W7):CIS 3.14[FW,D+],AV: Avast Free [XP+W7:10.4.2233] 20.8.2429|

Offline thekochs

  • Speak Your Mind, Who minds don't matter, Who matters won't mind
  • Advanced Poster
  • **
  • Posts: 1115
  • Hapkido Blackbelt
Re: Avast performance since nitro update
« Reply #2 on: July 29, 2016, 02:49:03 AM »
Since the nitro update, the launch time for Avast after logon has dramatically increased ...

On top of this, there's a performance slowdown.

I'm not the only one experiencing this and others have said so in other forums...

Take a look at this test for example : https://www.virusbulletin.com/testing/results/latest/vb100-antimalware

Until this is solved, I'm removing Avast from my PCs.

It's better than Avast's previous "NG".  ;D
OpenDNS + Avast Free + MBAM Premium + MBAE Free Anti-Exploit + CryptoPrevent + Windows Firewall
Avast FAQ Videos
Avast 2016 Videos
Avast Clean Un/Re-Install How-To

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Avast performance since nitro update
« Reply #3 on: August 05, 2016, 11:54:02 PM »
Bump.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline petr_matrix

  • Avast team
  • Sr. Member
  • *
  • Posts: 268
  • avast! programmer
    • AVAST Software
Re: Avast performance since nitro update
« Reply #4 on: August 06, 2016, 12:48:27 PM »
Hi,
how do you measure launch time? Can you provide some perf logs?

Thanks,
pm

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Avast performance since nitro update
« Reply #5 on: August 06, 2016, 01:41:49 PM »
Hi,
how do you measure launch time? Can you provide some perf logs?

Thanks,
pm

Hi,

I measure the launch time on how it takes avast after logon to load in the tray icon and start real time protection (I've set the taskbar icon to blue animation).

All other software be started like MBAM but Avast doesn't start for a while after which is annoying and the system becomes slow like anything until it's ready.

I haven't got any logs since I've removed it until this is fixed - it's worth noting this issue started with the first nitro update, before that, it was fine.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11796
    • AVAST Software
Re: Avast performance since nitro update
« Reply #6 on: August 06, 2016, 01:54:48 PM »
That's actually intentional - to minimize the effect on Windows startup (i.e. on other programs you may want to launch or be launched early), the start of the Avast UI has been delayed - which includes the tray icon.
However, it doesn't mean that your machine is not protected till then - the main service (AvastSvc.exe) is launched earlier and it doesn't need the UI to be running to scan and block infected files. So the real time protection is running, you just don't know about it for a while.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84921
  • No support PMs thanks
Re: Avast performance since nitro update
« Reply #7 on: August 06, 2016, 03:29:45 PM »
how do you measure launch time? Can you provide some perf logs?
pm

I measure the launch time on how it takes avast after logon to load in the tray icon and start real time protection (I've set the taskbar icon to blue animation).
<snip>

You might want to open task manager as soon as you can, because you will see avastUI.exe running in task manager, much sooner that you will see the avast tray icon. That is certainly the case on this system.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Avast performance since nitro update
« Reply #8 on: August 06, 2016, 05:21:27 PM »
That's actually intentional - to minimize the effect on Windows startup (i.e. on other programs you may want to launch or be launched early), the start of the Avast UI has been delayed - which includes the tray icon.
However, it doesn't mean that your machine is not protected till then - the main service (AvastSvc.exe) is launched earlier and it doesn't need the UI to be running to scan and block infected files. So the real time protection is running, you just don't know about it for a while.

Thanks for the explanation.

However until Avast UI is loaded, the system remains sluggish.

This issue only started since the Nitro Update.

Is there a way I can make Avast UI start without delay, I assume it won't be possible via services.msc.

Quote
You might want to open task manager as soon as you can, because you will see avastUI.exe running in task manager, much sooner that you will see the avast tray icon. That is certainly the case on this system.

Yes, you are correct. I want the tray icon to start immediately however.
« Last Edit: August 06, 2016, 05:24:22 PM by Alikhan »
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84921
  • No support PMs thanks
Re: Avast performance since nitro update
« Reply #9 on: August 06, 2016, 06:17:08 PM »
<snip quote>

Quote
You might want to open task manager as soon as you can, because you will see avastUI.exe running in task manager, much sooner that you will see the avast tray icon. That is certainly the case on this system.

Yes, you are correct. I want the tray icon to start immediately however.

I can't see your reasoning in that as Igor said it isn't part of the avast security. But it certainly isn't impeding the performance as per your topic title if the avastUI.exe is actually running but the icon not yet displayed.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Avast performance since nitro update
« Reply #10 on: August 06, 2016, 06:19:51 PM »
<snip quote>

Quote
You might want to open task manager as soon as you can, because you will see avastUI.exe running in task manager, much sooner that you will see the avast tray icon. That is certainly the case on this system.

Yes, you are correct. I want the tray icon to start immediately however.

I can't see your reasoning in that as Igor said it isn't part of the avast security. But it certainly isn't impeding the performance as per your topic title if the avastUI.exe is actually running but the icon not yet displayed.

It is impeding, that's the issue.

Until the Avast tray icon loads, the system is sluggish. It's as simple as that.

All other applications are ready etc but until the tray icon appears, it is slow.

As I said, if I go back to a version before the nitro update, it doesn't occur.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84921
  • No support PMs thanks
Re: Avast performance since nitro update
« Reply #11 on: August 06, 2016, 06:33:06 PM »
I'm not seeing that on either of my systems, I just can't see how it is sluggish whilst the tray icon is loaded when the executable is loaded.

I suspect that there is something else going on around this time, I would take a wild guess that instup.exe may also be running, avast checking for updates.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Avast performance since nitro update
« Reply #12 on: August 06, 2016, 06:36:32 PM »
I'm not seeing that on either of my systems, I just can't see how it is sluggish whilst the tray icon is loaded when the executable is loaded.

I suspect that there is something else going on around this time, I would take a wild guess that instup.exe may also be running, avast checking for updates.

That could be possible regarding instup.exe but I'm sure that process was there in previous versions before the nitro update and they never had issues.

I'll try narrow it down but with Avast removed I don't get the issue.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 70285
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast performance since nitro update
« Reply #13 on: August 06, 2016, 06:38:25 PM »
As you removed Avast, we can't really help you with troubleshooting.
W8.1 [x64] - Avast PremSec 21.4.2463.B4i [UI.617] - EEK - Firefox ESR 78.10.1 [NS/uBO/PB] - TB 78.10.1
Avast-Tools: Secure Browser 90.1 - Cleanup 21.1 - SecureLine 5.11 - Driver Updater 21.1 - CCleaner 5.78
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Avast performance since nitro update
« Reply #14 on: August 06, 2016, 06:42:03 PM »
As you removed Avast, we can't really help you with troubleshooting.

I've just re-installed it around an hour ago.

Running Avast Internet Security latest stable build.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •