Author Topic: [FIXED] You are unprotected! Avast Background service is not running.  (Read 126450 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Re: You are unprotected! Avast Background service is not running.
« Reply #105 on: July 30, 2016, 02:28:03 PM »
Hello, i have the samr problems. After many years of free avast i decided to get a update to internet secure. since than it won't work, i cannot even register.

Offline DPX

  • Jr. Member
  • **
  • Posts: 20
Re: You are unprotected! Avast Background service is not running.
« Reply #106 on: July 30, 2016, 02:30:28 PM »
Fix is already out, all clean installations and updates should be OK. We gonna provide more detail information soon.
That's obviously not true. I have a clean install and it's still not working. I hope Avast releases a patch we can download for this as apparently clean installs don't help at all (and haven't since this ridiculous situation started).

Offline Sbordoni

  • Newbie
  • *
  • Posts: 8
Re: You are unprotected! Avast Background service is not running.
« Reply #107 on: July 30, 2016, 02:34:03 PM »
It seems working fine also into the other notebook with the free version.

On my notebook winning Win10 Home 64 bits, i had the very same problem.

I reinstalled Avast 4 times.

The 3rd time, I used avastclean utility, and i downloaded the installer from myAvast page (the pro version).

At the end of the installation process, the program seemed running fine, until I uninstalled the 2 privacy components:
- secureline vpn
- passwords

From that point, RTS stopped working.

Up to now, the only way to keep it running is to:
- remove the program by using avastclean utility
- install it, without even clicking the personalization button.
- keep these two components


I hope it may help you.

Offline vonetta

  • Newbie
  • *
  • Posts: 1
Re: You are unprotected! Avast Background service is not running.
« Reply #108 on: July 30, 2016, 02:35:42 PM »
Nice to read this but can you tell us how long will it last to fix this bug?

I dindn't update 12.2.2276 so the protection including VPN works.


Hello!

We are aware of this issue and are currently working on a fix.

I'll keep this thread updated.

Our apologies for the inconvenience  :(

Moroni
[/quote]

Offline petr.chytil

  • Quality Assurance Director
  • Avast team
  • Full Member
  • *
  • Posts: 124
Re: You are unprotected! Avast Background service is not running.
« Reply #109 on: July 30, 2016, 02:37:17 PM »
Fixed. All fresh installations are OK from now on.

For existing affected users, fastest way to fix it is to run C:\Program Files\AVAST Software\Avast\AvastEmUpdate.exe and then reboot. Others are getting the fix anyway, it just takes some time.

Sorry for being so brief, we were working hard to get the fix in the production ASAP. You were protected the whole time. The issue was in the GUI - it did not know Avast service is in fact running.

Thanks for your patience,

Petr

Offline GEGEPING

  • Full Member
  • ***
  • Posts: 148
    • Ma Galerie Flickr
Re: You are unprotected! Avast Background service is not running.
« Reply #110 on: July 30, 2016, 02:40:51 PM »
Hi,

I'm currently running previous version 12.1.2272

So, i must update directly or should i make a clean install before?

Gerald
RIP Bx TZD TURBO 520140kms le 15/08/2015 et 26ans
Xantia ok jusqu'en 2018 et la C3 même punition@:
Dédicace à une fille merveilleuse Chloé qui a bien grandi:-)
Tonton d'une nièce nommée Chloé ^^ et du Mathieu dit le chinois

Offline Alpha-UMi

  • Der Ãœberdenker
  • Jr. Member
  • **
  • Posts: 26
  • "Vitam impendere vero"
Re: [FIXED] You are unprotected! Avast Background service is not running.
« Reply #111 on: July 30, 2016, 02:43:13 PM »
I can confirm that the bug has been fixed. I did a couple of reboots just to be sure. :)
"Vitam impendere vero"

REDACTED

  • Guest
Re: [FIXED] You are unprotected! Avast Background service is not running.
« Reply #112 on: July 30, 2016, 02:46:36 PM »
I tried to run AvastEmUpdate but it doesn't respond. Should I still reboot now?

Offline petr.chytil

  • Quality Assurance Director
  • Avast team
  • Full Member
  • *
  • Posts: 124
Re: [FIXED] You are unprotected! Avast Background service is not running.
« Reply #113 on: July 30, 2016, 02:50:28 PM »
I tried to run AvastEmUpdate but it doesn't respond. Should I still reboot now?
Yes, just double click on it. It does not have any UI, it just applies hotfixes. Then reboot.

REDACTED

  • Guest
Re: [FIXED] You are unprotected! Avast Background service is not running.
« Reply #114 on: July 30, 2016, 02:53:51 PM »
Appears to be working ! Finally a solution. Good work !  :)

You really need to work on your communication skills though, keeping quiet about this just won't do.
A lot of people think it's their own systems that are malfunctioning...
I tried to run AvastEmUpdate but it doesn't respond. Should I still reboot now?
Yes, run the AvastEmUpdate (nothing will change then) and then reboot (it should be better then).

Offline Rowan Boatman

  • Jr. Member
  • **
  • Posts: 20
Re: [FIXED] You are unprotected! Avast Background service is not running.
« Reply #115 on: July 30, 2016, 03:02:39 PM »
Ran the emergency update on a Windows Vista system and it fixed avast, however windows still says it cannot detect antivirus software on the computer after multiple restarts, I know it is there and up to date but it really should be talking to windows and not have that notification, any obvious solution (aside from selecting to monitor it myself which I shouldn't have to do).

Offline MaxLV

  • Jr. Member
  • **
  • Posts: 52
Re: You are unprotected! Avast Background service is not running.
« Reply #116 on: July 30, 2016, 03:11:13 PM »
And here I thought a virus infested my master boot record, causing Avast to not run properly and further screw up my machine. I've reset my MBR once and completed three fresh installs of Windows 10... Hours of troubleshooting and work down the drain because someone couldn't do proper Q&A on an update. Not to mention the many hours I'll spend tomorrow trying to reinstall everything. Definitely not how I wanted to spend my weekend...

This is why you (should) have backups.  My story with this buggy update. I have two desktop computers running Windows 10 pro 64 bit. The older computer installed the update and is running it  fine. The newer computer was running it fine  for the first few hours after avast was updated, then it started telling me I was 'unprotected'. I tried the repair install, but that didn't fix it.

Instead of jumping through 'all the hoops' others here have had to do, I restored the previous version of Avast from my weekly and daily backups (15 minutes) then ran the restore point prior to the time this buggy update was installed (5 minutes). Then I was back to a working copy of Avast until they fix (have fixed) the problem. No need to reinstall Windows at all.

Running Avast Internet Security. (paid for annual subscription)
 

Offline Staticguy

  • Super Poster
  • ***
  • Posts: 1429
Re: [FIXED] You are unprotected! Avast Background service is not running.
« Reply #117 on: July 30, 2016, 03:13:40 PM »
Did a fresh clean installation of avast. It's fixed now. Thanks avast for a quick fix. Stayed up all night long until (1:00am NZT) for avast to fix this.  :). Goodnight Avast Team  :)
DELL Inspiron 15" 7000 Gaming, Windows 10 Home Version 21H1 (OS Build 19043.1237), Trend Micro Maximum Security 2021 (17.0.1333), Avast SecureLine VPN (5.12.5655), Windows Firewall, Unchecky 1.2

REDACTED

  • Guest
Re: You are unprotected! Avast Background service is not running.
« Reply #118 on: July 30, 2016, 03:17:47 PM »
Fixed. All fresh installations are OK from now on.

For existing affected users, fastest way to fix it is to run C:\Program Files\AVAST Software\Avast\AvastEmUpdate.exe and then reboot. Others are getting the fix anyway, it just takes some time.

Sorry for being so brief, we were working hard to get the fix in the production ASAP. You were protected the whole time. The issue was in the GUI - it did not know Avast service is in fact running.

Thanks for your patience,

Petr

sorry for my english but i would like to ask some dumb question.

which is the bestway to fix this problem between fresh installations or use avastemupdate.exe?

i mean which one you recommend to do.

fyi : i try repair avast via control panel and reboot just once after it not work i turn off wifi since then. (i post by my phone)

my system : windows 8

thankyou
« Last Edit: July 30, 2016, 03:21:20 PM by nutyatovic »

REDACTED

  • Guest
Re: [FIXED] You are unprotected! Avast Background service is not running.
« Reply #119 on: July 30, 2016, 03:18:56 PM »
I tried to run AvastEmUpdate but it doesn't respond. Should I still reboot now?
Yes, just double click on it. It does not have any UI, it just applies hotfixes. Then reboot.

It replaces the avGui.exe, right? There will be a new one in the directory, dated 07/30/16 after the AvEmUpdater ran.

Then restart the PC, and all is fine.

Schahn