Author Topic: Avast! and K9 anti-spam  (Read 5515 times)

0 Members and 1 Guest are viewing this topic.

cymago

  • Guest
Avast! and K9 anti-spam
« on: December 07, 2003, 03:04:22 PM »
K9 sets a proxy to work on the input mail.

Avast! also will set a proxy to analyse the mail.

Are they compatible and work together?

cymago

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Avast! and K9 anti-spam
« Reply #1 on: December 07, 2003, 03:15:11 PM »
K9 sets a proxy to work on the input mail.

Avast! also will set a proxy to analyse the mail.

Are they compatible and work together?

cymago

I suggest you see this forum and read about the configuration of your spam killer for POP3 and SMTP servers.
I mean, it's posible to use both together. I use Spamihilator (have already used SpamPal too but not simultaneosly with Spamihilator).  ;)
The best things in life are free.

cymago

  • Guest
Re:Avast! and K9 anti-spam
« Reply #2 on: December 07, 2003, 06:51:31 PM »
OK, I have read the K9 doc, the avast help and posts related to proxy.

The K9 email filtering program uses a POP3 proxy server to analyse the incoming mail from the 110 port and uses the 9999 port to make the mail available to the email application (Outlook Express here).

The K9 settings for Outlook Express are:
POP3 server: 127.0.0.1
user name: pop3.tiscali.com/110/robin

I will make the following settings to allow Avast! 4.1 to sits between K9 and Outlook Express

C:\Program Files\Alwil Software\Avast4\DATA\avast4.ini
[MailScanner]
DefaultSmtpServer=smtp.tiscali.com
DefaultPopServer=127.0.0.1:9999 -- Avast! sees the incoming mail on 9999 port
UserDefaultSmtp=0
PopListen=127.0.0:111 -- Outlook Express sees the incoming mail on 111 port

Outlook Express
POP3 server: 127.0.0.1:111 -- changed from 127.0.0.1
user name: pop3.tiscali.com/110/robin -- unchanged!
SMTP server: 127.0.0.1 -- changed from smtp.tiscali.com
enable SMTP authentification
user name for SMTP server: robin#smtp.tiscali.com

comments welcome! seems that some gurus are looking these posts

cymago

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Avast! and K9 anti-spam
« Reply #3 on: December 07, 2003, 07:02:27 PM »
OK, I have read the K9 doc, the avast help and posts related to proxy.

The K9 email filtering program uses a POP3 proxy server to analyse the incoming mail from the 110 port and uses the 9999 port to make the mail available to the email application (Outlook Express here).

The K9 settings for Outlook Express are:
POP3 server: 127.0.0.1
user name: pop3.tiscali.com/110/robin

I will make the following settings to allow Avast! 4.1 to sits between K9 and Outlook Express

C:\Program Files\Alwil Software\Avast4\DATA\avast4.ini
[MailScanner]
DefaultSmtpServer=smtp.tiscali.com
DefaultPopServer=127.0.0.1:9999 -- Avast! sees the incoming mail on 9999 port
UserDefaultSmtp=0
PopListen=127.0.0:111 -- Outlook Express sees the incoming mail on 111 port

Outlook Express
POP3 server: 127.0.0.1:111 -- changed from 127.0.0.1
user name: pop3.tiscali.com/110/robin -- unchanged!
SMTP server: 127.0.0.1 -- changed from smtp.tiscali.com
enable SMTP authentification
user name for SMTP server: robin#smtp.tiscali.com

comments welcome! seems that some gurus are looking these posts

cymago

Seems ok, do not forget to change the OE account settings (Advanced) for listen the port 111 and not 110 (which is the default).

I do not understant the slashes "/" you used: pop3.tiscali.com/110/robin
The best things in life are free.

cymago

  • Guest
Re:Avast! and K9 anti-spam
« Reply #4 on: December 07, 2003, 07:12:51 PM »
pop3.tiscali.com/110/robin

/ is the K9 separator character. K9 asks the POP3 server pop3.tiscali.com to send the mail for robin using port 110.

cymago

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Avast! and K9 anti-spam
« Reply #5 on: December 07, 2003, 09:33:01 PM »
pop3.tiscali.com/110/robin

/ is the K9 separator character. K9 asks the POP3 server pop3.tiscali.com to send the mail for robin using port 110.

cymago

Ok, good luck. Seems to be an unusual configuration for Outlook Express anyway..., usually the user must have: robin#pop3.tiscali.com:110 (see help files: Ann.Jones#pop3.tiscali.com).
The best things in life are free.