Author Topic: Antivirus problem on Windows 7 pagefile other than on C:  (Read 1665 times)

0 Members and 1 Guest are viewing this topic.

Offline zen_owl

  • Newbie
  • *
  • Posts: 3
Antivirus problem on Windows 7 pagefile other than on C:
« on: September 01, 2016, 12:32:25 AM »
Hello,

    Avast Antivirus Free 12.3.2280 is creating a problem on my F: Windows 7 page file at boot time.


Setup:

Windows 7 x64 Ultimate SP1 fresh install (no additional patch) + 3 Intel drivers (chipset, storage and LAN adapter) + .Net 4.5 + Avast Antivirus Free, and nothing else.
Pagefile.sys configured to be on Drive F:.
OS installed on C:.
MBR partition.
Avast Antivirus Free 12.3.2280
Installed components are only File, Mail, Web, Software Updater, Browser Cleaner and Gadget.
All the rest is not installed, this is a Custom install.
No option / parameter touched in Avast configuration.
I verified that in the File Agent parameters, "?:\PageFile.sys" is specified as an exclusion.


Symptom:

Every other boot, i.e. right since after the Avast Antivirus install, and then every 2 boots after that, I get a Windows pop up saying:

Quote
Windows created a temporary paging file on your computer because of a problem that occurred with your paging file configuration when you started your computer. The total paging file size for all disk drives may be somewhat larger than the size you specified.

I can verify that when there is the pop up at boot time, i.e. every "odd" reboot, there is no pagefile.sys on F:, and a temporary one is created on C:.
When there is no pop up, i.e. every "even" reboot, the pagefile is right where it is configured on F:, and not on C:.

The problem occurs only when the page file is configured to be on F:.
When I set it to C:, there is no problem.

As soon as I uninstall Avast Antivirus, the message never appears anymore at boot time, whatever the number of reboots I do.
As soon as I reinstall it, it appears again.

I did twice the full sequence of installing the OS fresh after formattinfg the 2 drives C: and F:, and the drivers + .Net (needed by the Intel storage driver install) + Avast Antivirus and a number of reboots to verify.
Same effect in both cases, appearing as soon as Avast Antivirus is installed and disappearing when uninstalled.


So this is clearly linked to Avast Antivirus presence.

I tried to deactivate all protections, to modify options like detecting rootkits, launching avast service later .. etc .. this has no effect.
Only an uninstall is removing the problem.

I did a scan at start to make sure, there is nothing detected. And anyway this is a fresh OS install ...  ;D


Demand:
  • What can be causing the problem ?
  • I had in the past the same W7 installed on the computer with previous versions of Avast Antivirus and the same drive setup for pagefile.sys, and there was no problem => can this be a bug introduced in recent versions ?

Can you help ?
« Last Edit: September 01, 2016, 12:36:40 AM by zen_owl »

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 62795
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Win 8.1 [x64] - Avast PremSec 20.1.2396.Beta#3 [UI.457] - CC 5.63 - EEK - Firefox ESR 68.5 [NS/AOS/uBO/PB] - TB 68.5 - ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline zen_owl

  • Newbie
  • *
  • Posts: 3
Re: Antivirus problem on Windows 7 pagefile other than on C:
« Reply #2 on: September 01, 2016, 10:21:56 PM »
Ok, I did so ..

The tool fails on compatibility check saying there is another antivirus.
However there is no other antivirus in the computer than Avast Antivirus Free itself .. !!

Reminder: this is a fresh install of Win7 SP1, no patch no nothing, and only 3 drivers
=> there are only 4 programs installed which are AVAST and the 3 drivers

Anyway, I submitted ticket #489029 and uploaded information 20160901_2011_FSLWA_1417239550.zip

Thanks, zen_owl.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 62795
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Antivirus problem on Windows 7 pagefile other than on C:
« Reply #3 on: September 02, 2016, 05:57:18 AM »
You're welcome.
Win 8.1 [x64] - Avast PremSec 20.1.2396.Beta#3 [UI.457] - CC 5.63 - EEK - Firefox ESR 68.5 [NS/AOS/uBO/PB] - TB 68.5 - ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline zen_owl

  • Newbie
  • *
  • Posts: 3
Re: Antivirus problem on Windows 7 pagefile other than on C:
« Reply #4 on: September 25, 2016, 03:31:27 PM »
Hello, some more news, which I posted also in the ticket.

I could refine further the problem, and I can determine that it happens only when I set a "Custom size" on my F:\pagefile.sys.

If I set the parameter to "System Managed Size", there is no problem.

Therefore, Avast Antivirus Free interferes only in that specific scenario on W7 SP1.
Given that this is a solid error, I guess that somebody from Avast should be able to reproduce it on their systems, and investigate it.

Hope this helps somebody if they fall on the same problem,
zen_owl.