Author Topic: wi-fi calling screwed after using ABS  (Read 3038 times)

0 Members and 1 Guest are viewing this topic.

Offline jasoncollege24

  • Jr. Member
  • **
  • Posts: 71
wi-fi calling screwed after using ABS
« on: October 05, 2016, 10:19:24 PM »
Router details
Name: Belkin N600DB Wireless Router
Model: F9K1102 v3 (01)
Firmware: 3.04.06 (Mar 17, 2014) (LATEST!)
Boot Loader: v0.12
Intellistream: OFF
2GHz Band: ON (Channel 11)
Bandwidth: 20/40Mhz
Wireless mode: 802.11 b/g/n
SSID Broadcast: ON
5GHz band: OFF
Firewall: ON (Disabling this has no effect)
IPv4: Working normally
IPv6: Pass-Through (ISP natively supports IPv6, and cannot be disabled in router)
DMZ: Disabled
DHCP Server: Enabled
WPS: Enabled
Wireless Security: WPA2-PSK
Parental Control: OFF

Phone Information
Model Name: LG Leon LTE
Model Number: LGMS345
Carrier: MetroPCS
Android Version: 5.1.1
IP Type: DHCP (IP address obtained successfully for both IPv4, and IPv6)

Symptoms:
A connection with my router causes the phone to have internet, but no wi-fi calling. Occassionally, the phone will tell me that I have no internet, and then it automatically switches to mobile data. Usually the error message I receive when this happens is something along the lines of "No internet on [wi-fi name]" and then the phone switches to mobile data.

When did symptoms begin?
When I installed Avast Battery Saver

Error Messages:
Enabling wi-fi calling on the above network results in the following error - Error: REG99 "Unable to connect"

Did it ever work?
Originally it worked fine for a day or two, (even made some wi-fi calls on the above network, so I know it was working), until I installed the Avast Battery Saver app, then I would get the message wi-fi calling wasn't available, including the above error message, and the wifi would drop out intermittently, until it just stopped working. At that point, my phone was telling me that it was not getting an IP address from the router. (eg. IP address unavailable) Setting a static IP address worked to get internet, but wi-fi calling was still broken. Returning to DHCP resulted in an unavailable IP address again. I uninstalled the Avast Battery Saver app, before I performed the factory reset. Uninstalling, and then reset did not restore wi-fi calling for this network, but seems to have otherwise restored wi-fi internet access on this network.

Do other devices work properly on the same network?
Yes! All of them do! I have various devices on my network that include the following:
  • Netgear Wireless G Router (isolated wireless access point for connecting infected devices to the internet for cleaning)
  • Win10 Desktop (x2)
  • Win10 Laptop (x2, wireless)
  • Mac
  • AppleAir
  • Apple Time Capsule (wireless radio is off)
  • Linux Desktop
  • PS3 (x2)
  • Apple iPhone
  • Samsung Smart TV (x2)
  • Samsung Android Phone

Things I've tried:
Factory reset - fixed the unavailable IP address problem, but not wi-fi calling, which resulted in current symptoms.
Disable/enable Wi-Fi on phone - no changes
Modify Network - static IP address resolved no internet before reset, but resulted in no wi-fi calling (Error REG99 "Unable to connect") Have not tried this step since resetting
Try a different network - Wi-Fi calling works on other networks
Connect to isolated Wireless G - Same results
Switch to Mobile Data - Mobile data works fine! Issue is with Wi-Fi on the above network

Any suggestions, or ideas on how to fix this would be great! If you need more information, please do not hesitate to ask for it! Thanks in advance!

Offline Štěpán Vaněk

  • Avast team
  • Jr. Member
  • *
  • Posts: 82
Re: wi-fi calling screwed after using ABS
« Reply #1 on: November 04, 2016, 06:08:44 PM »
Hi,
thanks for nice detailed description, however we are missing few important information

1. What ABS version are you using
2. What is the name of wifi calling app
3. Have you been stopping apps in Battery Saver before your wifi calling stopped working?
4. Is any profile active? Have you checked its settings?

So far we have no clue, as BS just turns wifi on/off according to settings of your profile. But hopefully we can solve that once you respond our addition questions.
Cheers!