Author Topic: [Résolu] Gros problème à la désinstallation d'Avast  (Read 9261 times)

0 Members and 1 Guest are viewing this topic.

Offline Tyro

  • Newbie
  • *
  • Posts: 4
[Résolu] Gros problème à la désinstallation d'Avast
« on: February 13, 2017, 01:47:16 AM »
Bonjour à tous !
Voici mon problème : j'ai voulu désinstaller Avast. J'ai donc téléchargé sur leur site, l'outil "Avast Clear".
Je l'ai lancé, il m'a demandé de redémarrer l'ordinateur en Mode Sans Échec, ce que j'ai accepté.

L'ordinateur redémarre en MSE, mais j'ai un message d'erreur : "Impossible d'ouvrir avastclear.exe à l'aide du compte Administrateur intégré. Connectez-vous à l'aide d'un autre compte, puis réssayez." et le fichier refuse de se lancer (même en le lancant en tant qu'administrateur)
Je décide de redémarrer, et là il se lance, et me désinstalle Avast.

OUI MAIS VOILA

Lorsque je veux redémarrer l'ordinateur, impossible de sortir du MSE (Je suis sous Windows 10) Il redémarre constamment sous ce mode.
Obligée d'aller dans les options de récupération pour lancer windows normalement, mais même après avoir fait ca, en redémarrant par la suite, je retourne en mode sans échec ...

J'ai vu sur certains forums qu'il fallait "Windows+R" , taper MSCONFIG, dans l'onglet "Général" choisir le "Démarrage normal" mais il n'est pas accessible.
Et dans l'onglet "Démarrer" j'ai 2 systèmes d'exploitation : Windows 10, ET Avast Clear qui est en Système d'exploitation par défaut, et en démarrage sécurisé (mode sans échec j'imagine)
Même si je démarre sur Windows et que j'essaye de supprimer ce "Système d'exploitation Avast" il réapparait tout le temps.

Quelqu'un connait-il ce problème et aurait-il une solution?

Merci d'avance :D
« Last Edit: February 14, 2017, 06:59:47 PM by Tyro »

Offline chris..

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1987
Re: Gros problème à la désinstallation d'Avast
« Reply #1 on: February 13, 2017, 07:49:36 AM »
Bonjour,

essayes de retourner dans MSCONFIG mais dans l'onglet BOOT.INI

1-décocher safeboot (qui doit être coché)
2-vérifier si dans la fenêtre du haut il y a une ligne concernant avastclear (la faire descendre)
3-sinon éditer le fichier boot.ini à la racine du disque c: , en y effaçant cette ligne (seulement celle-ci)

ps:je ne sais pas si ça fonctionne comme ça sous w10.

Offline Tyro

  • Newbie
  • *
  • Posts: 4
Re: Gros problème à la désinstallation d'Avast
« Reply #2 on: February 13, 2017, 07:47:25 PM »
Merci de ta réponse !

Non il n'y a pas d'onglet BOOT.INI sur msconfig sous windows 10 :/

Offline chris..

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1987
Re: Gros problème à la désinstallation d'Avast
« Reply #3 on: February 13, 2017, 08:39:36 PM »
C'est bien ce que je craignais , n'ayant aucune expérience de W10.

Ceci dit , boot.ini existe sur W10 et tout porte à croire qu'avec ce que tu décrits dans ton 1er message , il a été modifié.

Sur ce lien il est expliquer comment réparer ce fichier.

Je ne vais pas m'aventurer plus loin par manque d'expérience.

Offline Tyro

  • Newbie
  • *
  • Posts: 4
Re: Gros problème à la désinstallation d'Avast
« Reply #4 on: February 14, 2017, 02:41:08 PM »
Merci.

Le problème est que j'ai l'impression qu'avast clear recréé un "système d'exploitation" à chaque redémarrage de l'ordinateur :( Vu que j'ai essayé de le supprimer graphiquement et qu'au redémarrage j'avais le même probleme.
J'ai vu une tâche planifiée au nom d'Avast alors qu'il avait été désinstallé... Que j'ai évidemment désactivée, mais sans succès.

Offline chris..

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1987
Re: Gros problème à la désinstallation d'Avast
« Reply #5 on: February 14, 2017, 06:23:37 PM »
As tu effectué la procédure proposée?

Ce n'est pas avast clear qui recrée un système d'exploitation et le supprimer ne résoudra rien.

C'est juste qu'avast a modifié ton fichier boot.ini de sorte qu'à chaque fois que tu allumes ton ordi , le boot indique qu'il faut ouvrir le système d'exploitation "avast clear" en mode sans échec..
Tant que tu n'auras pas remis boot.ini (il est à la racine de C: aussi sous W10) en son état d'origine (ou au moins supprimer la ligne qui dit qu'il faut démarrer avec avast) le problème restera.

La procédure donnée par le lien est simple
Les 3 commandes "attrib" sont pour que tu puisses y avoir accès
La commande "del" pour le supprimer
La commande "bootcfg /rebuild" pour le remettre en son état d'origine.


Offline Tyro

  • Newbie
  • *
  • Posts: 4
Re: Gros problème à la désinstallation d'Avast
« Reply #6 on: February 14, 2017, 06:59:20 PM »
Re-Bonjour :)

J'ai essayé la procédure du lien proposé (J'ai eu un peu peur de toucher à un fichier système mais ca s'est bien passé ^^). Je redémarre, c'est ok ... Délivrance? Non car j'ai reessayé de désinstaller avast via le même outil, et ca m'a refait la même chose ... Mais j'ai trouvé un autre moyen ! :D

MA SOLUTION :

- Effectuer une restauration système à une date ou il y avait encore Avast.
- Télécharger Avast Clear et enregistrez-le sur le bureau, mais SANS LE LANCER !
- Redémarrer en mode sans échec : Shift+Clic sur le bouton "Redémarrer" Voir le lien : http://forums.cnetfrance.fr/topic/1287795-windows-10--comment-demarrer-en-mode-sans-echec
- Tentez de lancer Avast clear (Sur le bureau) Si cela ne fonctionne pas, allez dans : Clic droit > Propriétés > et cochez la case qui empêche le systeme de bloquer le fichier
- Après suppression d'Avast via l'outil, redémarrez l'ordinateur, ET VOILA !

Problème résolu :D

Merci beaucoup de ton aide Chris05 !

Offline chris..

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1987
Re: [Résolu] Gros problème à la désinstallation d'Avast
« Reply #7 on: February 14, 2017, 08:02:57 PM »
Super,

Oui , c'est le coup classique (qu'a du faire avast automatiquement) de toujours redémarrer dans le dernier mode tant qu'on ne lui dit pas de changer à nouveau , c'est en passant par msconfig qu'on peut normalement le faire.
On peut le faire comme tu as fait mais aussi juste au démarrage de windows en appuyant sur une touche fonction (généralement F8 , mais pas toujours)

Si l'onglet "boot.ini" n'apparaissait pas chez toi dans msconfig, c'est sans doutes parce que tes fichiers cachés et système n'étaient pas configurés dans "option des dossiers" pour être visibles.
boot.ini invisible à la racine de c: et donc aussi invisible en tant qu'onglet dans msconfig.

Offline acara.maroni

  • Newbie
  • *
  • Posts: 4
Re: [Résolu] Gros problème à la désinstallation d'Avast
« Reply #8 on: February 25, 2017, 01:03:59 PM »
Bonjour;
Je viens me raccrocher à ce sujet ayant exactement le même souci que Tyro mais avec une autre approche:
- Je n'avais pas de point de restauration valide (?) et le fichier "boot.ini" est invisible que je sois logé en session Utilisateur standard ou Admin bien qu'ayant dans les deux cas décoché "Masquer les fichiers systèmes".
Du coup, pas de restauration ni - pour le moment - de possibilité de modifier le fichier de boot W10

Au secours! et merci par avance

Offline chris..

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1987
Re: [Résolu] Gros problème à la désinstallation d'Avast
« Reply #9 on: February 25, 2017, 01:23:13 PM »
Quote
Maintenant A CHAQUE BOOT je dois choisir entre W10 et AvastClear !
Est-ce que W10 te propose que ces 2 choix?
Sinon ,as tu essayé la méthode par la touche "F8"(ou autre fonction,dépend de ta config) juste au démarrage ?
Par exemple "démarrer windows normalement"(à essayer),ou "dernière bonne config"
nb:je parle en aveugle ne connaissant pas w10.

As tu essayé la procédure de pc astuce (voir lien donné le 13 février) , pour réinitialiser le fichier boot.ini ?
Comme je le disais ce fichier existe aussi sous w10 , bien que je ne sache pas où il se trouve.




Edit:j'ai parlé trop vite , en effet le fichier n'existe plus dans w10

essayes un peu dans cette direction
http://forums.cnetfrance.fr/topic/1346169-ecriture-d-un-multiboot-pour-windows-10/
https://msdn.microsoft.com/fr-fr/library/windows/hardware/mt450468(v=vs.85).aspx

http://www.wubijacq.com/easybcd/
Editer le menu de démarrage en supprimant avastclear?


si tu parviens à avoir la console de réparation au démarrage , je pense que tu peux réparer le boot
en anglais
http://www.thewindowsclub.com/repair-master-boot-record-mbr-windows
« Last Edit: February 25, 2017, 02:47:51 PM by chris05 »

Offline acara.maroni

  • Newbie
  • *
  • Posts: 4
Re: [Résolu] Gros problème à la désinstallation d'Avast
« Reply #10 on: February 25, 2017, 06:29:35 PM »
Bon, voilà le souci est résolu  :) et plus simplement que je n'en avais peur ("paceque" les bidouilles je crains  :-[):
Pour modifier le boot de W10 (puisque le fichier "boot.ini" n'existe plus en tant que tel) il faut passer par "msconfig" puis sélectionner l'onglet "Démarrer".
Sélectionner "Système d'exploitation Avast" puis "Supprimer".
Il ne doit rester que "Windows 10(C:\WINDOWS) : Système..........".
NE PAS OUBLIER DE FAIRE "Appliquer" !.
L'OS demande à redémarrer et - dans mon cas - comme il ne reste que Windows plus de choix possible et donc démarrage normal.

En espérant que cela serve à d'autres merci @ tous

Offline chris..

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1987
Re: [Résolu] Gros problème à la désinstallation d'Avast
« Reply #11 on: February 25, 2017, 06:51:33 PM »
[edit] oups désolé , j'ai peut être dit une bêtise


« Last Edit: March 05, 2017, 01:49:12 PM by chris05 »