Author Topic: Avast 4.6.763 incredible slows down my windows xp shutdown process  (Read 13286 times)

0 Members and 1 Guest are viewing this topic.

Offline jpavel

  • Newbie
  • *
  • Posts: 15
  • I'm a llama!
    • Pobre Página do Prof. Juliano
Ok, I've seen at avast site that there was an attempt to solve this problem at the 4.7.623 version. Ok... I installed avast 4.6.763 last week and everything was fine until 2 days ago, when the system becomes incredible slow to perform the shutdown (the "Windows is shutting down" screen in Windows XP home edition)... it started taking about 3 to 5 minutes to shutdown.

Well, after a lot of tests with some of the programs that were installed in my computer, I found that when I kill the ashserv.exe process, the system get back to normal shutdown delay.

Is there anything I'm missing? Is there anything I can do to solve this problem?

Juliano/Brazil
« Last Edit: March 10, 2006, 06:51:56 PM by jpavel »

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Avast 4.6.763 incredible slow windows xp shutdown process
« Reply #1 on: March 05, 2006, 01:37:02 PM »
I have experienced no problems with this build.  However, I have experienced the same problem with ZA pro so what I do is shut down ZA before I shutdown windows.  Do you use ZA?  Also if it initialy worked with no problem I would assume that some other element is causing your slowdown, or am I misreading your post ?

Offline jpavel

  • Newbie
  • *
  • Posts: 15
  • I'm a llama!
    • Pobre Página do Prof. Juliano
Re: Avast 4.6.763 incredible slow windows xp shutdown process
« Reply #2 on: March 05, 2006, 01:44:03 PM »
essexboy,

Before I try kill any avast process, I've tried kill zonealarm, and it didn't sove the slow shutdown problem. Thank you anyway. I'm listening for more sugestions...

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Avast 4.6.763 incredible slow windows xp shutdown process
« Reply #3 on: March 05, 2006, 02:40:08 PM »
Before I try kill any avast process, I've tried kill zonealarm
No troubles at shutdown here... I'm using ZA either... Which version are you using? I think there was an update recently...
Did you try to uninstall (and not only disable) ZA?
The best things in life are free.

Offline jpavel

  • Newbie
  • *
  • Posts: 15
  • I'm a llama!
    • Pobre Página do Prof. Juliano
Re: Avast 4.6.763 incredible slow windows xp shutdown process
« Reply #4 on: March 05, 2006, 03:41:50 PM »
Tech,

I've just update my Zone Alarm, but it seems it had no effect at all. The shutting down problem persists... I also tried shutting down msn, as I had configured it to use Avast to check for incoming files viruses (Tools->Options->File Transfers).

Acctually, the only thing I do that seems to work fine is kill the ashserv.exe process.

I'm still listening for new things to tryout.
« Last Edit: March 05, 2006, 11:25:05 PM by jpavel »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11786
    • AVAST Software
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #5 on: March 05, 2006, 04:06:55 PM »
Does the avast! icon spin during the slow shutdown (if it's still visible)?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Avast 4.6.763 incredible slow windows xp shutdown process
« Reply #6 on: March 05, 2006, 04:14:01 PM »
Acctually, the only thing I do that seems to work fine is kill the ashserv.exe process.
If just before shuting down you left click the 'a' blue icon and let the Standard Shield properties being shown, can you see the 'last' scanned file there?
The best things in life are free.

Offline jpavel

  • Newbie
  • *
  • Posts: 15
  • I'm a llama!
    • Pobre Página do Prof. Juliano
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #7 on: March 05, 2006, 04:15:53 PM »
Igor, when I begin shutting down, yes, it spins. But I can't see it during all the shutdown process... after a while, windows does a logoff and starts the shutting down routine... it passes to the "saving user's preferences" (or something like that) screen and then it stays a lot of time in the next message screen ("windows is shutting down")... during this message, at first, some disk access is performed, but only in the very begining. After this very begining period, comes a looooong period where no disk access is performed and the shutting down process seems it won't finish anymore. After a few minutes (about 4 or 5 minutes) the shuttdown process finish successfully.
« Last Edit: March 05, 2006, 04:23:07 PM by jpavel »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #8 on: March 05, 2006, 06:32:46 PM »
Jpavel, can you go Control Panel > Administrative Tools > Events
And check in each category if there is an ERROR while saving the user registry while shutting down or something similar?
Ist there any other error that could be interesting to know and troubleshoot?
The best things in life are free.

Offline jpavel

  • Newbie
  • *
  • Posts: 15
  • I'm a llama!
    • Pobre Página do Prof. Juliano
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #9 on: March 05, 2006, 07:10:45 PM »
Tech,

  There was no Errors, but there was a warning at the Application branch that may be related to the problem. It it's in Portuguese because is my default langage, but I'm gonna translate it:

"Windos has saved JOEY\Juliano Pável's User Registry Entry while an aplication or service still was using the Registry during logoff. The memory used by the user's Registry hasn't been released. The Registry will be flushed when it's not in use anymore.

Often this is caused by services that are being executed as an user account. Try setting them to run in the LocalService or NetworkService account."

(Same warning in Portuguese: "O Windows salvou o Registro JOEY\Juliano Pável do usuário enquanto um aplicativo ou serviço ainda estava usando o Registro durante o logoff. A memória usada pelo Registro do usuário não foi liberada. O Registro será descarregado quando não estiver mais em uso.

 Em geral, isso é causado por serviços que estão sendo executados como uma conta de usuário. Tente configurá-los para que sejam executados na conta LocalService ou NetworkService.")

Juliano

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #10 on: March 05, 2006, 07:19:36 PM »
"O Windows salvou o Registro JOEY\Juliano Pável do usuário enquanto um aplicativo ou serviço ainda estava usando o Registro durante o logoff. A memória usada pelo Registro do usuário não foi liberada. O Registro será descarregado quando não estiver mais em uso. Em geral, isso é causado por serviços que estão sendo executados como uma conta de usuário. Tente configurá-los para que sejam executados na conta LocalService ou NetworkService."
This is the problem... but what is causing this is unknown for me.
I'll think and post later...
The best things in life are free.

Offline MrRAlan

  • Full Member
  • ***
  • Posts: 195
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #11 on: March 05, 2006, 11:13:51 PM »
Do you have the avast and VRDB system tray icons merged?  If so, this causes a long delay in the shutdown process most of the time.  This has been mentioned before but apparently avast cannot find a fix for it.

Offline jpavel

  • Newbie
  • *
  • Posts: 15
  • I'm a llama!
    • Pobre Página do Prof. Juliano
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #12 on: March 05, 2006, 11:24:27 PM »
Thank you, MrRAlan! It seems the problem is solved. I've split up the icons into VRDB and avast again and the shutdown becomes normal in the first test I've just made. If something strange happen again, I'll report it here.
« Last Edit: March 05, 2006, 11:48:48 PM by jpavel »

Offline CharleyO

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7085
  • Be alert for error code - ID 10T
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #13 on: March 05, 2006, 11:39:00 PM »
***

Thank you for posting help, MrRAlan.    :)

Welcome to the forums, jpavel.    :)

I am sure we are all happy that your problem is solved.

Please come back often, learn more, and maybe help others.    :)


***
Self-built desktop (8 years old) - AMD64 3200+_Gigabyte GA-K8NS Ultra-939_4 gb RAM_GeForceFX 5800w/256 ram_XP/SP3_Avast 7_MBAM_ZA Free __and__ Toshiba Satellite Laptop_W7-64bit_ 4 gb Ram_Avast 8_MBAM

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #14 on: March 06, 2006, 10:52:58 PM »
MrRAlan, that sort of surprises me. Your saying this is a KNOWN problem and a KNOWN workaround (to split the icons)? I hear something like that for the first time...

If at first you don't succeed, then skydiving's not for you.