Author Topic: Avast 4.6.763 incredible slows down my windows xp shutdown process  (Read 13285 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84611
  • No support PMs thanks
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #30 on: March 11, 2006, 03:36:18 PM »
You have to provide either the full path to the file or use wild cards ' * ' as indicated in the image, example c:\*\sysreco.xml. In your original path 'C:\Program Files\IBM\Updater\' the Program Files part may not work because it it longer than 8 characters and has a space in it. Co you may need to enclose the complete path in "quotes" or use  C:\Progma~1\IBM\Updater\sysreco.xml or use wild cards.

I have no idea what file IBM Access uses (I haven't got that program), but surely you have identified the file which is being assessed.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11786
    • AVAST Software
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #31 on: March 13, 2006, 12:58:12 AM »
What exactly did you put into the list of exclusions?

Offline jpavel

  • Newbie
  • *
  • Posts: 15
  • I'm a llama!
    • Pobre Página do Prof. Juliano
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #32 on: March 13, 2006, 01:10:32 AM »
igor,

I put exactly

     C:\Arquivos de Programas\IBM\Updater\SYSRECO.XML

Where "Arquivos de Programas" means "Program Files" in an english based operating system. And it still doesn't work, even if I use wildcards (c:\*\sysreco.xml, for example).

    Juliano
« Last Edit: March 13, 2006, 01:13:14 AM by jpavel »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #33 on: March 13, 2006, 02:25:08 AM »
jpavel, why don't you try:
C:\Arquiv~1\IBM\Updater\SYSRECO.XML
The best things in life are free.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11786
    • AVAST Software
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #34 on: March 13, 2006, 04:36:55 PM »
C:\*\SYSRECO.XML should certainly work (and it's a short name, so there shouldn't be any long/short filename problem).

Are you sure it's the one causing the heavy scanning? I.e. if you put this mask into the list of exclusions and check the "Last scanned" item of the Standard Shield - is it really the matching file that keeps appearing there?

Offline jpavel

  • Newbie
  • *
  • Posts: 15
  • I'm a llama!
    • Pobre Página do Prof. Juliano
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #35 on: March 13, 2006, 05:04:11 PM »
Igor, I'm not sure if SYSRECO.XML is the one responsible for the heavy work... but it is the only one markup language file related to IBM tools I've found that was constantly changing. If fact, it's not even real big. Its about 300K.

About the last scanned file... it changes from time to time (I mean, as I can see when de system is rebooting or shutting down).

Juliano

Offline posbis

  • Newbie
  • *
  • Posts: 1
Re: Avast 4.6.763 incredible slows down my windows xp shutdown process
« Reply #36 on: June 22, 2006, 12:00:39 PM »
Ok, I've seen at avast site that there was an attempt to solve this problem at the 4.7.623 version. Ok... I installed avast 4.6.763 last week and everything was fine until 2 days ago, when the system becomes incredible slow to perform the shutdown (the "Windows is shutting down" screen in Windows XP home edition)... it started taking about 3 to 5 minutes to shutdown.

Well, after a lot of tests with some of the programs that were installed in my computer, I found that when I kill the ashserv.exe process, the system get back to normal shutdown delay.

Is there anything I'm missing? Is there anything I can do to solve this problem?

Juliano/Brazil

Have the same problem with Avast 4.7.xxxx

I have a complex setup in my home environment.
- Windows 2003 Active Directory Domain
- Roaming Profiles
- SmartCard Authentication
- ....

My Windows XP Workstation suffers from the same slow shutdown. When I read through this forum somebody mentioned an Event-Log entry saying that the user registry (ntuser.dat) cannot be unloaded.

That was the point when I remembered that I had the same problem in our enterprise network at our company. Lots of PCs (NT4, 2K, XP) had extremely long shutdown times.

The reason is because some buggy applications (not especially MS ones but some MS as well :-) do not close their registry handles correctly when logging off. Therefore the romaing profile (especially the ntuser.dat (= HKCU) cannot be unloaded and the system waits until these processes die before unloading the registry.

Interesting is that MS has no fix for this (is not so easy to handle this cleanly in coding) but some MS guy wrote a really cool workaround which works quiet good for such applications. It seems that the tool is kind of supported by MS and offered through the standard download channels.

We distributed it on all our company workstations and the result is really good.

So I installed it on my XP workstation and did a shutdown with ZoneAlarm and Avast fully loaded. The system went down smoothley and the message in the event log was gone. The tool is a service (uphclean.exe) and checks  the open handles to the registry on shutdown. If there are some it does some cleanup work by remapping or closing them and to free HKCU for unloading.

Give it a try.

http://www.google.com/url?sa=U&start=1&q=http://www.microsoft.com/downloads/details.aspx%3Ffamilyid%3D1B286E6D-8912-4E18-B570-42470E2F3582%26displaylang%3Den&e=9797

or

Google for: uphclean (it is the first link)

Hope this helps for some of you as well.