Author Topic: How to disable "Enable hardware-assisted virtualization"  (Read 46887 times)

0 Members and 1 Guest are viewing this topic.

Offline -matteo-

  • Newbie
  • *
  • Posts: 8
How to disable "Enable hardware-assisted virtualization"
« on: March 09, 2017, 11:52:12 AM »
Hi,
many devices are reporting heavy problems with virtual machines since the last week. I checked personally many of these notebooks/desktops and I saw it's impossible to use the installed virtual machines both by using VMware Player/Workstation and VirtualBox.
I think so I found out a workaround by reading the post https://forum.avast.com/?topic=196714.0. Exactly I followed these instructions:
  • Go to "Settings" - "Troubleshooting" - remove checkmark at "Enable hardware-assisted virtualization" - reboot PC
However, even if I uncheck the flag "Enable hardware-assisted virtualization" on a client machine after a little the Avast client synchronizes itself to the cloud server. So, the sync process resets the flag to its original configuration ("Enable hardware-assisted virtualization" -> ON). How can I set this flag by using the cloud console? I don't see any option to disable "Enable hardware-assisted virtualization" from the cloud console.

I am in touch with the support with no success for now, and we have dozens of laptops with this issue  :(.

Thanks to everyone!!

Offline misak

  • Avast team
  • Sr. Member
  • *
  • Posts: 234
    • Personal page (CZE)
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #1 on: March 09, 2017, 01:19:48 PM »
Hi matteo,

we will add the ability to change the "Enable hardware-assisted virtualization" setting remotely into next version. ETA for release is 15/3/2017.
Meanwhile we are working on micro-update which should fix the root cause.

Offline -matteo-

  • Newbie
  • *
  • Posts: 8
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #2 on: March 09, 2017, 02:08:35 PM »
Hi matteo,

we will add the ability to change the "Enable hardware-assisted virtualization" setting remotely into next version. ETA for release is 15/3/2017.
Meanwhile we are working on micro-update which should fix the root cause.

Ok, misak... I will wait for the next release of 15/03/2017.

Many thanks!

jburge@starplastics.com

  • Guest
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #3 on: March 16, 2017, 03:06:29 PM »
Has the micro update been released yet that fixes these virtualization problems?  We are on build 17.2.3419.61 and are still experiencing this problem.

Offline -matteo-

  • Newbie
  • *
  • Posts: 8
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #4 on: March 16, 2017, 03:28:02 PM »
I just applied manually the micro update on some PCs but they are facing the same issues  :'(. So, I'm trying to disable the "Enable hardware-assisted virtualization" feature by using the remote console.

In the meanwhile on some PCs we needed to remove totally Avast in order to allow to users to work by using the local virtual machines.

I am also in touch with the Avast support, and they suggested me these instructions:
Quote
Hello. We have released a micro update to correct some of the issues with our recent version release.

There are two ways to update the version. The first is to go into the C:\Program Files\AVAST Software\Avast folder and run the AvastEmUpdate exe. Once the update is done a reboot will be necessary.

Or

This update will require two reboots to complete the install. The first reboot is to start the AvastEmUpdate task to look for and download the new micro update. You should only need to allow 3-5 minutes for the update to happen and then you can reboot. If you want to confirm the update has been applied, you can review the following registry keys to see if the Microupdate version is now 239.

It can be found in registry in:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\AVAST Software\Avast (64bit)
or
HKEY_LOCAL_MACHINE\SOFTWARE\AVAST Software\Avast (32bit)

and the value is MicroUpdates.

jburge@starplastics.com

  • Guest
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #5 on: March 16, 2017, 09:17:45 PM »
Thanks for sharing that.  I tried the instructions from Avast support and that did not work.  Disabling the "Enable hardware-assisted virtualization" setting did not work either.  Like you, the only we we can run virtual machines is to uninstall Avast.  It is frustrating that Avast can't get this fixed.

Offline -matteo-

  • Newbie
  • *
  • Posts: 8
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #6 on: March 17, 2017, 10:41:46 AM »
Thanks for sharing that.  I tried the instructions from Avast support and that did not work.  Disabling the "Enable hardware-assisted virtualization" setting did not work either.  Like you, the only we we can run virtual machines is to uninstall Avast.  It is frustrating that Avast can't get this fixed.

You're welcome... I just reopened the ticket to the support since they signed the ticket as solved  >:(.
Let you know as soon as they answer to me.

jburge@starplastics.com

  • Guest
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #7 on: March 17, 2017, 07:36:48 PM »
I just updated to the latest micro update, 64,and it did not fix the virtual machine problem.   

Offline -matteo-

  • Newbie
  • *
  • Posts: 8
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #8 on: March 20, 2017, 09:49:08 AM »
I just updated to the latest micro update, 64,and it did not fix the virtual machine problem.

The support answered me they are working for a few new fixes.
In  the meanwhile I tried to disable the feature "Enable hardware-assisted virtualization" on some notebooks and the situation seems to be better even if not perfect.
I suggest you to disable this feature...

Offline Neptune2

  • Newbie
  • *
  • Posts: 16
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #9 on: March 30, 2017, 03:56:04 PM »
We are having the same issue. Micro-update has not solved it.

Disabling Enable hardware-assisted virtualization from the settings template in the console does nothing as the client continues to have the box ticked. (After reboots and waiting days not hours)

We cannot run VM's and Avast at the same time. No solution after all these weeks??
« Last Edit: March 30, 2017, 04:01:16 PM by Neptune2 »

jburge@starplastics.com

  • Guest
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #10 on: April 05, 2017, 03:17:18 PM »
We continue to have this issue.  I opened a support ticket 1 week ago, and still have not received any update on when this will be fixed.  We are seriously considering moving on to a different endpoint protection vendor.

Offline Neptune2

  • Newbie
  • *
  • Posts: 16
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #11 on: April 24, 2017, 01:38:47 PM »
Any updates on this problem getting resolved or even being worked on? It's now been over a month and a half and still no answers.

gippslandfm@hotmail.com

  • Guest
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #12 on: May 23, 2017, 08:31:58 AM »
I'm curious to know what version of VirtualBox you have running?  I have 5.0.x and it runs just fine, but I tested a new desktop with 5.1.x and it seems sluggish, particularly to boot the guest.  The hardware is different and thought it was something to do with that until I read this thread.  I haven't tried turning off Avast hardware assisted VM yet but might give it a try or go back to 5.0.x for a while longer.  Perhaps this is also an option for you?

gippslandfm@hotmail.com

  • Guest
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #13 on: June 17, 2017, 12:22:17 PM »
I haven't tried turning off Avast hardware assisted VM yet but might give it a try or go back to 5.0.x for a while longer. 

I just disabled Hardware Assisted Visualization in the console for a test group, and my XP virtual guests under Virtualbox 5.1.18 are noticeably faster to boot and seem more responsive.  So I don't exactly know why the two products contend with each other but both the Avast and VirtualBox forums suggest using one or the other and not both for best performance.

azbycx@monumentmail.com

  • Guest
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #14 on: July 27, 2017, 12:09:35 PM »
Had been having performance issues on my VM and been playing with giving more cores and RAM etc. but with no improvement in performance.

However, after disabling H/W assisted virtualization in AVAST, I'm seeing a tremendous improvement in performance on my VMs, tremendous.

This is Horrible... Maybe Avast is trying to improve their AV but this feature has come short and they really need to revisit this.