Author Topic: How to disable "Enable hardware-assisted virtualization"  (Read 46907 times)

0 Members and 1 Guest are viewing this topic.

  • Guest
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #15 on: July 28, 2017, 03:49:13 AM »
However, after disabling H/W assisted virtualization in AVAST, I'm seeing a tremendous improvement in performance on my VMs, tremendous.

This is Horrible... Maybe Avast is trying to improve their AV but this feature has come short and they really need to revisit this.

What version of Avast do you have now?  17.5 has "nested virtualization", which in theory should solve the problems with multiple VMs.  I haven't checked that myself, so I've be curious to see if you still had issue with 17.5 with assisted (and nested) virtualization or not.

What I'd really like to see is the interactive installer checking for known VM installations like VirtualBox, VMWare etc, and giving a notice prior to installation that for performance reasons you should consider disabling H/W assisted virtualization later.  Could save people a lot of headaches who don't know about this issue.

Offline guy.rouillier

  • Newbie
  • *
  • Posts: 1
Re: How to disable "Enable hardware-assisted virtualization"
« Reply #16 on: July 16, 2019, 11:00:52 AM »
Running Avast 6.0.8 r130520 on Windows 7 Professional 64-bit.  I use VirtualBox to run VMs, and it has been working fine for years.  Then just today, trying to start my largest and most important VM would crash every time.  I ran it 2 days ago without issue.  I did some searching about "virtualbox crash", and found a link about disabling "Enable hardware-assisted virtualization" in Avast.  I did this and the problem went away.  The VM runs Ubuntu 64-bit.  I have a 64-bit AMD CPU (Opteron 4234) with hardware virtualization enabled.

I can only guess that Avast updated itself and turned on this hardware-assisted virtualization feature.  Please default this setting to OFF for existing installations.