Author Topic: Avast has been slowing my internet lately.  (Read 8529 times)

0 Members and 1 Guest are viewing this topic.

zammyfighter

  • Guest
Avast has been slowing my internet lately.
« on: July 30, 2012, 01:53:35 AM »
So whenever I look at the resource monitor, it shows that Avast is taking up a majority of the network, second to chrome.  Lately my internet has been really slow.  This got me to think that Avast is taking a majority of my bandwidth. This has resulted in me turning off the web shields.  Do you think it's okay to have web shields turned off as long as I am on safe sites like youtube/facebook?  If I ever google something and go on an unknown site, I'll turn it back on.  I really didn't want to resort to this, but it is unreasonable for Avast to scan sites like youtube/facebook.  All it does is take my bandwidth!

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47555
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast has been slowing my internet lately.
« Reply #1 on: July 30, 2012, 02:08:56 AM »
Since 85% of all infections come directly from the internet and since it's impossible to tell just by looking at a site
if it's clean or infected, turning off the Webshield is probably the last thing you should be doing. IMHO
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87064
  • No support PMs thanks
Re: Avast has been slowing my internet lately.
« Reply #2 on: July 30, 2012, 02:12:20 AM »
@ zammyfighter
What you are unfamiliar with is how avast works, when browsing your browser requests are redirected through the Web Shield (avastSvc.exe) proxy so that the http traffic can be scanned.

The web shield doesn't initiate these connections, you do via your browser, that is why you see a much reduced browser connection activity.

Turn the web shield of, nothing gets redirected, nothing gets scanned and your browser traffic goes up. The web shield is by far and away the best shield that you have as it blocks malware getting on the system to start with.

This is the biggest misconception "If I ever google something and go on an unknown site, I'll turn it back on." It isn't only unknown sites that are a risk, virtually all sites can present a risk, as the most common cause of infection on the internet is from hacked sites, even known or supposed good sites get hacked.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

zammyfighter

  • Guest
Re: Avast has been slowing my internet lately.
« Reply #3 on: July 30, 2012, 02:33:40 AM »
@ zammyfighter
What you are unfamiliar with is how avast works, when browsing your browser requests are redirected through the Web Shield (avastSvc.exe) proxy so that the http traffic can be scanned.

The web shield doesn't initiate these connections, you do via your browser, that is why you see a much reduced browser connection activity.

Turn the web shield of, nothing gets redirected, nothing gets scanned and your browser traffic goes up. The web shield is by far and away the best shield that you have as it blocks malware getting on the system to start with.

This is the biggest misconception "If I ever google something and go on an unknown site, I'll turn it back on." It isn't only unknown sites that are a risk, virtually all sites can present a risk, as the most common cause of infection on the internet is from hacked sites, even known or supposed good sites get hacked.

Then you are saying that avast doesn't have anything to do with my internet slowing down?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87064
  • No support PMs thanks
Re: Avast has been slowing my internet lately.
« Reply #4 on: July 30, 2012, 03:18:01 AM »
I haven't said anything about it slowing down internet, you were saying that avast is taking up most of your bandwidth, "This got me to think that Avast is taking a majority of my bandwidth" and this isn't the case it only looks like it is using your bandwidth, overall that would be the same if the web shield wasn't redirecting the traffic.

Because the web shield actually scans the traffic could slow it slightly and I really mean slightly. I have an average internet connection speed of around 38Mbps and I see no slowdown in normal browsing, in fact on some tests I have done my download speed is slightly quicker with the web shield enabled. Avast have said that it isn't until your broadband connection speed is of the order of 100Mbps you shouldn't see an appreciable difference.

What is your operating system and firewall ?
« Last Edit: July 30, 2012, 03:22:20 AM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

hlecter

  • Guest
Re: Avast has been slowing my internet lately.
« Reply #5 on: July 30, 2012, 03:32:08 AM »
Then you are saying that avast doesn't have anything to do with my internet slowing down?

For your info I can tell that my line which is 2mbits/s and at a very constant speed, drops to between
1.90 and 1.95 mbits/s when Webshield is on, which it btw always is.

Avast technology 'intelligent stream scanning' is scanning on the fly and in theory will give no speed
reductions at all.

If you are experiencing a major slowdown I hope the real experts can help you out. :)

zammyfighter

  • Guest
Re: Avast has been slowing my internet lately.
« Reply #6 on: July 30, 2012, 04:29:39 AM »
I use the built in windows firewall and have Vista.  I use chrome as a browser and use adblock/avast web rep. 

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 87064
  • No support PMs thanks
Re: Avast has been slowing my internet lately.
« Reply #7 on: July 30, 2012, 02:39:32 PM »
You could start with doing some tests, such as the speedtest.net shown in my image above.

Run it first with the web shield enabled, then stop the web shield (for 10 minutes), run the test again and post the results.

The Vista firewall doesn't have the outbound protection enabled by default, so shouldn't be blocking.

How long have you had avast and has it always appeared to be like this ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.10.6038 (build 22.10.7633.734) UI 1.0.733/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

jereellison

  • Guest
Re: Avast has been slowing my internet lately.
« Reply #8 on: August 02, 2012, 06:59:19 PM »
Same problem here. I ran the tests and here are my results:

With shields running: 14.65 Mbps down, and 3.21 Mbps up
With shields deactivated: 17.45 Mbps down, and 7.71 Mbps up

Now, I don't know how these compare to the standard, as I'm on a university network, but I noticed a significant change about 3-4 days ago. Avast all the sudden started attacking Steam, also, when it was trying to update last week.

REDACTED

  • Guest
Re: Avast has been slowing my internet lately.
« Reply #9 on: March 21, 2017, 12:57:01 AM »
Avast has been killing my bandwidth. I have a gigabit fiber connection and with the Firewall on and Web Shield off, I get 403Mbps down and 594Mbps up.  With firewall off and Web Shield off, it is 723Mbps down and 951Mbps up. With the Web Shield component on, it remains about the same, 708Mbps down and 949Mbps up. It shouldnt take 20% of the bandwidth.  The product seems to have become about as bad as bloatware.