Author Topic: Firewall block all local IP adress: 192.168.1.* After updating  (Read 23054 times)

0 Members and 1 Guest are viewing this topic.

Offline sycbox

  • Newbie
  • *
  • Posts: 5
Hello,

After update my Avast Premier to 17.3.2291 (build 17.3.3443.0) all local IP Adresses 192.168.1.* are blocked. Can not connect to them or to do a PING. I can't connect to my NAS and the rest of my devices.

Please Help. I don't changed anything only update. I have to deactivated the Avast Firewall to work.

OS: Windows 10 64 bits.

Thank so much.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 36692
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #1 on: March 30, 2017, 07:36:17 PM »
Any change if you try this and reboot?  >>  https://www.avast.com/faq.php?article=AVKB204#artTitle


Offline sycbox

  • Newbie
  • *
  • Posts: 5
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #2 on: March 30, 2017, 07:43:26 PM »
Thanks.

Done but nothing has changed ... The problem continue.

Offline bobinNaperville

  • Newbie
  • *
  • Posts: 6
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #3 on: March 30, 2017, 07:59:56 PM »
I'm having same issue and no fix, other than turning all the Shields off, seems to work.  I have updated to build 17.3.3443.0 with no change.

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #4 on: March 30, 2017, 08:01:43 PM »
Is it the Firewall or the Web Shield which is causing the issue?
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline sycbox

  • Newbie
  • *
  • Posts: 5
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #5 on: March 30, 2017, 08:07:16 PM »
The firewall. I can browse any public URL with no problems. It's only in the local IP 192.168.1.*

I have checked the "allow friendly net in Private" (sorry i don't know the name of this option in english) but not work too.

The range 192.168.1.0 - 192.168.1.255 is in the "Friends" option.

Thanks.

Offline bobinNaperville

  • Newbie
  • *
  • Posts: 6
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #6 on: March 30, 2017, 08:15:21 PM »
That seems to depend on the mood Avast is in. Sometimes it's one, then again next time it's both, then next time it's the other.  This was never an issue until the update of two days ago.

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #7 on: March 30, 2017, 08:27:26 PM »
Could you both run an Avast repair and report back if the issue is resolved?
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline bobinNaperville

  • Newbie
  • *
  • Posts: 6
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #8 on: March 30, 2017, 08:38:06 PM »
NO Change!

Offline catalan.ua

  • Newbie
  • *
  • Posts: 5
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #9 on: March 30, 2017, 09:04:02 PM »
Have similar issue. Avast blocks access to my router! I thought that it is a router problem and was thinking to buy a new one! I can login to my router but after few seconds it gets unresponsive.

P.S. Have to disable automatic port scan detection to make it works...
« Last Edit: March 30, 2017, 09:18:58 PM by catalan.ua »

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #10 on: March 31, 2017, 12:44:48 AM »
I've reported the issue to the Avast devs.

The firewall is not running in public mode, correct?
« Last Edit: March 31, 2017, 12:48:14 AM by Alikhan »
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline Filip Braun

  • Avast team
  • Jr. Member
  • *
  • Posts: 98
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #11 on: March 31, 2017, 11:12:00 AM »
Hello,

Can you please post in what mode is your Firewall profile (public/private) when you have the issue?
Also knowing your OS helps a lot, since there are differences in Firewall on different OSes.

However the best option to pinpoint the issue would be sending us some debug logs.
Please enable debug logging in Settings > Maintenance > Enable debug logging
And complete Firewall logging in FW component settings > Advanced > Log all blocked packets

After setting this, please reproduce the issue and send us the following logs:
"C:\ProgramData\AVAST Software\Avast\log" folder
"C:\ProgramData\AVAST Software\Avast\fw" folder
"C:\ProgramData\AVAST Software\Avast\Fw.db" file

You can then send them zipped to braun@avast.com

Thank you very much,
Filip

Offline Filip Braun

  • Avast team
  • Jr. Member
  • *
  • Posts: 98
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #12 on: March 31, 2017, 11:48:43 AM »
Alternatively, you can check Firewall logs (Firewall page > Firewall logs).
Switch to "Show log for:" Rules
And if you see a message like "Firewall has automatically blocked IP address: <IP_addres> [Port scan detection]"
It means that there was a port scan done from the <IP_address> and Firewall blocked all communications from that address for 30 mins.

Port scan protection is by default turned on, but can be turned off in Firewall settings > Advanced > Port scan detection.

Filip

Offline sycbox

  • Newbie
  • *
  • Posts: 5
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #13 on: March 31, 2017, 12:18:19 PM »
I put my OS in the first message:

FW in Private mode
OS: Windows 10 64 bits.

I will do some bug logs and will send you,braun@avast.com

Thanks

Offline sycbox

  • Newbie
  • *
  • Posts: 5
Re: Firewall block all local IP adress: 192.168.1.* After updating
« Reply #14 on: March 31, 2017, 01:13:02 PM »
I had "And if you see a message like "Firewall has automatically blocked IP address: 192.168.1.- [Port scan detection]" in the rules report.

I turned off in Firewall settings > Advanced > Port scan detection yesterday.

The problem persist.