Author Topic: ! You're vulnerable. Some shields are turned off. But what shields?  (Read 4204 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidRGreen

  • Newbie
  • *
  • Posts: 14
When I booted up my PC this morning, and if I recall, the previous morning, the tray icon had an exclamation mark and the main screen had the message; "! You're vulnerable. Some shields are turned off".

The last time I saw this message, I clicked the "Turn ON" link, and left it at that.

Now that it has happened again so soon, I looked around and found;
File Shield = ON
Web Shield = ON
Mail Shield = ON
Firewall = ON
Real Site = ON
Anti-spam = ON
Software Updater - Automatic updates = OFF

Attempting to turn it just returns the message "Online content is unavailable".
Clicking the "UPDATE" button on 2 of the 3 flagged items just resulted in "Something went wrong…try again".

Interestingly, clicking on the "Turn ON" link on the front (Status) window returns "You're Protected" and the exclamation mark goes away, but, Software Updater is still OFF.

That behaviour is indicative of inconsistency, and suggests that it was not the Software Updater status that flagged the original "You're vulnerable" message, but I have no idea what could be causing the alert status. And having an unreliable alert message may prevent a real alert condition from being paid any attention.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69307
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Repair Avast:
1. Control Panel -> Add/Remove programs -> Avast
2. Click on 'Repair'.
3. Follow instructions.
4. Reboot.
Win 8.1 [x64] - Avast PremSec 21.2.2451.Beta#2 [UI.599] - EEK - Firefox ESR 78.8 [NS/uBO/PB] - TB 78.8
Avast-Tools: Secure Browser 88.2 - Cleanup P 21.1 - SecureLine 5.9 - Driver Updater 21.1 - CCleaner 5.77
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidRGreen

  • Newbie
  • *
  • Posts: 14
A repair action and reboot has not provided a long time solution, as now 2 days later, the same problem has occurred.

I think that there is something more awry going on here.
Going through a re-installation routine every few days is not a viable solution.

Offline DavidRGreen

  • Newbie
  • *
  • Posts: 14
I have just discovered, while looking at other posts in this forum, that the "Behaviour Shield" was off.

This highlights a shortfall in the UI.
Behaviour Shield is not listed anywhere under the icons on the Protection Tab, but only visible under Settings / Components.
By the way it sounds, "Behaviour Shield" should be one of the switches visible on Protection / Antivirus. But even if that is not the case, it should be accessible somewhere on the Protection tab.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84565
  • No support PMs thanks
I have just discovered, while looking at other posts in this forum, that the "Behaviour Shield" was off.

This highlights a shortfall in the UI.
Behaviour Shield is not listed anywhere under the icons on the Protection Tab, but only visible under Settings / Components.
By the way it sounds, "Behaviour Shield" should be one of the switches visible on Protection / Antivirus. But even if that is not the case, it should be accessible somewhere on the Protection tab.

Couldn't agree more, if it is getting monitored them it should have an entry in the AvastUI > Settings > Status Monitoring section.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69307
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Couldn't agree more, if it is getting monitored them it should have an entry in the AvastUI > Settings > Status Monitoring section.
Fixed in the latest beta. Cheers.
Win 8.1 [x64] - Avast PremSec 21.2.2451.Beta#2 [UI.599] - EEK - Firefox ESR 78.8 [NS/uBO/PB] - TB 78.8
Avast-Tools: Secure Browser 88.2 - Cleanup P 21.1 - SecureLine 5.9 - Driver Updater 21.1 - CCleaner 5.77
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84565
  • No support PMs thanks
Couldn't agree more, if it is getting monitored them it should have an entry in the AvastUI > Settings > Status Monitoring section.
Fixed in the latest beta. Cheers.

Thanks for that, I haven't updated my XP system yet, the only one with avast17 installed that I use for beta testing.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69307
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
You're welcome Dave.
Win 8.1 [x64] - Avast PremSec 21.2.2451.Beta#2 [UI.599] - EEK - Firefox ESR 78.8 [NS/uBO/PB] - TB 78.8
Avast-Tools: Secure Browser 88.2 - Cleanup P 21.1 - SecureLine 5.9 - Driver Updater 21.1 - CCleaner 5.77
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Stop8

  • Jr. Member
  • **
  • Posts: 40
Don't want to hijack this thread, I went to check the status as above and while looking around I clicked Update virus definitions, I expected it to say I was up to date, but it didn't it spent a while downloading and then told me it had updated.  I thought it updated automatically when it had a connection?

Everything else looked fine.  :-\
To many years young and to old to care!

Avast Free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84565
  • No support PMs thanks
Don't want to hijack this thread, I went to check the status as above and while looking around I clicked Update virus definitions, I expected it to say I was up to date, but it didn't it spent a while downloading and then told me it had updated.  I thought it updated automatically when it had a connection?

Everything else looked fine.  :-\

Virus definition updates are automatic, what they aren't is constantly checking for an update. I believe there is a 4 hour check interval by default in the free version. If it hasn't been 4 hours since your last VPS update check then any manual update could well download a VPS update if one is available.

What is automatic are the streaming updates when VPS updates are set to automatic. When a VPS update is available, it is generally a consolidation of previous streaming updates and any not yet streamed.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline DavidRGreen

  • Newbie
  • *
  • Posts: 14
Re: ! You're vulnerable. Some shields are turned off. But what shields?
« Reply #10 on: May 21, 2017, 01:09:29 AM »
I noticed this morning, again after 2 days, that the Behaviour Shield is off again.

If it is fixed in beta, then I would certainly hope that this bug gets removed in the live versions soon.