Author Topic: Slow execution of DOS application on share  (Read 7768 times)

0 Members and 1 Guest are viewing this topic.

Hansch

  • Guest
Slow execution of DOS application on share
« on: January 23, 2006, 01:09:16 PM »
We have a problem with the speed of a DOS application run on a client from a network share. The application is written in Clipper; it is in a shared directory on a Windows 2000 SP4 server. The clients have a mapped network drive and execute the application from it.

When Avast Antivirus Server Edition is installed, the DOS application on the client is much slower. When testing a database query the following results became clear:

Without Avast on server (Avast on client or not does not make a difference):
Locally: 5 seconds / CPU 100% NTVDM
Client PC on the network: 8 seconds / CPU 100% NTVDM on client / CPU 5-15% SYSTEM on server
Network usage: 12.5%


With Avast on server:
Locally: 7 seconds / CPU 100% NTVDM
Client PC on the network: 37 seconds / CPU 100% NTVDM on client / CPU ca. 8% SYSTEM on server
Network usage: 5%

Testing systems:
Server: P2 400 MHz, 256 MB RAM, Windows 2000 Server SP4 including all updates
Client: P2 400 MHz, 256 MB RAM, Windows XP SP2 including all updates

Similar results apply when using their normal system:
Server: P3 500 MHz, 256 MB RAM, Windows 2000 Server SP4 including all updates
Client: P4 2400 MHz, 256 MB RAM, Windows XP SP2 including all updates

Different settings for the scanner, the resident shield, disabling different providers etc., including disabling the scanner altogether do not make a difference. Even stopping the Antivirus Service does not correct the problem. Just uninstalling Avast helps!

Is there a solution?
« Last Edit: January 23, 2006, 01:18:52 PM by Hansch »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11657
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Slow execution of DOS application on share
« Reply #1 on: January 23, 2006, 07:02:24 PM »
Hmm, interesting problem.
So, even stopping the "avast antivirus" service does not prevent the problem? Really strange...

Please try the following. Remove reference to avast from the following two locations:

- the file \Windows\System32\config.nt (use notepad to edit it, use the REM command to comment out a line)
- the registry key HKLM\System\CurrentControlSet\Control\VirtualDeviceDrivers, value called "VDD". It's a REG_MULTI_SZ value - so please use RegEdt32.exe instead of regular RegEdit.exe (since this is Win2K and RegEdit.exe in Win2K cannot edit this kind of value).


Then retry and let me know if it makes any difference (it definitely should).

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Hansch

  • Guest
Re: Slow execution of DOS application on share
« Reply #2 on: January 23, 2006, 08:59:27 PM »
Interesting but very annoying and time-consuming problem indeed....
I am an Avast reseller and as such, I have to provide support, which means I had to build an entire testing environment (and conduct numerous trials) so as not to keep annoying the users with constant trials on the workfloor... If I do not come up with a solution, they will probably throw out Avast and revert to some other solution which starts with K and ends with -ski... (which, by the way, did not create this kind of problem but simply costs more money). They were however pleased with the desktop/client version of Avast.

You can have this sort of problem which is very limited to this situation with every program of course. (Will Avast come up with a solution?)

I already tried deleting the Avast reference in config.nt, but this file is only loaded locally by the Windows 2000 command line when executing the program on the server - not on a client. Remember, on the clients having Avast running or not or having it installed or not did not matter.

It is a very strange problem indeed. I will try your second suggestion and report back the results.

By the way, deleting references to Avast must be a workaround - not a real solution. Still, it is interesting to find out where the problem is located.
« Last Edit: January 25, 2006, 08:32:38 AM by Hansch »

Hansch

  • Guest
Re: Slow execution of DOS application on share
« Reply #3 on: January 25, 2006, 08:32:18 AM »
NEW INFORMATION:
Deleting the key (and of course rebooting afterwards) does not make ANY difference whatsoever. The same slooooooow performance, which only gets better after completely removing Avast Server Edition.
Hopeless. I am really desillusioned and desperate....

I wonder if the Avast programmers have any idea what could cause the problem.

By the way, normal file transfer (copying files from the share to the client using Windows Explorer) through shares has the normal speed (ca. 70% of the 100 Mbit bandwidth).
« Last Edit: January 25, 2006, 08:34:24 AM by Hansch »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11657
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Slow execution of DOS application on share
« Reply #4 on: January 25, 2006, 06:27:41 PM »
So, let me recap:

- the avast! service is turned off
- the entries from config.nt and the VDD reg key are removed

and STILL, the problem happens?? :o

In this case, I can only think of one last thing. Set the "Avast Antivirus" service startup type to "Manual", restart the machine, and test it once more.

This causes the file system filter driver to stay in a completely inactive state...


BTW is the CPU usage in kernel-mode in client-mode? (task manager can show that).


Thanks (and sorry for the troubles, this is really the first time I have seen this problem)
Vlk
If at first you don't succeed, then skydiving's not for you.

Hansch

  • Guest
Re: Slow execution of DOS application on share
« Reply #5 on: January 28, 2006, 01:24:36 PM »
I have tried all the options, including the "manual startup of the Avast Service" but the only way to get the application to run its normal speed is completely removing Avast Server Edition.

Seems like voodoo to me, but it is the truth.

caii

  • Guest
Re: Slow execution of DOS application on share
« Reply #6 on: April 20, 2006, 11:04:09 AM »


Same Problem for me ... !!!

SLOW SLOW SLOW since i deployed @vast netClient on my lan

Xav