Author Topic: Avast 4.7 problems [Win2K/NT4 access rights issue]  (Read 15620 times)

0 Members and 1 Guest are viewing this topic.

solstone

  • Guest
Re: Avast 4.7 problems
« Reply #15 on: April 22, 2006, 12:50:12 AM »
I am confused about how they could have gotten messed up, but that aside I will focus on fixing this.  I am also running w2k sp4. 

To recap- I updated originally through Avast itself (and please note that I have been using Avast with no problems for at least 2 years), but as soon as it had done it, it would not work. I tried repair- no good.  I uninstalled and reinstalled from a fresh dl of the installer from Avast website- no good.  I uninstalled and re-installed Avast 4.6 from an installer found on cnet (since they are still hosting the previous version, at least as of yesterday)- worked fine.  Permissions set properly, or so it seems.  Uninstalled 4.6, reinstalled 4.7 (again, dl a fresh installer from Avast website)- no good.  Same problem every time.  Manually set permissions to match what they were in 4.6- seems to run fine.  Tech (username on this forum) says the permissions I am setting manually are unwise, but they are exactly what is installed by default under 4.6. 

Todays update- updated iAVS through Avast, and it reset file permissions in the Avast4 folder so that the program doesn't run again.  What a pain.  So I manually set them again, just for functionality at the moment. 

I don't understand how it is that my computer, and something I may have changed at some time in the past (?) would make the installer for 4.7 behave in this way, but the installer for 4.6 not.  It seems to me to be a fault in the install for 4.7. 

Jaws (and Tech and anybody else who is willing), can you look and see what permissions are set for core Avast program files (such as ashAvast.exe) on your machines.  I am curious.

Meanwhile, I suppose I may have to revert back to 4.6 again just for stability. 


rfrapp

  • Guest
Re: Avast 4.7 problems
« Reply #16 on: April 22, 2006, 08:17:31 AM »
Similar problems with Windows NT, except many less options for permissions.  4.7 seems to change them to something NT does not understand, and will not allow the program to update or run.  Changing permissions only works, as you say, until the next update.  And, I also have never messed with the permissions from the default that previous versions set.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #17 on: April 22, 2006, 04:12:45 PM »
I'll have this checked asap. Thanks for the heads up so far.. :)
If at first you don't succeed, then skydiving's not for you.

Jaws

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #18 on: April 22, 2006, 04:38:57 PM »
Settings from my w2k sp4 computer. I checked and these are the same for every folder of programs (ewido, winpatrol) on my computer. Avast 4.7 didn't seem to change permissions on my system.

Solstone, the core files have the same permissions as the folders.
________________________

Security tab for -- C:\Program Files > Alwil Software > Avast4.

***Administrators (computer name\Administrators) -- Check marks in all boxes for allow.

***CREATOR OWNER -- No check marks in any box.

***Power Users (computer name\Power Users) -- Check marks (allow) in all except Full Control.

***SYSTEM -- Check marks in all allow boxes.

***Users (computer name\Users) -- Check marks (allow) in Read & Execute, List folder contents, Read.

Check mark in box for -- Allow inheritable permissions ...
________________________

Advanced ... button

Highlight name -- Click View ... button.
***Users -- Check mark in allow for -- Traverse Folders/Execute File, List Folder/Read Data, Read Attributes, Read Extended Attributes, Read Permissions.

***Power Users -- Check mark (allow) in all except -- Delete Subfolders and Files, Change Permissions, Take Ownership.

***Administrators, ***SYSTEM, ***CREATOR OWNER, check mark in all allow boxes.

When in view mode for each named user there is no check in box for -- Apply these permissions to objects and/or containers within this container only.

HTH
Jaws

« Last Edit: April 22, 2006, 04:57:36 PM by Jaws »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #19 on: April 22, 2006, 05:31:20 PM »
Hi Jaws, yeah, these seem to be correct, and that's how they should be.

I'm wondering what might be causing the problems other users are having.
If at first you don't succeed, then skydiving's not for you.

Forejt

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #20 on: April 23, 2006, 09:36:39 AM »
Please send me setup.log from avast4\setup folder, and a log from Hijackthis.
I'll try to simulate the installation with all programs you have installed.
Here's the link to download:
http://www.merijn.org/files/hijackthis.zip

Are you logged with administrator account? Are the security settings for Program Files folder set correctly? It should be Administrator - Full Control.
« Last Edit: April 23, 2006, 09:41:21 AM by Forejt »

playj

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #21 on: April 23, 2006, 12:21:56 PM »
I have the same problem with Windows rights but i don't know how repair that ....

Can you help me ( I am french so i would an easy explication  ;) ) ?

Forejt

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #22 on: April 23, 2006, 03:56:51 PM »
If you're having the same problem, try to update program from this test build:
1)download file http://public.avast.com/~forejt/test1/servers.def
2)copy downloaded servers.def to avast4\setup folder
3)run program update

This test build contains more log entries that will help to locate problem. Please send file setup.log in avast4\setup folder to my email.

Check properties of avast4 folder->Security->Advanced and check if the box "Inherit from parent the permission entries that apply to child objects" is selected.

Thanks
« Last Edit: April 25, 2006, 11:53:32 AM by kubecj »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #23 on: April 25, 2006, 02:10:01 AM »
For anyone who's facing this problem: could you please try out a prerelease version of the upcoming update that should fix the problem? If so, just let me know.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

solstone

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #24 on: April 25, 2006, 03:03:07 AM »
Hi Vlk, I would be glad to try the prerelease version.

I had a very busy weekend (but filled with wonderful weather), so haven't been able to come back and check this thread.  Time away from the computer.  It sounds crazy, I know...  ;D
 
Thanks Jaws for taking the time to check out all the permissions and post them.

And Forejt, presumeably I should try the new version and see if it does the trick before doing what you are asking?   

Sol

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #25 on: April 25, 2006, 03:20:28 AM »
It was a lovely weekend indeed (even here in Oregon/Washington).

If everything goes alright, I'll send you an updated version tomorrow.


Thanks
vlk
If at first you don't succeed, then skydiving's not for you.

solstone

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #26 on: April 25, 2006, 03:28:22 AM »
Ok.  I will be watching for it.  Thanks.

You are in OR/WA area?  Me too.  Weekends like this last one are like the payoff for putting up with the winter months. 


gschabel

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #27 on: April 25, 2006, 04:14:23 AM »
Hi VLK and group

Running Win NT4 sp6a with all the same permission problems listed here with the 4.7 update.

Please forward a link to the new pre-release version and I will be happy to do a test run.

Many thanks

Glenn Schabel
gschabel@yahoo.com

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #28 on: April 25, 2006, 06:37:33 AM »
Quote
You are in OR/WA area?

Currently, yes. Redmond, WA. Yeah, right in the MS campus. :)

Quote
Me too. 


Really? Where? (you can put your pin on the Member map - see the button above). :)


BTW, just to recap: you have Win2K, right? The NT4 problem is pretty much clear, while the one on Win2K seems to be a bit more tricky... Therefore, we're primarily looking for people who've had the problem on Win2K.


Thanks
Vlk


« Last Edit: April 25, 2006, 06:40:29 AM by Vlk »
If at first you don't succeed, then skydiving's not for you.

Forejt

  • Guest
Re: Avast 4.7 problems [Win2K/NT4 access rights issue]
« Reply #29 on: April 25, 2006, 01:52:18 PM »
You can download and install avast! 4.6, the setup is here:
http://public.avast.com/~forejt/setupeng.exe

Then test update from 4.6 to this test version as stated in my previous post:
1)download file http://public.avast.com/~forejt/test1/servers.def
2)copy downloaded servers.def to avast4\setup folder
3)run program update

It should work on NT4, also I'd like to hear about results on Win2K.

Also you can try 4.7 setup containing the security rights fix:
http://public.avast.com/~forejt/setupeng47.exe
« Last Edit: April 25, 2006, 04:39:35 PM by Forejt »