Author Topic: MsMpEng.exe very high CPU and Memory usage  (Read 1175 times)

0 Members and 1 Guest are viewing this topic.

Offline namanhpro1990

  • Newbie
  • *
  • Posts: 1
  • Vu Quynh Chi
    • https://windows10freeapps.com/
MsMpEng.exe very high CPU and Memory usage
« on: August 29, 2017, 04:49:07 AM »
Hello!
I am using Windows 10 Pro. I have get Antimalware Service Executable high CPU usage on my machine. I tried using Avast Free Antivirus to kill MsMpEng.exe, but it did not work. I still see random RAM usage spikes, to upwards of 1/1.5 GB's, which will then drop the the normal memory usage. However, when the memory drops, the CPU usage starts to go up, very slowly, until it reaches 100%.
Could anyone give me a hand here?

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31483
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: MsMpEng.exe very high CPU and Memory usage
« Reply #1 on: August 29, 2017, 07:45:22 AM »
And what has this got to do with SecureLine ?

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 79195
  • No support PMs thanks
Re: MsMpEng.exe very high CPU and Memory usage
« Reply #2 on: August 29, 2017, 10:13:19 AM »
I don't know how you are trying to get avast to kill it as that isn't a function of avast, it is looking for malware. When you install avast (or any other AV), windows 10 should disable the Windows Defender function, not avast.

Check out some of the search hits on that file name, https://search.yahoo.com/search?p=MsMpEng.exe.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 17.8.2318/ Outpost Firewall Pro9.3/ Firefox 52.5.2 ESR, uBlock Origin, RequestPolicy/ MailWasher Pro7.8.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline thuonghoaianh1989uk

  • Newbie
  • *
  • Posts: 1
Re: MsMpEng.exe very high CPU and Memory usage
« Reply #3 on: October 22, 2017, 05:06:33 PM »
Turning off Windows Defender can help fix this problem.

1. Open the Local Group Policy Editor.
2. Go to the following path: Computer Configuration > Administrative Templates > Windows Components > Windows Defender
3. Find the setting named Turn off Windows Defender and double click it.
4. Select the Enabled option to disable Windows Defender.

This tutorial helps you: https://windowsfreeapps.com/antimalware-service-executable-high-cpu-usage-msmpeng-exe-problem-windows-10/