Author Topic: System State Backups broken on Windows 2012 R2 ?  (Read 5542 times)

0 Members and 1 Guest are viewing this topic.

Offline GFM

  • Sr. Member
  • ****
  • Posts: 208
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #15 on: September 06, 2017, 07:27:00 AM »
Its a real pain. I have got Avast on about 15-20 servers currently.
Are all your servers 2012 R2 or this affects other server versions you have too?  I assumed it was just a 2012 R2 issue given the low priority Avast have put on the bug.

Offline TetraSteve

  • Newbie
  • *
  • Posts: 5
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #16 on: September 12, 2017, 01:03:17 PM »
Are all your servers 2012 R2 or this affects other server versions you have too?  I assumed it was just a 2012 R2 issue given the low priority Avast have put on the bug.

I have got the issue with Server 2016, Server 2012r2, Server2012.  I had contact from Avast last Tuesday/Wednesday but nothing since.

Steve

Offline Дмитрий114

  • Newbie
  • *
  • Posts: 5
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #17 on: September 15, 2017, 05:41:02 PM »
i have the same problem on 2008 r2, 2012r2 and 2016 servers. Is there any stable workaround?
« Last Edit: September 15, 2017, 05:48:47 PM by Дмитрий114 »

Offline GFM

  • Sr. Member
  • ****
  • Posts: 208
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #18 on: September 18, 2017, 08:54:17 AM »
i have the same problem on 2008 r2, 2012r2 and 2016 servers. Is there any stable workaround?

No, there is no official workaround, however downgrading to v12 works for me.  Please log this fault with Avast support so that they prioritize this bug fix.  The more reports they get the faster they will fix it, or so they tell me  :-X 
« Last Edit: September 18, 2017, 08:59:44 AM by GFM »

Offline Дмитрий114

  • Newbie
  • *
  • Posts: 5
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #19 on: September 19, 2017, 10:25:46 AM »
This works (with disable selfprotection) for now at least


Code: [Select]
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\aswRvrt]
"ImagePath"="system32\\drivers\\aswRvrt.sys"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\aswVmm]
"ImagePath"="system32\\drivers\\aswVmm.sys"

Offline GFM

  • Sr. Member
  • ****
  • Posts: 208
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #20 on: September 19, 2017, 01:02:54 PM »
Yes it works, but it's a risky unsupported fix and could render a server unbootable if done improperly  :)  Doing a product upgrade might also fail later on because of the changes and leave the server in a worse state.   Thats the reason I chose not to do it on my server.  So do take care and have a good alternate backup and recovery plan if this is a critical server.

Offline Дмитрий114

  • Newbie
  • *
  • Posts: 5
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #21 on: September 21, 2017, 09:09:03 AM »
Quote
The developers have identified the cause of the issue in the installer configuration and should be releasing a corrected installer as part of our next major update patch, or the major update patch after next. You shouldn't experience this issue again for this system unless you re-install the AV. Please let me know if these registry entries revert back to the broken path again.

I got this, it looks like allmost the same as you get) Lets see, what happens next version.

Offline TetraSteve

  • Newbie
  • *
  • Posts: 5
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #22 on: October 05, 2017, 01:59:20 PM »
Does anyone know what is going on with this?

I havent had any update from Avast support for 3 weeks.

The way its going I will end up moving Anti-Virus software.

Offline GFM

  • Sr. Member
  • ****
  • Posts: 208
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #23 on: October 21, 2017, 03:07:20 AM »
I just tried 17.7.2526 today; same problem on my test VM.  Can anyone else confirm?

Very disappointing that a company with data security as it's core will consciously allow this problem to continue 6 months later.  System State is an OS core feature, also with the aim of data security.  It's not like it's a 3rd party backup Avast can blame. 

I too will be shopping around for another vendor, but first I might post something and see what happens in the https://forum.avast.com/index.php?board=15.0 Beta board since the cloud beta board is dead.

Offline GFM

  • Sr. Member
  • ****
  • Posts: 208
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #24 on: October 25, 2017, 12:52:50 AM »
Please follow topic https://forum.avast.com/index.php?topic=210048.0
Looks like the target for the fix is 17.8
Exciting!  ;D

Offline Maxi IBC

  • Newbie
  • *
  • Posts: 3
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #25 on: October 25, 2017, 05:35:35 PM »
Perfect. I will wait for that version.

Thank you.

Maxi

Offline TetraSteve

  • Newbie
  • *
  • Posts: 5
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #26 on: November 29, 2017, 02:02:11 PM »
Its look the new version 7.8 has sorted the issue.


Offline GFM

  • Sr. Member
  • ****
  • Posts: 208
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #27 on: November 30, 2017, 02:05:53 PM »
Yes I can confirm my Test VM is able to complete a System State backup now with Avast v17.8

Looking forward to finally installing to my Production host!

Offline misak

  • Avast team
  • Sr. Member
  • *
  • Posts: 218
    • Personal page (CZE)
Re: System State Backups broken on Windows 2012 R2 ?
« Reply #28 on: December 07, 2017, 03:16:54 PM »
Perfect. Glad to hear it!