Author Topic: Mail protection doesn't work  (Read 11708 times)

0 Members and 1 Guest are viewing this topic.

Offline rexmale

  • Jr. Member
  • **
  • Posts: 21
Re: Mail protection doesn't work
« Reply #30 on: June 01, 2006, 05:10:55 AM »
Is it possible to scan the email if I use winsock or Ms Proxy?

Offline rexmale

  • Jr. Member
  • **
  • Posts: 21
Re: Mail protection doesn't work
« Reply #31 on: June 05, 2006, 04:39:38 AM »
Is it possible to scan the email if I use winsock or Ms Proxy?
I think it is not possible in the current version. Thanks anyway

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83800
  • No support PMs thanks
Re: Mail protection doesn't work
« Reply #32 on: June 05, 2006, 03:02:15 PM »
The Internet Mail provider monitors ports 25 (SMTP), 110 (POP3), 119 (NNTP), 143 (IMAP) and is expecting those protocols to be used, windsock as far as I'm aware is a connection TCP/IP means not an email program/protocol. MS Proxy if as its name suggests is a proxy, perhaps if the port it uses is added to the redirect ports (but still uses the above protocols) then perhaps it might work.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.598) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline rexmale

  • Jr. Member
  • **
  • Posts: 21
Re: Mail protection doesn't work
« Reply #33 on: June 07, 2006, 04:06:42 AM »
If my internet connection use winsock, then how to set avast to scan my email?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83800
  • No support PMs thanks
Re: Mail protection doesn't work
« Reply #34 on: June 07, 2006, 02:23:20 PM »
It is not the type of connection but the protocol used to transfer the email.

What email program do you use ?
What ports are used to send and receive email ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.598) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline rexmale

  • Jr. Member
  • **
  • Posts: 21
Re: Mail protection doesn't work
« Reply #35 on: June 08, 2006, 09:54:40 AM »
It is not the type of connection but the protocol used to transfer the email.

What email program do you use ?
What ports are used to send and receive email ?
My email is OE and Pegasus with normal ports 110 and 25.
When I use winsock from the proxy to connect to internet the avast does not scan my incoming or outgoing email.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83800
  • No support PMs thanks
Re: Mail protection doesn't work
« Reply #36 on: June 08, 2006, 04:57:20 PM »
What proxy ports does MSProxy use, sorry I haven't the faintest what it does. What is it you are using MSProxy for ?

You need to add the proxy port (which is ?) to the avast redirect ports or bring MSProxy into line so it works with the avast transparent proxy, required to be able to scan emails before they arrive in the inbox. If MSProxy is doing a similar task, e.g. also redirects the email ports.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.598) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline rexmale

  • Jr. Member
  • **
  • Posts: 21
Re: Mail protection doesn't work
« Reply #37 on: June 09, 2006, 10:08:50 AM »
What proxy ports does MSProxy use, sorry I haven't the faintest what it does. What is it you are using MSProxy for ?

You need to add the proxy port (which is ?) to the avast redirect ports or bring MSProxy into line so it works with the avast transparent proxy, required to be able to scan emails before they arrive in the inbox. If MSProxy is doing a similar task, e.g. also redirects the email ports.
Yes MSProxy that bundled with the MS NT 4.0 server, but I do not the ports that used by MSProxy.

Regards,
Yudi

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83800
  • No support PMs thanks
Re: Mail protection doesn't work
« Reply #38 on: June 09, 2006, 03:36:07 PM »
Sorry as I said I'm totally in the dark on MSProxy and more so on the MS NT4 Server.

Though I tried to find out a little more about it using google but I didn't find much that gave me an idea of what it id and how it worked or how it might have an impact on the Internet Mail provider of avast.

http://www.microsoft.com/isaserver/evaluation/previousversions/default.mspx
Quote
Proxy Server 2.0

Microsoft Proxy Server has been discontinued. But you can still find detailed product information, downloads, and support options that will help you get the most out of your Proxy Server installation. You can also move to ISA Server. ISA Server goes far beyond Proxy Server by delivering a full-featured enterprise firewall and a high performance Web cache server.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.598) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro