Author Topic: * Introducing * - a very short beta of upcoming avast update - now 4.7.840  (Read 22942 times)

0 Members and 1 Guest are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
This thread is now obsolete - the new version has already been released, as 4.7.844.

Thanks.



Hi *,

this is already becoming a tradition. :) As usual, we're offering our forum members to test drive the upcoming avast update before it is official released.

How to install it (for starters - most people already know this trick anyway ): simply download and run the following program: http://files.avast.com/files/beta/aswbeta.exe . That's about all it takes (provided you have the latest version of avast Home/Pro already installed, of course).


This is a minor release, and doesn't bring any new big features. It should fix couple of bugs that were discovered since the last official update (such as incorrect display of non-Latin characters in avast tasks - although in some special cases, a reinstall of the program may be necessary to completely solve the problem). Also, we have added an AsProtect unpacker in this release (quite an interesting change) - so I'd like to ask everyone who installs this version to run a full on-demand scan of all your drives (with unpacking enabled) and report any respective problems (stalls, crashes etc).

Also, this build adds Danish language pack - so if there's anyone who speaks Danish here, it would be very helpful if he/she could install it and report any typos, grammatical errors etc (this applies to the program and the help files as well).


Thanks
Vlk
« Last Edit: May 31, 2006, 06:52:47 PM by Vlk »
If at first you don't succeed, then skydiving's not for you.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11763
    • AVAST Software
Two of the changes mentioned by Vlk (the Danish language pack and the ASProtect unpacker) are in the state of "being polished" - so they'll be slightly improved within the next few days.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
No comments at all...? ;D
If at first you don't succeed, then skydiving's not for you.

Offline drahnier

  • Full Member
  • ***
  • Posts: 173
No comments at all...? ;D

ok, at least one:

have installed this build on two of my laptops. on both machines avast insisted to have the computer restarted two times.

and: on both machines the blue avast icon in system tray stopped spinning after the update. at firs ti thought this was indication non running providers, but avast control panel indicates that all providers are running smoothly and the "Last scanned: ..." item and "Scanned Count" is changing over time.
_____________________
drahnier

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
So, you restarted the machine after the update completed, and when the machine booted, you were prompted to restart again?

If so, please send me the file <avast>\setup\setup.log from such a machine...


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline drahnier

  • Full Member
  • ***
  • Posts: 173
So, you restarted the machine after the update completed, and when the machine booted, you were prompted to restart again?

If so, please send me the file <avast>\setup\setup.log from such a machine...


Thanks
Vlk

yes, when the machine rebooted, after login, avast asked me to restart the machine once again.

i did send setup logfile to you by email.

any idceas why the tray icon isn't spinning any more ("Animate the icon ..." in settings is checked)?
« Last Edit: May 23, 2006, 11:35:21 AM by drahnier »
_____________________
drahnier

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
No comments at all...? ;D
Can you give us a list of 'tests' to perform?

P.S. Just one reboot after its installation.
The best things in life are free.

Offline XMAS

  • Avast translator
  • Super Poster
  • ***
  • Posts: 1211
  • Santa is watching you ;)
    • avast! in Bulgarian
No comments at all...? ;D
Well installed it without a problems, only one reboot was required.
Also I run a full system scan(unpacking was enabled) and everything went fine - no errors  :)
You've Got To Get Close To The Flame To See What It's Made Of...

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9346
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
I'm on KAV6 Beta atm, so i'll have to skip this one :-[
Visit my webpage Angry Sheep Blog

Offline drahnier

  • Full Member
  • ***
  • Posts: 173
I have since re-installed avast on one of my two laptops showing the before mentioned strange upgrade behavior.

After I de-installed avast and rebooted, Windows Security Center still reported avast 4.7.838 as installed and virus database information as up-to-date. Funny. I double checked but no avast component was left on the system (no services, no nothing). Maybe this was because I used the stand-alone deinstaller (aswclear).

Before re-installing avast, I removed some avast relarted entries from the registry and deleted avast installation folders to start as clean as possible. While the newly installed version 4.7.827 could be painlessly updated to version 4.7.738 and only one reboot was necessary, I noticed that security settings on the installation folders are still pretty weak (yes, we're talking Windows XP here): While group Users had "Read&Execute, Read" permission on files on folder DATA, group Everyone had "Full Control". E. g. file avast.ini had User:Read&Exe and Everyone:FullControl. This does result in a plain FullControl for any user which might not be what is intended (or desireable). Other folders had a plain Everyone:FullControl ... - I would prefer much thighter security settings here.
_____________________
drahnier

Offline Daffy

  • Jr. Member
  • **
  • Posts: 70
Hurray!!!
Avast in Danish.

I have the beta up and running. No problems so far. Only that the avast seems to start up a little later than before. When my screen opens, I was used to see
the icon spinning, indicating that avast was running. Now it starts whit a icon whit the red circle, and then starts whit in 10 sek.

Haven't tried a scan yet. But I have some corrections to the translating.

1. when start up the "memory and startup test"  translation is to long. "Stands hukkomelsest" is what I can see, but in fact there is missing 3 letters. it should say " stands hukkomelsestest" but there isn't room enough. And it look stupid. ;D
I suggest something shorter, like " stands test "

2. In settings > confirms > you missed a line.  " ask before deliting files from chest " is not translated.
Could be something like " spørg før sletning af filer i viruskiste."

Thats it for now. I will now go fore the big scan.
See you later.

Offline Daffy

  • Jr. Member
  • **
  • Posts: 70
Question???

Unpacker enabled. Where do I find that checkbox.

Offline Daffy

  • Jr. Member
  • **
  • Posts: 70
I missed one error in translation.

In settings > confirms, the "subheadline" says " Fjern markeringer udfor bekræftelses-spørgsmålene.....and so on."

I am 99.99% sure that udfor is in two words. " ud for"

But only 99.99% :)

Offline Daffy

  • Jr. Member
  • **
  • Posts: 70
Ok. The GUI in " On-access beskyttelseskontrol" has a lot off errors in translation.

If you want me to, I can check it out, but for now I will wait for the improvement.

Where do I find the unpacker box.????

Offline mauserme

  • Massive Poster
  • ****
  • Posts: 2475
Installation on 3 computers at work went fine with only a single re-boot required.

One has finished scanning with no errors.  Will post again when the others finish.


EDIT:

run a full on-demand scan of all your drives (with unpacking enabled)

Vlk,

I should have asked this before - do you mean just the default formats or should we enable all formats in a task window?

M



Edit #2:  All scanned without any probelms based on the default formats.
« Last Edit: May 23, 2006, 09:45:16 PM by mauserme »
"If at first you don't succeed keep on sucking 'till you do succeed" - Curley Howard in Movie Maniacs (1935)